Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Only part of .RTF file is placing into my InDesign document

New Here ,
Jan 20, 2021 Jan 20, 2021

Copy link to clipboard

Copied

For some reason my .RTF file is only partially placing into my inDesign file. More than half the text isn't flowing into the inDesign document. I tried placing a number of other .RTF files with the same import settings, and they managed to flow into the InDesign Doc in full, so I think the issue might be with the .RTF/ word doc I'm using. I tried copying all the text and resaving it as a new .RTF file, but it didn't work. I've also cleaned all my Adobe cache and preference cache, and uninstalled/ reinstalled Adobe inDesign. I can't seem to figure out the issue. 

 

When I open up the Story Editor, it shows that the text is there, but overset. Still, when I click the red plus sign to flow the remaining (overset) text into the next text box on the next page, nothing flows in. Any ideas what's going on here? I'm attaching an image of the text in Story Editor view and in the document view, below, in case anyone can see something I can't! Note there are a lot of footnotes, but again I haven't experienced this issue using my workflow in the past. I'm saving my Word doc as an .RTF file as that has been recommended in other threads. When I try flowing the word doc in, the text still ends at the same point. 

 

My computer should definitely have enough RAM/ memory etc. to handle the file as I've done this workflow multiple times without probem. It's an iMac with a 3.6 GHz Intel Core i9 Processor, 64 GB memory 2667 MHz DDR4, and a Radeon Pro 575X 4 GB  graphics card. I'm working on the newest version of InDesign -- 16.0.2 and haven't had issues with it before. 

 

Any help would be much appreciated! 

TOPICS
Bug, How to, Import and export, Type

Views

238

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jan 21, 2021 Jan 21, 2021
I would try to cut the footnotes 43 from your word document. Save your word as a copy and then try to placed it in indesign. You could cut the footnote 43 from InDesign's story editor too. Then if the text flows you could reinsert the footnote 43. The footnote 43 has a very long link and maybe InDesign can't hyphenate it.

Likes

Translate

Translate
Adobe Community Professional ,
Jan 20, 2021 Jan 20, 2021

Copy link to clipboard

Copied

Have you tried placing a Word file? I see few advantages in choosing an RTF file to a Word file.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 20, 2021 Jan 20, 2021

Copy link to clipboard

Copied

Yes, tried the Word file as well. They both cut off at the same point in the InDesign doc. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 20, 2021 Jan 20, 2021

Copy link to clipboard

Copied

It sounds like the file is damaged. Any way to have it recreated?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 20, 2021 Jan 20, 2021

Copy link to clipboard

Copied

The word doc or the InDesign doc? I tried copying and pasting all the text from the Microsoft Word doc into a new word doc, and exporting that, but I had the same issue. Any other suggestions? 

And as far as the InDesign doc goes, I tried importing into multiple versions of my template, the .rtf always cuts off at the same spot. Do you know what this vertical line might indicate from the story editor view? This is where it's cutting off, and I'm not sure what that vertical line in the story view are intended to mean, but might help me troubleshoot Screen Shot 2021-01-20 at 6.20.40 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 20, 2021 Jan 20, 2021

Copy link to clipboard

Copied

It sounds like a corrupted file. 

 

InDesign has a method for dealing with corruption which often works (saving as IDML) and reopening.  There may be methods of dealing with Word corruption, but you're more likely to find it in Microsoft Word foums, and not here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 20, 2021 Jan 20, 2021

Copy link to clipboard

Copied

I tried the IDML option, it didn't work. The microsoft word file is not corrupt, and even if it were, I have already done the necessary copy/ paste/ save into new document to resolve any possible corruption on that front. There is something about the way my InDesign document is reading the word/ .rtf file. Any alternate troubleshooting ideas? And do you know what the vertical line means? The problem is that overset text will not flow into my text boxes. I can see it's in the document because it's present in the story editor, but I can't see it in my text boxes. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 21, 2021 Jan 21, 2021

Copy link to clipboard

Copied

I would try to cut the footnotes 43 from your word document. Save your word as a copy and then try to placed it in indesign.

You could cut the footnote 43 from InDesign's story editor too.

Then if the text flows you could reinsert the footnote 43.

The footnote 43 has a very long link and maybe InDesign can't hyphenate it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 07, 2021 May 07, 2021

Copy link to clipboard

Copied

LATEST

Vladan, that's it.

The very long link InDesign is not able to hyphenate.

Therefore further text composition cannot take place in the text frame.

 

I marked your answer as the correct one.

 

How to correct this?
One could try to apply language [No Language] so that the long URL can break without a hyphen where necessary.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines