• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Paragraph styles constantly needing to be "cleared"

Participant ,
Oct 21, 2022 Oct 21, 2022

Copy link to clipboard

Copied

Hi all! Recently, perhaps after a update, when I import text from Word, almost invariably when I apply a paragraph style, I have to click on it in the Style palette and clear character styles (see Ckear Character.jpg below and attached).

 

Clear Character Styles.jpg

I've set up Basic to match the main font of the book (in this case Montserrat Regular—it's an unusual book, don't ask), but the Word doc still imports in Calibri, which I edit the Word files in. Then I apply Normal, say, and I still have to clear the character styles (see Basic paragraph.jpg below and attached).

 

Basic paragraph.jpg

It seems no matter what style I apply this happens, and I'm quite frustrated, as typesetting is taking my twice as long as usual for having to touch every paragraph.

 

Any ideas? 

TOPICS
Bug , Type

Views

94

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Expert , Oct 21, 2022 Oct 21, 2022

Hmmm. Lot's going on here.

 

First of all, Normal is Word's default style. It's fine to use it in Word, but I recommend creating a new base style in InDesign (not [Basic Paragraph], and based on [No Paragraph Style]) and map Normal to that style. You can do that as you place the Word doc if you enable Import Options. The feature is called style mapping. 

https://creativepro.com/solving-word-workflow-problems-with-style-mapping/

 

If you have inline formatting like bold and italics used to emphas

...

Likes

Translate

Translate
Participant , Oct 29, 2022 Oct 29, 2022

Thanks Eugene, didn't know about the signature. 

The solution turned out to be the Character Style I had selected when I imported (Normal, which was set to Monserrat Regular) was making everything Regular and not responsive to applying the different Paragraph Styles. When I changed the Character Style to None prior to importing, I could apply Paragraph Styles and they worked fine. So, easy fix, but I wouldn't have realized it if I hadn't read the various responses.

So thank you all!

 

 

Likes

Translate

Translate
Community Expert ,
Oct 21, 2022 Oct 21, 2022

Copy link to clipboard

Copied

Hmmm. Lot's going on here.

 

First of all, Normal is Word's default style. It's fine to use it in Word, but I recommend creating a new base style in InDesign (not [Basic Paragraph], and based on [No Paragraph Style]) and map Normal to that style. You can do that as you place the Word doc if you enable Import Options. The feature is called style mapping. 

https://creativepro.com/solving-word-workflow-problems-with-style-mapping/

 

If you have inline formatting like bold and italics used to emphasize words within a paragraph, use Find/Change to find them and replace them with an appropriate character style. For example, find italics and change it to a character style defined as italics. Repeat for the other inline formatting. 

 

Next, turn on the Style Highlighter to highlight anything with overrides. It's the + button at the top right of the Paragraph and Character Styles panel. Now you can clearly see what overrides are left. Save your work, select all and then click the Clear Overrides in Selection (it's the ¶* button at the bottom right of the Paragraph styles panel). That should put you in pretty good shape to continue.

 

If not, let us know.

 

~Barb

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 21, 2022 Oct 21, 2022

Copy link to clipboard

Copied

I had variations of this happening a little while back, and there was some useful discussion. The details elude me at the moment, but — are you using the full import menu, with the styles specifically mapped? Or just relying on a one-to-one name match? Word is such a PITA in this manner, applying all kinds of default overrides in its fiendish desire to maintain total control. (Also, PS as Barb noted, avoid using Normal as an import style. Define your own and that will help bypass many of these problems. "Never Use Default Styles.")

 

Also remember the Clear Overrides button at the bottom of the Paragraph Styles pane... that was pointed out to me last time and can be a huge time saver.

 

JamesGiffordNitroPress_0-1666380305297.png

 

 


| Word & InDesign to Kindle & EPUB: a Pro Guide (Amazon)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 21, 2022 Oct 21, 2022

Copy link to clipboard

Copied

@Barb Binder  & @James Gifford—NitroPress have given amazing advice.

 

I'll just add my tid-bit.

I use a script called PrepText 
Link here https://creativepro.com/downloads/preptext.zip

 

When I import the word document I'll use this script - which generates the Character Styles throughout the document.

If you already have styles - you can delete the created ones and replace them with the ones currently in the document.
I find - folders help with this - keep your created styles in a folder for safe keeping, just a suggestion.

 

Then when you've mapped all the text on import - run the script.

I usually select all - and hit the Clear Overrides. 

 

Now all the text should be very clean bare perhaps the oddity here and there- but for me that is rare.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 22, 2022 Oct 22, 2022

Copy link to clipboard

Copied

Hi Barb, James, and Eugene:

Thank you all for your responses to my question. I'm going to try these
tips and will get back to you as to whether they work. I so appreciate the
community's help.

Susan

--

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 22, 2022 Oct 22, 2022

Copy link to clipboard

Copied

No prob. Let us know how you get on.

 

If you're reply by email can you please remove your signature.

 

I've edited your last post to remove your personal info.

 

Take care

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 29, 2022 Oct 29, 2022

Copy link to clipboard

Copied

Thanks Eugene, didn't know about the signature. 

The solution turned out to be the Character Style I had selected when I imported (Normal, which was set to Monserrat Regular) was making everything Regular and not responsive to applying the different Paragraph Styles. When I changed the Character Style to None prior to importing, I could apply Paragraph Styles and they worked fine. So, easy fix, but I wouldn't have realized it if I hadn't read the various responses.

So thank you all!

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 30, 2022 Oct 30, 2022

Copy link to clipboard

Copied

LATEST

Thanks for clarifying what happened - let us know if you need anything else at all. It's a great community of InDesign users here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines