Photoshop file with spot channel placed into InDesign, turn off 4C

Guide ,
Oct 15, 2018 Oct 15, 2018

Copy link to clipboard

Copied

Is there a way to place the spot color only from a 5 channel .psd file into InDesign? Normally I would just place a grayscale tiff and color it in InDesign.

I do not want anything but the spot channel to appear in the exported PDF.

Views

1.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Oct 15, 2018 Oct 15, 2018
with the 4C content appearing as white
You should be able to do that.Here's a CMYK + Spot Channel .PSD with the CMYK channels filled with whiteShowing the spot channel:Placed in ID:Hiding the Spot channel shows the CMYK channels are white:

Likes

Translate

Translate
Adobe Community Professional ,
Oct 15, 2018 Oct 15, 2018

Copy link to clipboard

Copied

PDFs with spot colors always include the CMYK plates along with the spot colors. The best you can do is set up an InDesign preflight rule that flags any use of the CMYK plates. The only case where you don't get CMYK plates in the exported PDF is with an export to a gray profile (which produces a single black plate PDF), but that would also convert the spot colors to grayscale.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Oct 15, 2018 Oct 15, 2018

Copy link to clipboard

Copied

OK, so there is no way to place a 5C .psd into InDesign as a spot color only. Saving it as a grayscale and coloring in InDesign is the only option?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 15, 2018 Oct 15, 2018

Copy link to clipboard

Copied

No, you can place a .psd with a spot channel and the spot channel should show as a spot color in Separation Preview. The color mode of the .psd can be anything, i.e., you can have an empty grayscale with the spot channel.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Oct 15, 2018 Oct 15, 2018

Copy link to clipboard

Copied

I must be missing something. I can place the 5C .psd, but cannot turn off the 4C.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 15, 2018 Oct 15, 2018

Copy link to clipboard

Copied

That's right, you can't delete the CMYK channels. The Separation Preview always has the CMYK plates plus whatever spot color swatches you create. You can use preflight to confirm that the CMYK or CMY plates are empty. At output your printer can turn off the CMYK plates from either the ID or Acrobat print dialog.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Oct 15, 2018 Oct 15, 2018

Copy link to clipboard

Copied

Thanks for confirming. This is going to a digital printer printing a spot color only for the image and 4C for other areas.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 15, 2018 Oct 15, 2018

Copy link to clipboard

Copied

So you should be able to place the 5-color psd and use Separation Preview to confirm the contents of the spot and CMYK plates via the panel's eyeball icons

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Oct 15, 2018 Oct 15, 2018

Copy link to clipboard

Copied

Yes, The 5C content appears in InDesign, but I need the spot color only, (with the 4C content appearing as white), which I can only achieve using a grayscale tiff colored in InDesign. I could delete the 4C content in Photoshop, but would prefer to use one file for both the 4C and 1C content, which appears to be not possible.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 15, 2018 Oct 15, 2018

Copy link to clipboard

Copied

with the 4C content appearing as white

You should be able to do that.

Here's a CMYK + Spot Channel .PSD with the CMYK channels filled with white

Screen Shot 6.png

Showing the spot channel:

Screen Shot 7.png

Placed in ID:

Screen Shot 10.png

Hiding the Spot channel shows the CMYK channels are white:

Screen Shot 9.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Oct 15, 2018 Oct 15, 2018

Copy link to clipboard

Copied

I appreciate your efforts to clarify, and realize I'm not being very clear. I was hoping to use a single .psd file that would appear as a normal 4C image and also as a 1C spot color on the same InDesign page (in different places), similar to using object layer options with .ai or .pdf

Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Dec 04, 2021 Dec 04, 2021

Copy link to clipboard

Copied

Im getting this error color space issue in Indesign trying to place a PSD with spot channels. Doesnt make sense to me? I cant print using separation neither from photoshop. I tried saving image out as a PDF from photoshop, but i only get 5 save file formats in save as?! This is really weird?

Using photoshop 22.5 on windowscolor-space-error-psd-spotchannels.pngfew-saveing-options-psd-spotchannels.png

 

EDIT
Well not sure what went wrong. I can use save copy and then PDF does show. But i think save as should also show these options. Still had the same color space issue when i saved the file as TIF. That kinda useless since it renames the spot channels to something else. Kinda weird we need to save separate channels like this old skool thing. Why isnt this possible to to in 2021?!

 

EDIT 2

Well Indsign seems to have big issues with PDF with spot channles. Weird, on OSX this works fine. I now saved it out as PSD PDF and now get a bleed box error in Indesign.

saved-psd-pdf-bleedbox-isse.png

Edit took a bit of time. But glad i kept researching it. The issue was having spot channels with the same name as one of the default channel names. This issue is in both RGB and CMYK files. As soon as you names it different the file is red properly. Though i find it weird it tells its a color space issue, while its a color spot channel issue!

SPOT-CHANNEL-CMYK-ISSUE-SOLVED.jpgSPOT-CHANNEL-RGB-ISSUE-SOLVED.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 04, 2021 Dec 04, 2021

Copy link to clipboard

Copied

From my testing, it appears that the spot colors need to be legitimate colors in Photoshop and InDesign libraries Not discussing the channel name, but the selected spot color.

 

For example, my old example files use the original Pantone colors and would not work in InDesign. I changed the colors to Pantone+ and they worked fine. 

David Creamer
Adobe Certified Instructor, Adobe Certified Professional, and Adobe Certified Expert (since 1995)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 05, 2021 Dec 05, 2021

Copy link to clipboard

Copied

Hi @Creamer Training , IIf you wanted to use a legacy CMYK defined Pantone Color, add the legacy swatch in InDesign before placing the PSD with the same named spot:

 

Screen Shot 19.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 05, 2021 Dec 05, 2021

Copy link to clipboard

Copied

Thanks, Rob--I understand that. I was just pointing out the files will not work without the libraries installed. Since so few people are using the old libraries, I just mentioned the workaround for the installed libraries. 

David Creamer
Adobe Certified Instructor, Adobe Certified Professional, and Adobe Certified Expert (since 1995)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Dec 06, 2021 Dec 06, 2021

Copy link to clipboard

Copied

I got it working after some more "investigating", as soon as you have duplicate names like black, red, magenta etc. Then it will return this errors. As long as the names are unique it works. It also still works when using rgb or cmyk values, they didnt specifically need to be PMS colors.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 05, 2021 Dec 05, 2021

Copy link to clipboard

Copied

Hi @schroef , You can’t name Spot Channels Black, Cyan, Magenta, or Yellow. In your capture the Black Spot Channel is causing the unsupported color message.

 

Also, use of Red, Green, or Blue would cause this messsage:

 

Screen Shot 13.png

 

If you give the spot color a custom name and don’t use a book value (e.g., a Pantone Solid Ink) it will display as gray unless you create the spot color with the same name in InDesign first:

 

Screen Shot 14.png

Screen Shot 16.pngScreen Shot 17.png

 

Here I’ve created MyGreen in InDesign before placing the PSD:

 

Screen Shot 18.png

 

 

 

You don’t have to save as PDF, PSD with legal Spot Channel names should work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Dec 06, 2021 Dec 06, 2021

Copy link to clipboard

Copied

Yes, i had figured that part a bit later as well. Yet i didnt get that error you show, yours shows exactly what the issue was. Kinda weird my Indesign showed a different error.

 

After some more fiddling i noticed the issue was having not unique names and we cant use default channel names neither

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Dec 06, 2021 Dec 06, 2021

Copy link to clipboard

Copied

I did get colors though, there is an option to show spot channels as colors vs greys.

show as colros custom rgb spot colorshow as colros custom rgb spot colorshow as colros custom rgb spot colorshow as colros custom rgb spot color

 

Here's the spot channel setup in photoshop

Spot channel using no PMS inkSpot channel using no PMS ink

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 07, 2021 Dec 07, 2021

Copy link to clipboard

Copied

You could still use the Black CMYK channel. I don’t think you gain anything by Saving As Photoshop PDF, here I’m placing a PSD image file:

 

Screen Shot 2.pngScreen Shot 4.png

 

Also I’m not sure if it matters but in your InDesign capture where you are sampling the red, the Magenta and Yellow separations are being used—100% Red + 95% Magenta + 100% Yellow

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Dec 07, 2021 Dec 07, 2021

Copy link to clipboard

Copied

LATEST

That about still magenta being doesnt matter. This was just a test file where i tried getting plates. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 05, 2021 Dec 05, 2021

Copy link to clipboard

Copied

EDIT 2...The issue was having spot channels with the same name as one of the default channel names....Though i find it weird it tells its a color space issue, while its a color spot channel issue!

 

Sorry, I missed your Edit 2—I see you figured out the naming conflict.

 

It might be worth noting that the Color Space of a spot color is defined as Separation, ColorName and not CMYK, RGB, or Lab. The Black name is reserved for the CMYK space, and a spot color is always a solid ink separation and would never have a Black or CMY ink component. Acrobat’s Object Inspector:

 

Screen Shot 21.png

 

 

now get a bleed box error in Indesign

 

Photoshop documents don’t have a bleed option, so when you save a Photoshop PDF there is no way to include a Bleed Box the way there is from InDesign. If you check Show Import Options when you Place a Photoshop PDF, the Bleed Crop To: Option will be grayed out (the Crop To: option is sticky so that’s probably why you are getting the error message):

 

Photoshop

Screen Shot 20.png

 

InDesign

Screen Shot 20.pngScreen Shot 22.png

 

Screen Shot 20.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Dec 06, 2021 Dec 06, 2021

Copy link to clipboard

Copied

Well i guess i didnt see that bleed option greyed out, as i was relinking it to an already placed PSD file. If i had placed it as a new linked file, then i would have seen that

 

Thanks for posting it out and showing it like this!

 

EDIT
I tried it again using the same file, but now placed as a new linked file. Then it does work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 04, 2021 Dec 04, 2021

Copy link to clipboard

Copied

I haven't played with spot color channels in ages--brings back memories!

Try a multi-channel file in Photoshop.

image.png

InDesign will not import a multi-channel PSD file. You get the following error:

image.png

Going back to my QuarkXPress days, I saved the file in the DCS 2.0 format. 

image.png

I was able to place it in InDesign, but the preview did not show up until I turned on Separations (Overprint Preview)

I then printed to the Adobe PDF driver to test the separations:

image.png

The PDF (separation) only contained the spot color channels:

image.png

BTW,  I tried a grayscale with spot color channels and separated it. Got a blank black plate, but most printers can disable output on that plate.

 

Ask where the old way is, where the good way is, and walk on it. 

David Creamer
Adobe Certified Instructor, Adobe Certified Professional, and Adobe Certified Expert (since 1995)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines