Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Popup when I open a file telling me I have missing fonts....not popping up

Community Beginner ,
Aug 10, 2021 Aug 10, 2021

Copy link to clipboard

Copied

Not sure what I dismissed or option I changed, but suddenly when I open a file that has missing fonts I no longer get the popup allowing me to substitute them.

 

I don't really want to go through 200+ instances of changing each instance, and no unfortuanately they did not use character styles. (I already have the fonts, just not the OFT versions - they are all differing weights of Roboto, or Roboto Condensed).

 

Does anyone know where the check box is that I need to check again so it pops up each time I open a file like this?

TOPICS
Import and export

Views

51

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Aug 10, 2021 Aug 10, 2021
I don't know why the pop-up is gone, but you can access the Find/Replace Font dialog from the Type Menu

Likes

Translate

Translate
Adobe Community Professional ,
Aug 10, 2021 Aug 10, 2021

Copy link to clipboard

Copied

I don't know why the pop-up is gone, but you can access the Find/Replace Font dialog from the Type Menu

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 10, 2021 Aug 10, 2021

Copy link to clipboard

Copied

Thanks. that will do just fine. Didn't realise it was located there!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 10, 2021 Aug 10, 2021

Copy link to clipboard

Copied

Hi WESTMAC Marketing,

if the document is using the Roboto OTF fonts from the Adobe Fonts service you have to supply the OTF fonts!

And not font files from e.g. Google fonts that come as *.ttf font files even if you see no difference in glyph shapes or hyphenation. If you do not do this you risk changes in the position of the first baseline of the text in text frames. We already had that case here in the forum…

 

And also make sure that there is no Roboto font file placed in a Document fonts folder or the Fonts folder of the InDesign Application folder or manually installed in the system…

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 10, 2021 Aug 10, 2021

Copy link to clipboard

Copied

When my collegue opens the file it's making it switch from TT fonts, when I open it, it is making me switch it from OTF fonts. I really don't mind which one we have, we have both creative cloud and we have bought a license for Roboto.

 

I'm not sure why it conflicts, but yes it's annoying even with substituting them some documents require me to change fix the baselines in ext frames. I don't really care which version I use, just want them the same on both computers, and need o make sure they can be used in other applications like Word, Excel and Outlook.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 10, 2021 Aug 10, 2021

Copy link to clipboard

Copied

If you have the say on this best provide or install font files instead of activating fonts from the Adobe Fonts service.

Install the otf font files all over the place. Install them for All Users when on Windows which requires admin rights, I think. Or provide them with the Document fonts folder. But do not do both.

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 11, 2021 Aug 11, 2021

Copy link to clipboard

Copied

I've unsynched on both machines with Roboto on Adobe Fonts, but we were still getting the same problem: OTF on hers and TTF on mine (our purchased Roboto files are all .ttf).

 

Over night and a reboot later it has stopped doing it and it works for both of us now. Thanks for the all the info.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 11, 2021 Aug 11, 2021

Copy link to clipboard

Copied

LATEST

Well, "a reboot later" are the magic words, I think…

 

I noticed that I had to restart InDesign to make sure the font management does the right thing in a different case with a missing font that was also missing in a placed SVG file. Before that restart I had a perfect text rendering with the font on the page but at the same time a missing font warning with the usual pink bar behind the text:

 

NoAccessToFont-EvenWhenInstalledFor-AllUsers.JPG

 

Weird, isn't it? A restart of InDesign cleared all this:

When-all-is-well-INDD-OPEN-01.jpg

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 10, 2021 Aug 10, 2021

Copy link to clipboard

Copied

You can reset the warning in the prefs. It's a button at the bottom of the General panel...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 11, 2021 Aug 11, 2021

Copy link to clipboard

Copied

Perfect. Thank you. That fixed it....and then a litte later is stopped popping up again. Not to worry though, I have missing fonts set to be highlighted (plus I'm always checking preflight before exporting) and now I know where the option is to replace them, all is golden.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines