• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Problem with Text Wrap (unwanted space between image and text)

Explorer ,
Jun 03, 2024 Jun 03, 2024

Copy link to clipboard

Copied

Hello there. I've got a problem with the Text Wrap option. You can see an example in the screen. I have an image with this option (text up and down) and I set some margins. Problem is, I can't have the same space between the texts and the image. The text above the image is perfectly attached to the margin, but the text below the image is not. How can I solve? Thanks.

TOPICS
Type

Views

170

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Expert , Jun 03, 2024 Jun 03, 2024

The four fields in the Text Wrap panel let you set different margins for the four sides. You need to unclick the Lock so you can set them individually.

 

Screenshot 2024-06-03 at 12.01.22 PM.png

Votes

Translate

Translate
Community Expert , Jun 03, 2024 Jun 03, 2024

"but InDesign keeps keeping a space between the lower text and the margin..."

This is going to sound weird but this is actually normal behaviour. Text line spacing is based on the leading of the line, and this affects your wraps. The difference for the top line (only) in your text frame is that it uses a different calculation based on your Baseline Option for the text frame (which is likely Ascent, which crops off the leading up to the top of the type).

If you changed your Baseline Option to lea

...

Votes

Translate

Translate
Community Expert ,
Jun 03, 2024 Jun 03, 2024

Copy link to clipboard

Copied

You didn't include your screenshot. However, it sounds very much like you want to disable 'skip by leading' in the Preferences:

PeterKahrel_0-1717441230431.png

If that doesn't fix the problem, please do show your screenshot.

 

P.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 03, 2024 Jun 03, 2024

Copy link to clipboard

Copied

The four fields in the Text Wrap panel let you set different margins for the four sides. You need to unclick the Lock so you can set them individually.

 

Screenshot 2024-06-03 at 12.01.22 PM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 03, 2024 Jun 03, 2024

Copy link to clipboard

Copied

Thank you everyone! 

 

@Peter Kahrel sorry I forgot to attach the image, I've just done it. Reguarding the option, I disabled it and the text moved further up towards the margin, but it didn't stick to the margin like the upper text...

 

It's strange. I can move the image everywhere and make the upper text stick perfectly to the margin, but InDesign keeps keeping a space between the lower text and the margin...

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 03, 2024 Jun 03, 2024

Copy link to clipboard

Copied

"but InDesign keeps keeping a space between the lower text and the margin..."

This is going to sound weird but this is actually normal behaviour. Text line spacing is based on the leading of the line, and this affects your wraps. The difference for the top line (only) in your text frame is that it uses a different calculation based on your Baseline Option for the text frame (which is likely Ascent, which crops off the leading up to the top of the type).

If you changed your Baseline Option to leading, you'd see exactly the same effect. As far as I know ID has yet to implement the ability to do the same calculation to text below a wrap.

Your option then is to reduce your bottom wrap dimension as mentioned by others on the thread.

Screen Shot 2024-06-03 at 3.07.03 PM.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 03, 2024 Jun 03, 2024

Copy link to clipboard

Copied

LATEST

Oh my God I didn't think about it... You saved me! And now that I think of it, @Steve Werner had given me the hint... I was stoned guys lol... never mind. Perfect solution. A big thank to all of you.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 03, 2024 Jun 03, 2024

Copy link to clipboard

Copied

In that case the problem may be that the text is aligned to the baseline grid. Undo that to see whether it makes any difference. It could then be that the text doesn't make it to the bottom of the text frame. If the text should make it to the bottom of the text frame then you should move the image until the space above and below is the same. Or crop the image a bit. The best would be to move the image to the top of the page (or the bottom).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 03, 2024 Jun 03, 2024

Copy link to clipboard

Copied

Thanks a lot but it seems that option is already ok. I checked the
paragraph panel and is set to "not align to the baseline grid".

It seems that a real fix doesn't exist after all... I'll have to make do.
Thanks everyone anyway.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines