Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Remove auto generated hyperlink in interactivePDF

Community Beginner ,
Nov 05, 2021 Nov 05, 2021

Copy link to clipboard

Copied

Hi,

Im trying to export a document as interactivePdf

I have some urls in this document and dont want to put hyperlink to that! but they get hyperlink after export automaticly!

is there a removeHyperlink or something like that?

TOPICS
Scripting

Views

56

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 05, 2021 Nov 05, 2021

Copy link to clipboard

Copied

Acrobat, by default, will autogenerate hyperlinks. You can turn it off in Acrobat's preferences.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 05, 2021 Nov 05, 2021

Copy link to clipboard

Copied

Thanks @BobLevine, but im using indesign/indesign script

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Nov 05, 2021 Nov 05, 2021

Copy link to clipboard

Copied

Hi @Mesmaili, so they are already hyperlinks? Do they appear in the Hyperlinks panel? If so, you can remove them from there.

Or are you saying that Indesign is turning them into hyperlinks only when you export them as interactive pdf? If so, I think @BobLevine's comment is correct. I think what he means that the pdf reader app you are using (Acrobat for example) is deciding to make them into hyperlinks as a "convenience". I don't think there's anything you can do in Indesign to fix that, but I might be wrong. You might be able to turn off that feature of your pdf ready app, but of course that means that every reader of your pdf will have to deal with their own pdf reader's settings.

Just a wild idea: what if you insert, say, zero-width-spaces into the url text before exporting? That might fool Acrobat into thinking they aren't URLs.

- Mark

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 05, 2021 Nov 05, 2021

Copy link to clipboard

Copied

Zero-width spaces is the "trick" I'd use.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 05, 2021 Nov 05, 2021

Copy link to clipboard

Copied

@m1b @BobLevine 

I tried it with chrome, edge, adobe acrobat also

let tell you more about it.

the big problem is here, my URL is multiple line, and also it generate link automaticly!

when you put your URL in 2 lines, just your first line can get the hyperlink and also its wrong cause it make content of first line as hyperlink for first line also,

for example:

https://community.adobe.com/t5/inde- 

sign-discussions
and now just the first line has a wrong link! ( https://community.adobe.com/t5/inde-  = https://community.adobe.com/t5/inde-  )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Nov 05, 2021 Nov 05, 2021

Copy link to clipboard

Copied

LATEST

Try this: do a find and replace grep in your document and replace "http" with "h\x{200B}ttp". This will slot a zero-width space after the "h" and might achieve what you want. If it doesn't try putting the zero-width-space somewhere else in the url. Of course if your URLs are a different protocol than "http", then just put the space in there, eg. "f\x{200B}tp".

- Mark

 

Note: \x{...} is how to enter unicode characters into indesign find/replace grep feature. 200B is the unicode number for zero-width space.

Screen Shot 2021-11-06 at 7.48.34 am.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines