Remove Hyperlinks permanently in CS6

Community Beginner ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

Hello,

 

Is there any script which removes all the hyperlinks from Indesign document. I am trying to remove them the conventional way, but the hyperlinks still show as active in the PDF document once exported.

 

Thanks

Rajat

TOPICS
Scripting

Views

438

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Community Professional , Jun 07, 2021 Jun 07, 2021
Perhaps you mixed ExtendScript with an ActionScript method to show the result? Instead of trace() use a simple alert(). Regards, Uwe Laubender ( ACP )

Likes

Translate

Translate
Adobe Community Professional , Jun 07, 2021 Jun 07, 2021
Add a hair space in the middle of the URL. That should break them up.

Likes

Translate

Translate
Adobe Community Professional ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

Are you sure they're not being auto-generated by Acrobat or Reader (or even some third party PDF reader)?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

Thanks for your response. Yes, it is not auto-generated in Acrobat. I removed it from Indesign, but once the PDF is opened in Adobe Acrobat and I hover mouse over that text, it shows me the address of the link, like mailto:

 

So, I want that to appear as normal text.

 

Regards

Rajat

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

Hello,

Take a look at the post below for a possible solution.....

https://community.adobe.com/t5/indesign/remove-hyperlinks-from-an-indesign-document/td-p/3200475

 

Regards,

Mike

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

Thanks Mike, I reviewed this link. However, being a begineer in Indesign, I do not know how to use scripts or make it. So, no success here as well.

 

Regards

Rajat

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

Hello,

 

Copy the code from the first link I sent you, paste the code in TextEdit (Mac) Notepad (PC) make the format plain text and save the script file with the file extension .jsx. The link below will guide you on how to load it into Indesign.

https://creativepro.com/how-to-install-scripts-in-indesign/

 

Regards,

Mike

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

Yes, I tried the same and got the following error message.

WhatsApp Image 2021-06-07 at 15.35.30.jpeg

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

Hi Rajat0101,

if your original script code is using method trace() as in your screenshot with the error message you ran the wrong code.

trace() is no command with ExtendScript. Could be with Flash's ActionScript:

https://www.oreilly.com/library/view/actionscript-the-definitive/1565928520/re241.html

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

Perhaps you mixed ExtendScript with an ActionScript method to show the result?

Instead of trace() use a simple alert().

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

Many Thanks, it did removed the hyperlinks in the Indesign. However, when I exported it and opened the PDF in Adobe Acrobat, the same text is still showing as active link, when the moused is hovered over. 

 

Can you please advise if this is something related to Adobe Acrobat.

 

Regards

Rajat

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

Go back to my original response. Acrobat auto detects these URLs. It can be turned off in your preferences.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

Bob, I now understand your first reply, but by changing the preferences it only makes the document system specific. What if, the other user accessing that file on his system does not have the same preferences.

 

I wanted to know if there is any concrete method is available, and it does not show at all.

Regards

Rajat

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

Add a hair space in the middle of the URL. That should break them up.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

LATEST

Bob, adding hair space has proved to be the game changer as of now.

 

Thank You.

Rajat

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines