• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

RTL text with bullets on right

New Here ,
Feb 13, 2024 Feb 13, 2024

Copy link to clipboard

Copied

As the subject suggests, I'm having difficulty getting bullets on the right side of the page while working with the Arabic language.

 

Some things I've done:

  • Changed default install language to English with RTL support. I have tried both of these options, and I have tried closing/reopening InDesign between each attempt
    Joe35432376xeuy_1-1707845639405.pngJoe35432376xeuy_2-1707845659809.png

     

     

  • I've set the paragraph to be RTL.
    Joe35432376xeuy_3-1707845838721.png

     

  • In the Bullets and Numbering window, I set the Alignment to right. Setting it to center or left doesn't seem to do much of anything.
    Joe35432376xeuy_4-1707845863429.png

     

  • I have paragraph styles set up from the English version of this book, I have tried setting the paragraph styles. I have also tried manually setting this up through the paragraph.

 

This might be complicated by the fact I'm copying/pasting from Microsoft Word.

 

Here is how the bullets are displaying in InDesign 

Joe35432376xeuy_5-1707847022097.png

compared to how it is in Word

Joe35432376xeuy_6-1707847048715.png

 

with the punctuation on the left.

 

What am I doing wrong here?

TOPICS
How to , Type

Views

126

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Feb 15, 2024 Feb 15, 2024

Well, looking at your post-paste close-up, it really looks like your paragraph composer is set to Adobe Paragraph Composer. What happens when you select your bulleted text and set it to the World-Ready Composer? There are numerous ways to do so, but if you are already using a localization of InDesign with RTL tools, the easiest thing to do would be, after pasting in your Arabic bullets, to go to the Type menu and choose" Apply World-Ready Composers".

Votes

Translate

Translate
Community Expert ,
Feb 13, 2024 Feb 13, 2024

Copy link to clipboard

Copied

Have you updated InDesign to 19.2? It is supposed to fix a list of issues with RTL languages.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 13, 2024 Feb 13, 2024

Copy link to clipboard

Copied

Just checked, I am currently on 19.2

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 13, 2024 Feb 13, 2024

Copy link to clipboard

Copied

This might be complicated by the fact I'm copying/pasting from Microsoft Word.

 

[...]

 

What am I doing wrong here?

 

My guess that you have formatting coming along with your text copied from Word. There is a setting in InDesign that controls this: Edit -> Preferences -> Clipboard Handling -> When Pasting Text and Tables From Other Applications -> Text Only.  I suspect that you currently have it set to "All Information" and some of that information is formatting from Word that is overriding or conflicting with your careful setup in InDesign. If you are pasting your Arabic text into a paragraph in InDesign with a paragraph style with RTL behavior set up, then I'd suggest that you look at the Paragraph Styles panel after pasting. I suspect that you'll find overrrides that came in with your pasted text. 

 

The better way to handle this, of course, is to not copy and paste from Word. Placing the Word document with File -> Place is a much safer way of getting your complex-script text into InDesign. In the unlikely event that your Word doc has well-applied paragraph styles, you can map those styles onto your InDesign styles when placing the document. But, since so few Word users style their documents carefully, you may not be able to use that method. 

 

When I need to be able to paste raw text sometimes, and styled text at other times (an awful workflow that I never suggest, but sometimes it's the least bad option), I usually use a little free utility called PureText that lets me set up a shortcut to "sanitize" the clipboard.  So if I copy rich text from Word with Control-C, I then whack Control-Win-C, which causes the rich text on the clipboard to be turned into raw text, which I can then paste into InDesign, which then of course inherits the styling of the paragraph I'm pasting into. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 15, 2024 Feb 15, 2024

Copy link to clipboard

Copied

Thank you very much for this response. I checked clipboard handling, it was already on Text only. I tried all information to test it out, but didn't see any change, so it's currently set to Text only.

 

I tried placing the word document, really hoping this would fix it. I just can't figure out why it's doing this, but all of the characters are backwards, essentially the same as how I've been pasting it. Here's a segment of the placed Word document:

Joe35432376xeuy_0-1708013301301.png


and the same section of the word document:

Joe35432376xeuy_1-1708013359150.png

I'm by no means even a novice in the language, but I can see the characters are just coming in the wrong order.

 

I did check to make sure, and RTL was selected by default in the placed document.

 

At this point, I'm thinking it's an issue with the copy/paste function of Windows, so I'll try that utility out next.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 15, 2024 Feb 15, 2024

Copy link to clipboard

Copied

Well, looking at your post-paste close-up, it really looks like your paragraph composer is set to Adobe Paragraph Composer. What happens when you select your bulleted text and set it to the World-Ready Composer? There are numerous ways to do so, but if you are already using a localization of InDesign with RTL tools, the easiest thing to do would be, after pasting in your Arabic bullets, to go to the Type menu and choose" Apply World-Ready Composers".

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 16, 2024 Feb 16, 2024

Copy link to clipboard

Copied

This seemed to do it. Thank you so much.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 15, 2024 Feb 15, 2024

Copy link to clipboard

Copied

Did you choose one of the World Composer in the Paragraph Styles?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 16, 2024 Feb 16, 2024

Copy link to clipboard

Copied

LATEST

I hadn't, and this seems like this was the issue. Thank you.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines