• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Rule Above is showing double line

Community Beginner ,
Apr 11, 2024 Apr 11, 2024

Copy link to clipboard

Copied

Hello, 
I've been searching for an answer for a couple hours and cannot find why my rule above in paragrah style is showing a double line. 
Does anyone know how I can get a single line? 
I have tried both text width and column width, but it remains the same.
(Image of double line issue and of paragraph rule settings)
Thank you! 
Screenshot 2024-04-11 at 5.11.05 PM.pngScreenshot 2024-04-11 at 5.11.34 PM.png

TOPICS
How to

Views

96

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 11, 2024 Apr 11, 2024

Copy link to clipboard

Copied

It looks as if the line you want is the separator line above footnotes. This is managed in the Footnote Options menu and has nothing to do with (direct) paragraph styling. I'm not even sure your applied line style is causing the second line here, as it is set to "Text" width and is matching the defined footnote separator.

 

Turn off ALL paragraph rules for these styles, and pop into Type | Document Footnote Options | Layout to adjust that separator.

 

JamesGiffordNitroPress_0-1712881433404.png

 


╟ Word & InDesign to Kindle & EPUB: a Guide to Pro Results (Amazon) ╢

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 11, 2024 Apr 11, 2024

Copy link to clipboard

Copied

Thank you, James! I was trying to manually do this because inserting the footnote added text space above. I didn't realize I could edit this and control how I wanted it to appear. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 11, 2024 Apr 11, 2024

Copy link to clipboard

Copied

Almost every design or layout element in ID has a very powerful, flexible formatting and configuration menu one or two clicks away. You don't have to manually format most common elements like footnotes or lists, just configure them correctly.


╟ Word & InDesign to Kindle & EPUB: a Guide to Pro Results (Amazon) ╢

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 11, 2024 Apr 11, 2024

Copy link to clipboard

Copied

I also notice that even though you have "Text" selected in your width field that the rules are not adhering to the maximum width of the text which should be the case since the left and right indents are both set to zero. What happens if you pull down the "Type:" menu and change the style to one of the other options? If you change it back to single line does your problem persist? Is this happening in just a single file or does it happen with all files? If it's just this file try exporting it as an IDML (File>Export>InDesign Markup (IDML)) and then opening that file with your version of InDesign. This process can clear up some corruption in a file. If it is happening with all documents then try resetting your InDesign preferences.

To do so:

For Macintosh Users: The User Library folder in which InDesign’s preferences are stored is hidden by default on most Macintoshes. To access it make sure that InDesign is closed and click on the desktop to launch a Finder Window (Command-N). With this window in column view follow the path User>Home folder (it’s the folder with an icon that looks like a house—it may have the user’s name rather than “Home”) and click on the Home folder. With the Option Key pressed choose Library from the Finder Go Menu. “Library” will now appear within the Home folder. Within the Library folder find the folder called Preferences and within it find the folder called “Adobe InDesign” and the file called “com.adobe.InDesign.plist” and delete both that folder and that file. When InDesign is next launched it will create new preference files and the program will be restored to its defaults.

For Windows Users: You can try the quick way of resetting on a PC which is to hold down Ctrl + Alt + Shift when launching InDesign and respond affirmatively when asked if you want to reset. There have been some recent reports that the window asking if you want to reset is not popping up but that the prefs are being reset anyway. If this works great but if it doesn’t you may have to manually delete them.

To do so: On Windows 7 and above the preference files are hidden. To find them go to the Control Panel and open Folder Options and then click the View tab. Then select “Show hidden files and folders” or “Show hidden files, folders or drive options” in Advanced Settings. Then delete (or rename) the folder at the end of this path: C:\Users\<USER>\AppData\Roaming\Adobe\InDesign\<Version #>\<Language>. Make sure that InDesign is closed when you do this. When you relaunch the program it will create new preference files and the program will be at its default settings.

The advantage of manually deleting preference files is that after you’ve reset up the program (make sure that no document window is open) to your liking, you can create copies of your personalized “mint” preference files (make sure that you quit the program before copying them—that finalizes your customization) and use them in the future to replace any corrupt versions you may need to delete.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 11, 2024 Apr 11, 2024

Copy link to clipboard

Copied

Thank you, Bill! 
I was searching for how to make rule line above a fixed width and came across a work-around answer. The solution was to create a custom stroke and choose that in the paragrah rule settings. But it still doesn't explain the double line. Maybe the file is corrupt, like you suggest. I will try that out and see if it clears up the corruptedness. 
Screenshot 2024-04-11 at 5.34.27 PM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 11, 2024 Apr 11, 2024

Copy link to clipboard

Copied

I think it may have more to do with a battle between paragraph rule formatting fighting with the special conditions of footnote formatting. If you strip the Footnote text style down to basics, and set up the separator line correctly, the oddity should go away.


╟ Word & InDesign to Kindle & EPUB: a Guide to Pro Results (Amazon) ╢

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 11, 2024 Apr 11, 2024

Copy link to clipboard

Copied

LATEST

Thank you James, I agree. Working on learning how to set up the footnotes to my liking. I appreciate your time! 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines