Slow performance on Indesign v16.3.2 on M1 Macbook Air on macOS v11.4 Big Sur - Spinning Beach ball

Explorer ,
Jul 19, 2021 Jul 19, 2021

Copy link to clipboard

Copied

Hi, from time to time the spinning wheel comes out in Indesign. New preferences and GPU on or off, it's the same. Very annoying.
Guido

 

Macbook Air 2020

M1

Big Sur 11.4

Indesign 16.3.2

 

 

{Renamed by MOD}

TOPICS
Performance

Views

3.3K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Aug 05, 2021 Aug 05, 2021

At the end I switched out the Creative Cloud App and everything got working correctly. After a few days of joy I'm going to switch it on again since I need fonts, shared projects etc.
I'll keep you informed.

 

Likes

Translate

Translate
Adobe Community Professional ,
Jul 19, 2021 Jul 19, 2021

Copy link to clipboard

Copied

There are a number of things inside and outside of InDesign that might cause slowdowns like that. For example, If you have Preflight active, when that "spinning wheel" seems to appear for no reason, look at the status bar (at the bottom of the editing window) for the Preflight status. If it indicates "Checking..." it could be the cause, especially if your document is particularly long or complex. For that reason, I prefer to work with active Preflight turned off (it's on by default), and run Preflight as a dedicated task when warranted.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 19, 2021 Jul 19, 2021

Copy link to clipboard

Copied

Thank you John, I'll give a try.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 19, 2021 Jul 19, 2021

Copy link to clipboard

Copied

That's a new feature--Adobe is trying to tell you are working too hard. You need to step away from the computer for a while and go out and smell the roses...

 

Seriously, what is the RAM on the system? How much available space do you have on the drive? How large is the document and does it have a lot of graphics? Is the document in high-quality or overprint preview?

David Creamer
Adobe Certified Instructor, Adobe Certified Professional, and Adobe Certified Expert

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 20, 2021 Jul 20, 2021

Copy link to clipboard

Copied

Many thanks to Adobe that take cares of my freetime! 😉

My mac has 8 gigabyte Ram, disk is an SSD with 300 free space, typical view is in use, documents (they are several) are normal documents, overprint is off. I never had this issue with Intel machines (also with lower specs), looks like if the the problem is M1 processor.

Anyway, it's getting better with "Preflight off", the spinning wheel shows up from time to time, but just for one second or two.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 20, 2021 Jul 20, 2021

Copy link to clipboard

Copied

Are you using the new M1 version of ID? 

If so, it's probably going to take a few updates to work out any "issues".

David Creamer
Adobe Certified Instructor, Adobe Certified Professional, and Adobe Certified Expert

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 23, 2021 Jul 23, 2021

Copy link to clipboard

Copied

Yes, but the intel version of indesign was even worse.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 20, 2021 Jul 20, 2021

Copy link to clipboard

Copied

Hi there,

 

Sorry about the trouble, and thanks for sharing the details.  Could you please share a few more details:

  • Does it happen while working on a specific document? If yes, could you please share that document with us? You can upload it to the Creative Cloud (https://helpx.adobe.com/in/creative-cloud/help/share.html) and share the download link.
  • Where are you saving the files (Network Drive/ System HDD/ Shared Folder on System / External HDD)?
  • When did this start happening? Are there any recent changes made to your system? For example, any antivirus, system updates, or web extensions installed recently.

 

You may try the steps shared on this page (https://community.adobe.com/t5/indesign/resolve-slow-performance-and-unexpected-behavior-of-indesign... ) and share your observations with us.

 

Looking forward to your response.

 

Thanks & Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 23, 2021 Jul 23, 2021

Copy link to clipboard

Copied

Its getting better with preflight-off option.

But it still appens from time to time, it comes out with different docs, all files are saved on Mac hard disk with a lot of free space, no changes made to the system, it was the same with previous version of indesign software (intel).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 03, 2021 Aug 03, 2021

Copy link to clipboard

Copied

Hi there,

 

I would like to know if you are still facing slow performance issues. If yes, Does turning off Automatic Graphics Switching from Macbook settings (Both Battery and Power adapter) helps to resolve the issue? (https://support.apple.com/en-us/HT202043)

Also, are you using TimeMachine? If yes, please try disabling it as multiple users have reported that TimeMachine has slowed down some apps while they were working.

 

I will be looking forward to your reply.

 

Thanks & Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 05, 2021 Aug 05, 2021

Copy link to clipboard

Copied

At the end I switched out the Creative Cloud App and everything got working correctly. After a few days of joy I'm going to switch it on again since I need fonts, shared projects etc.
I'll keep you informed.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 12, 2021 Aug 12, 2021

Copy link to clipboard

Copied

Glad to hear that you resolved the issue. Please feel free to reach out if you run into any other questions or issues in the future. We'd be happy to help.

Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 14, 2021 Dec 14, 2021

Copy link to clipboard

Copied

Hi,

What did you switch it out for? What does switched out mean?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 24, 2021 Jul 24, 2021

Copy link to clipboard

Copied

Are you using High Quality Display? Large images can cause slow downs in this view mode. In many cases you can work with Typical Display to work faster. You can change it in View > Display Performance. This only affects how things look on screen and does not affect output quality.


— Adobe Certified Expert & Instructor at Noble Desktop | Web Developer, Designer, InDesign Scriptor

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 27, 2021 Jul 27, 2021

Copy link to clipboard

Copied

No, I'm not using high quality dispaly option.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 02, 2021 Sep 02, 2021

Copy link to clipboard

Copied

I get the Beachball all the time in Indesign 16.4 

I am using a Mac Mini M1 

16 GB 

1 TB Drive with 170 GB Free 

(DropBox ON) 

 

High Quality Display 

Preflight ON 

Overprint Preview NOT on

My document is a storyboard so each page has an Illustrator Link with vector illustrations
And each page has threaded text boxes holding the script. 

Following advice here I have gone to typical display level and that seems to improve it so far. 
It's a pity as the main incentive for upgrading and maxing out my machine was to be able to work faster and handle these kind of simple scenarios more easily. 

 

Is what I am doing so much more complex that a multitrack music production or layers and layers of 6K video? 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 02, 2021 Sep 02, 2021

Copy link to clipboard

Copied

Hi David, these the options that worked for me:
1) switch off "preflight"

2) switch out the main Creative Cloud Application (from the finder bar), restart mac, re-enter the application.

Hope it helps

Guido

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 18, 2021 Oct 18, 2021

Copy link to clipboard

Copied

Oh my god turning off the "Preflight" just saved me so much anguish w/ that damn spinning wheel of death.  Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 14, 2021 Dec 14, 2021

Copy link to clipboard

Copied

By switch out do you mean sign out, switch off? Re-enter - does that mean 'sign in again'?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 07, 2021 Dec 07, 2021

Copy link to clipboard

Copied

I upgraded to Monterey and my 2020 Mack book runs better than it ever did. No more beach balls. Also now using v 17.01 Indesign. I was going to return my Mac but it's been great now. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 22, 2021 Dec 22, 2021

Copy link to clipboard

Copied

Experiencing the same beach ball headache. Incredibly frustrating.

 

2020 iMac 1 TB SSD drive (400 GIGs free)

Mac OS Monterey 12.1

Indesign 17.0.1

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 04, 2022 Jan 04, 2022

Copy link to clipboard

Copied

I have this problem too and it's not because of the Creative Cloud App because I never have it running. When I last used InDesign in July 2021 with my M1 MacBook Pro, it was the smoothest experience ever. This was before v. 17.0.1 and before Monterey.

 

Now, in January 2022, I'm using InDesign again and I constantly get the beach ball. This is incredibly frustrating!

 

MacBook Pro M1

macOS Monterey 12.0.1

16GB RAM

500GB free disk space

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 05, 2022 Jan 05, 2022

Copy link to clipboard

Copied

Hi @brabner & @olivierb10194581,

 

Sorry to hear about the trouble you are facing. I would request you to share a few more details like:

  • Does this happen while working on a specific document? If yes, could you please share the document with us? You can upload it to the Creative Cloud (https://helpx.adobe.com/in/creative-cloud/help/share.html) and share the download link.
  • Where are the files and links saved (Network Drive/ System HDD/ Shared Folder on System/ External HDD)?
  • When did this start happening? Are there any recent changes made to your system? For example, any antivirus, system updates, plugins, or web extensions installed recently.
  • Please check if turning off the internet help resolve the issue?
  • Are you using TimeMachine? If yes, please check if turning it off/ disabling it help resolve the issue?
  • Please open the Creative Cloud Desktop app and sign out, then close it and check if that helps?
  • Please check if turning off preflight  (Window > Output > Preflight > Deselect the checkbox) help resolve the issue?
         Anshul_Saini_0-1641411132885.png
  • Please try different Display options (View > Display Performance) in InDesign. I recommended working on Typical Display.
  • Please try turning off GPU performance from InDesign preferences (cmd + k > GPU Performance > uncheck GPU Performance and see if that helps?

 

I will be looking forward to your response.

 

Thanks & Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 05, 2022 Jan 05, 2022

Copy link to clipboard

Copied

It is really unsustainable to recommend "switching off internet access" inthis day and age when it is required to work. I use Google Drive linked daily for client projects and can't work with internet off. InDesign 2022 has been insanely slow for me - version 17.0.1 and I am on a Macbook Air M1 - Big Sur 11.6.2. It happens with every document, and happens ALL the time when trying to do anything, even if very simple. I have already tried:

 

- turning off Preflight

- uninstalling/reinstalling

- turning off GPU performance

- don't have any third party plugins

- on Typical Display ption

- Signed out of Creative Cloud app

- they are saved on an SSD

- no changes to my network

- no time machine

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 06, 2022 Jan 06, 2022

Copy link to clipboard

Copied

Thanks for sharing the details. I totally agree with you that switching off the internet shouldn't even be suggested in this modern era. However, I asked you to do that for just testing's sake. As you mentioned above, you use Google Drive for the clients' projects. Could you please confirm whether you are using the links (Images/ PDF) stored in Goggle Drive in your InDesign document?

 

Regards,

Anshul Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines