• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Spell Checker Keeps Switching Language to Estonian Mid Document

Community Beginner ,
Mar 26, 2023 Mar 26, 2023

Copy link to clipboard

Copied

This has been repeating many times over the past year and I don't know when or why it started but I am trying to figure out how to fix it.

The pattern is this:

1. I open a document which is all in English

2. I start to do a spell check

3. Mid-way through the document, it starts to tell me every word is misspelled.

4. Closer scrutiny reveals that in the "Check Spelling" window the "Language" has switched to "Estonian."

4. I click "Dictionary ..."

5.In the dropdown, I change "Language" to "English: USA" and I click Done

6. Back in "Check Spelling" it still says "Estonian" and the spell checker still does not work.

 

Any ideas what is going on here?

TOPICS
Bug , How to , Type

Views

149

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Mar 26, 2023 Mar 26, 2023

The spell checker will use the language which is applied to the word it's looking at. When it switched to Estonian, did you go to the Control Panel (Character mode) or Character Panel and examine the language for that word in the Language menu? That is what I would expect you would see.

 

If the words that are causing the error actually have English applied, then you may need to restore your InDesign preferences.

Votes

Translate

Translate
Community Expert ,
Mar 26, 2023 Mar 26, 2023

Copy link to clipboard

Copied

The spell checker will use the language which is applied to the word it's looking at. When it switched to Estonian, did you go to the Control Panel (Character mode) or Character Panel and examine the language for that word in the Language menu? That is what I would expect you would see.

 

If the words that are causing the error actually have English applied, then you may need to restore your InDesign preferences.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Mar 26, 2023 Mar 26, 2023

Copy link to clipboard

Copied

LATEST

Oh, that fixed it, thank you. When I went to the control panel I found the language selected as Estonian in the dropdown.  I selected all the text in that page/frame and changed it to English: USA.  Then it stopped finding words like "when" and "at" as misspelled.  When it happened again later in the documet I repeated that fix. Thanks so much!!!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines