Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Spinning wheel every time switching back to InDesign [Mac]

Participant ,
Sep 06, 2018 Sep 06, 2018

Copy link to clipboard

Copied

Hey there,

facing a very annoying issue since long time, on my old MacBookPro 2012 and now on brand new and clean installed MBP 2018 with ID CC 2018.

Working on some documents I get spinning wheel almost every time I switch back to ID after jumping to some other app (like checking a PDF and going back to ID).

On small documents (48 pages) this is like 3 seconds of freeze, on larger documents (500 pages) can get up to 1 MINUTE of hang. Almost EVERY SINGLE TIME I switch back. This is insane.

Do you think it might be related to this old discussion?

Any help is really appreciated.

- MacBook Pro 2018

- Mac OSX HighSierra

- ID CC 2018

- Font Explorer X (uninstalled the ID plugin, no solution)

L.

Views

974

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 06, 2018 Sep 06, 2018

Copy link to clipboard

Copied

Hi,

does that occur when you do Select All to the text of a long story?

That's a known bug since InDesign CC 2015. Not resolved yet.

Tested with InDesign CC 2015.4, CC 2017.1 and CC 2018.1.

I cannot see it with InDesign CS6, CC v9.3.0 and CC 2014.2 on the same machine.

German Windows 10 ( 1803 ) but also reported with OS X machines.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 07, 2018 Sep 07, 2018

Copy link to clipboard

Copied

Hi,

no, it's happening regardless of document selection status, like no objects selected and no cursor mode, simply when switching back to ID window coming from other apps. I'm seeing some strange TCP activities in system logs but cannot really connect to the bug.

This is totally annoying, it really freezes ID for a few seconds up to minutes, making going in and out ID a real pain.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 07, 2018 Sep 07, 2018

Copy link to clipboard

Copied

Take a look at this short clip, sorry could not record directly from Mac as spinning wheel is not being recorded by ScreenFlow.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 07, 2018 Sep 07, 2018

Copy link to clipboard

Copied

Presumably you've tried resetting your InDesign preferences and unticking GPU Performance in preferences?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 11, 2018 Sep 11, 2018

Copy link to clipboard

Copied

Sure, reset preferences many times, and moreover did a total platform switch with clean install.. no way.

It is specific to the document and also seems related to document length.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 07, 2018 Sep 07, 2018

Copy link to clipboard

Copied

Have you tried turning off Preflight? If you have a complex Preflight, this can happen in some documents.

Another possibility, if you're working in High Quality Display, try Typical instead.

I've had the same issue and turning off Preflight (and turning it on only when needed), usually works. Same with High Quality Display.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mentor ,
Sep 07, 2018 Sep 07, 2018

Copy link to clipboard

Copied

FWIW, I've seen a very similar behavior of the file, which has no obvious corruption, but a very long and dirty history (designer uses technically the same file almost a decade!). Usual optimizing tricks, like those Jeff mentioned, won't work anymore. Neither saving as, or opening as a copy, or packaging. Not sure about exporting to / saving as idml. Actually, that wasn't my job, and I didn't care about it that much.

Obviously it was a very faulty workflow of doing a weekly magazine. You shouldn't do a new issue on top of the previous, just saving file as a new, years by years. Also I noticed other bizarre thing with that file: while opening it says it looks for over 2000 (!) links, and… finds them successfully (!!). In fact there was never more than a few dozens links in a given issue used.

What to do?

Your best bet is to start from scratch, and consider using templates when it's applicable.

Try exporting to / saving as idml.

Create New Document, copy pages from your old one using Move Pages command from Pages panel.

Take a look at your pasteboards: do they really need to be so crowded with various stuff? It also may increase file size significantly and slow down performance.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 11, 2018 Sep 11, 2018

Copy link to clipboard

Copied

Thanks,

all you say is very logical, although I of course did all the IDML cycle with no benefits.

This matter seems related to this very old issue cited in my main post, where pasting from old documents might bring along information like wrong or old paths that need to be checked/cleaned.. Unfortunately cannot change workflow for this documents so would rather understand what's going on..

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 11, 2018 Sep 11, 2018

Copy link to clipboard

Copied

Could it be a corrupt font?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 11, 2018 Sep 11, 2018

Copy link to clipboard

Copied

Nope, checked.

More likely to do with document links.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Sep 11, 2018 Sep 11, 2018

Copy link to clipboard

Copied

Of course, took every precaution for minimizing CPU and it's not that.

- Preflight OFF

- Page Thumbnails OFF

- Save thumbnails in Indd OFF

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 29, 2019 Jul 29, 2019

Copy link to clipboard

Copied

UPDATE to this issue:

- InDesign works fine just by making a new user on MacOS (same machine, same documents)

- It means it's some sort of interaction with user preferences or other software

I have investigated file access I have investigang Spinning Ball freeze using opensnoop via terminal and found it's probably really font related:

This is with Spinning Ball freezing: a lot of accesses to fonts (in this case Document Fonts local folder) - as you can see it's several seconds of waiting. CPU usage is not high.

This is with the new user, no spinning ball: no accesses to fonts.


Anyone has suggestions?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 01, 2021 Apr 01, 2021

Copy link to clipboard

Copied

LATEST

I had the same issue. I finaly figured out that it had to do with two GREP-styles I used in the document. Indesign probably searches for those GREPS every time you switch back into the document. Adobe, fix that lag please.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines