Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Strokes not displaying consistently on object frames

Explorer ,
Nov 08, 2021 Nov 08, 2021

Copy link to clipboard

Copied

Am working with a book design where I have over 100 placed images. When I apply the basic object style to them, it should add a 1pt black stroke around the image. This stroke is not displaying consistently. Sometimes it's too thin, sometimes it's too thick.

Drawing a new object frame and applying the basic object style and then placing the same image corrects the issue.

The original images came from a MS Word import, but were replaced with properly resized PSD files using the link panel.

If I select one of the original images that is displaying incorrectly, and manually change the stroke, it does not display in the proper weight.

The examples show two images with differing display strokes. Both are defined as 1pt by the basic object style. 

What could be causing this behavior?

TOPICS
How to, Performance

Views

78

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

I suspect it's just where the pixels are falling on the monitor due to the resolution, which could be related to monitor resolution and size. If you zoom in to 200%, do they look the same? (You could probably hide the frame edges [blue outline], but that might cause more issues than it would solve.)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

Thanks for your response. It prints the 1 pt stroke at inconsistent sizes as well. Not a display issue. I'm familiar with hiding and showing frame edges; not a solution to this particular issue. Zooming in shows the inconsistency better.

 

Replacing the image in a new frame seems to solve the problem, but I've got over 100 illustrations in this book, so that's a tedious work-around. Would like to be able to avoid the issue in the future. If it has any bearing on the problem, the original document was imported from MS Word.  The images were all resized and relinked, but I still have the problem on some of the pictures, not all. I'm guessing it's some Word grimble causing the problem.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

LATEST

Can you upload a sample file that is displaying the problem?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

Have you scaled either frame?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

And if the Object style shows an override: StyleName+

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

In the example, neither frame is scaled. Both at 100%.

The content is at different scales however, but that should not matter to the frame stroke, should it?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

no, it shouldn't

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

  1. Create a specific Objects Style, no + after the name
  2. In the transorm panel look how strokes are scaled.
  3. If you have overrides on an object, you see a +, reapply the style with holding the alt key. Therefore it is goot to have a dedicated object style for any kind of text or graphic frame (or the content of a graphic frame as well).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

Thanks, that's what I'm doing. I have a dedicated object style for the images. Really the only thing it should be applying is a 1pt black stroke. 

Strokes are not being scaled.

I know how to clear overrides. Seems to make no difference what's actually applied, even if the style is shown to be applied to the image.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 09, 2021 Nov 09, 2021

Copy link to clipboard

Copied

The strokes must be getting scaled somewhere in the process. A quick fix is to do a find/change with the object style, and set your style as the Find and the Change value.

To prevent this from happening, try changing your Object Editing preferences (under General) to uncheck Stroke Weight.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines