Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Text around image jumps to next page and creates "hole" in text

Participant ,
Jan 06, 2021 Jan 06, 2021

Copy link to clipboard

Copied

I have a page with an image that is copy-pasted with text-tool active as I usually do. However, in this instance when I add empty lines before or after the image (the way I usually do...) the text before the image breaks up and leaves half a page empty. Picture 1 shows the page before I add any blank lines, and picture 2 shows that whether I press enter above or below the image, the line above the pictures jumps all the way to the next page

 

 

picture 1:

pic1.png

 

picture 2:
pic 2.png

Questions:
1) Any explanation for this? the black part of the page do not show as empty lines where I can add text, but are just "dead"
2) In general should I avoid using blank lines around images? It has worked in 100 cases before, but that doesn't necessarily make it right to do 

TOPICS
How to

Views

184

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Participant , Jan 08, 2021 Jan 08, 2021
Thanks for the great idea, but I think I have solved it! I looked a final time (at least my 5th) at keep options and changed "keep with next" to 0. I thought this box was toggled off by the checkmark above, but that's not how it works I realized by trial and error.

Likes

Translate

Translate
Participant ,
Jan 06, 2021 Jan 06, 2021

Copy link to clipboard

Copied

I'm starting to think this could be caused by a GREP style that I have used to limit new lines to 15 characters. I can't find a way to show active GREP styles though, so haven't been able to test this theory of a cause so far.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 06, 2021 Jan 06, 2021

Copy link to clipboard

Copied

Hi Simon:

 

Adding hard returns is not recommended as a way to control spacing. A better option in this situation is to create a new paragraph style—perhaps call it "anchor"—assign it to an otherwise empty paragraph and then paste the image onto that ¶. Now you can use space above and below to control the spacing, globally, for all of the images. 

corg1.png

 

corg2.png

 

As for why you are getting the white space—yes, it could be a grep style or it could be keep settings. Examine the style attributes on the extra lines, specifically Keep Options and GREP Styles.

BTW, I've been working on your other question and I cannot find a solution. I'll work a little bit more and then I'll go over there and let you know what I've tried.

 

~Barb

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 06, 2021 Jan 06, 2021

Copy link to clipboard

Copied

I have found another case of seemingly the same problem and took 2 screenshots that could potentially shed light on this. In the first one, there are empty lines down page 19 (see numbers at the bottom) but this is just to test it out. When I move the cursor to the beginning of the title line at the bottom of the page and press enter the "weird" thing happens: the sentence at the top of page 19 is broken into parts and the 2nd line is moved all the way down to the top of the next page.


I have disabled keep settings.

 

Could this shed light on something?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 06, 2021 Jan 06, 2021

Copy link to clipboard

Copied

I don't see any new screen shots. Did you mean to include them in your reply? If so, be sure to reply in your browser and click the Insert Photos on the reply toolbar.

 

~Barb 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 07, 2021 Jan 07, 2021

Copy link to clipboard

Copied

Oops! I simply forgot to add them, sorry.

 

First picture shows the situation before pressing enter and the 2nd shows the result. I have this problem is multiple chapters - there is seemingly a large area that becomes "dead" as I can't place the cursor there.

 

Picture 1:

forum billede 1 2021-01-06 19_10_02-_SR Kapitel 1.indd @ 50%.png

 

Picture 2:

 

forum billede 2 2021-01-06 19_10_25-_SR Kapitel 1.indd @ 50%.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 07, 2021 Jan 07, 2021

Copy link to clipboard

Copied

It seem it is not only around pictures but more general.

I have been looking around to see if there is some way to show all active GREP styles in a document, but can't find it. I would like to make absolutely sure all GREP is removed to rule that out.

It seems it could be related to a GREP style I added a while back, but under the active paragraph style there is nothing showing under GREP

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 07, 2021 Jan 07, 2021

Copy link to clipboard

Copied

What is described in this thread sounds like the same issue:
https://creativepro.com/topic/text-jumps-to-next-page-wout-filling-first-page/

An answer points to the keep option. Both keep options and GREP are disabled/not defined for my paragraph style, but I don't know if they could be active from elsewhere? So a way to check that would be helpful!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 07, 2021 Jan 07, 2021

Copy link to clipboard

Copied

Hi Simon:

 

Are you comfortable sharing your file with me? You can put it on dropbox and post a link here (public) or click my name above and message the link directly to me (private). I think that would be the quickest at this point.

 

~Barb 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 08, 2021 Jan 08, 2021

Copy link to clipboard

Copied

Thanks for the great idea, but I think I have solved it!

I looked a final time (at least my 5th) at keep options and changed "keep with next" to 0. I thought this box was toggled off by the checkmark above, but that's not how it works I realized by trial and error.

 

2021-01-08 09_53_54-Paragraph Style Options.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 09, 2021 Jan 09, 2021

Copy link to clipboard

Copied

LATEST

Hi @simon5CD0:

 

Yep, keep options was my first thought. Glad you were able to locate the setting and disable it. 

 

~Barb 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines