Text doesn't display

New Here ,
Jun 14, 2021 Jun 14, 2021

Copy link to clipboard

Copied

I was doing a long document in bulgarian language. I didn't package my indd file, only have it as pdf and indd. My computer died completely and I got a new one while this project went on hold for a long time. Now when I open the indd file on my new laptop all the text has disappeared and I just get pink highlith instead. I have tried replacing the font. What may be wrong? I can't figure out. All the fonts are installed and so is the language...

TOPICS
Bug, Type

Views

704

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jun 18, 2021 Jun 18, 2021
You should uninstall and reinstall the fonts. I did a very quick test: I have copied a text from the Bulgarian tourist office website and pasted it in an InDesign document, using Alegreya (regular, bold, italic, bold italic, black, and black italic). Absolutely no problem:

Likes

Translate

Translate
Adobe Community Professional ,
Jun 14, 2021 Jun 14, 2021

Copy link to clipboard

Copied

If text is highlighted in pink, font is missing.

Can you post a screen shot of the Find font window and one other of any page?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 14, 2021 Jun 14, 2021

Copy link to clipboard

Copied

@irinas64121795 

To clarify, the "Find Font" dialog is in the Type menu.

~ Jane

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 14, 2021 Jun 14, 2021

Copy link to clipboard

Copied

1Asset 1-100.jpg

1Asset 2-100.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 14, 2021 Jun 14, 2021

Copy link to clipboard

Copied

It doesn't say and fonts are missing. For testing purposes, what happens when you go to View > Screen Mode > Preview?

janee_0-1623680632094.png

 

There is a little bit of yellow. That shows the H&J violations when text is fully justified. Do you see anything else in Preferences > Composition?

 

janee_0-1623681097244.png

 

~ Jane

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 14, 2021 Jun 14, 2021

Copy link to clipboard

Copied

Hi @irinas64121795 

 

I played with it some more.

 

In Preferences > Composition:

  • H&J violations are yellow
  • Substituted Glyphs are orange
  • Custom Tracking is green

Try turning of Substituted Fonts and let us know if that's it.

 

~ Jane

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 14, 2021 Jun 14, 2021

Copy link to clipboard

Copied

screen mode - normal is the same: only numbers punctuation.
I do have titles displaying in a different font. Could it be that the font no longer supports bulgarian cyrillic? 1Asset 3-100.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 14, 2021 Jun 14, 2021

Copy link to clipboard

Copied

Hi

 

Click an insertion point in the text and go to Edit > Story Editor. Does the text appear there?

 

Select a bit of text that was / is highlighted in pink and show a screen shot of the Character panel. Repeat for a quotation mark or comma. Then we can compare the exact character settings of the two.

 

~ Jane

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 14, 2021 Jun 14, 2021

Copy link to clipboard

Copied

My OTF version of Alegreya support cyrillic. Is Bulgarian cyrillic different?

Capture d’écran 2021-06-14 à 17.25.10.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 14, 2021 Jun 14, 2021

Copy link to clipboard

Copied

A little bit different. I noticed that my font doesn't have cyrillic characters at all. The other one does. I wonde what happened to the font and if I can get an older version of the font?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 14, 2021 Jun 14, 2021

Copy link to clipboard

Copied

See the OTF version available on Google fonts:

https://fonts.google.com/specimen/Alegreya?query=alegreya#glyphs

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 14, 2021 Jun 14, 2021

Copy link to clipboard

Copied

It seems that you have a mix of the True Type and the OTF version of Alegreya, which is not the best thing to do. Choose one of the versions and remove the other one, but your screen shot is quite strange: punctuation and digits are OK but not the letters.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 14, 2021 Jun 14, 2021

Copy link to clipboard

Copied

That's actually pretty normal, seeing just the Cyrillic glyphs drop, leaving behind everything that is ASCII-encoded, like basic punctuation. Chances are fairly good that the OTF font has Cyrillic support and the TT does not. It's not uncommon at all for this to be the case; perhaps the TrueType is much older? 

 

I use a (very old!) Windows utility called BabelMap, which has tools to show which fonts installed on your system support which scripts. If you copy a chunk of text to the clipboard, open up BabelMap, and go to Fonts -> Font Coverage and paste in your Bulgarian sample, then the tool will tell you which version(s) of Alegreya on your system have extended Cyrillic support. 

 

If all those fonts in your Find Font window actually do have extende Cyrillic support  for Bulgarian, then perhaps something is wrong with your InDesign file itself? I'd start by exporting to IDML and re-opening. Alternately, you could post it (or a fragment thereof) here so we could download it and see if we couldn't figure out what was wrong. 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 14, 2021 Jun 14, 2021

Copy link to clipboard

Copied

I don't see cyrillic characters in Alegreya glyphs. How would I export to IDML? There is no text.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 14, 2021 Jun 14, 2021

Copy link to clipboard

Copied

File > Save As > IDML

janee_0-1623698388858.png

 

What did you see when you looked in the Story Editor?

 

~ Jane

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 18, 2021 Jun 18, 2021

Copy link to clipboard

Copied

Nothing. That doesn't help at all. How do you expect to export an empty document? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 18, 2021 Jun 18, 2021

Copy link to clipboard

Copied

I couldn't figure out how this software works. I can see my fonts in fonts folder. The thing is, now I have the normal Alegreya but no italics and no bold as if only bulgarian normal weight is supported.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 18, 2021 Jun 18, 2021

Copy link to clipboard

Copied

irinas45467911_0-1624011932614.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 18, 2021 Jun 18, 2021

Copy link to clipboard

Copied

You should uninstall and reinstall the fonts. I did a very quick test: I have copied a text from the Bulgarian tourist office website and pasted it in an InDesign document, using Alegreya (regular, bold, italic, bold italic, black, and black italic). Absolutely no problem:

Capture d’écran 2021-06-18 à 12.39.42.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 24, 2021 Jun 24, 2021

Copy link to clipboard

Copied

nope, doesn't work

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 24, 2021 Jun 24, 2021

Copy link to clipboard

Copied

It's really weird… Did you uninstall the previous versions of Alegreya font and install the Google font version?

https://fonts.google.com/specimen/Alegreya?query=alegreya#glyphs

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 24, 2021 Jun 24, 2021

Copy link to clipboard

Copied

Finally, it has worked! I have uninstalled and restarted several times and it did work. Not sure what was wrong. I have initially installed the google font version but not the 'variableFont_wght.ttf'. Maybe it was the reason why it went wrong.
What a relief. Thank you all for the support and help, I appreciate it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 24, 2021 Jun 24, 2021

Copy link to clipboard

Copied

LATEST

Great! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines