text on path disappears when I change the path stroke to none/transparent

Community Beginner ,
Jul 06, 2022 Jul 06, 2022

Copy link to clipboard

Copied

I am having an issue with typing on a path.

I want to have black fill text, on a path with no fill/stroke

 

If I start of with a black stroked line, type along the path, I can then direct select the path and change the stroke to any colour, apart from none/transparent - If I change the path to none/transparent stroke, the text also disappears. Any ideas? I only have the path selected, with the direct selection tool - I don't have the text selected. 

 

After changing the path stroke to transparent, the text disappears but shows as being overset. I have tried reducing the text size before changing the stroke but this makes no difference.

Any ideas? this behaviour doesn't seem right

TOPICS
Bug , How to , Type

Views

95

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jul 06, 2022 Jul 06, 2022
@salpilk said: "I want to have black fill text, on a path with no fill/stroke" Just do the following: Have a path with a visible stroke. Set your text with the Type on Path tool. Change the stroke color to [None]. From my German inDesign: Also doable with the Effects panel. Set the opacity of the stroke to 0%. Do not do that with the whole object. Regards, Uwe Laubender ( Adobe Community Professional )

Likes

Translate

Translate
Engaged ,
Jul 06, 2022 Jul 06, 2022

Copy link to clipboard

Copied

And when you edit the whole text - with the double click - in the swatches panel, the T symbol have the black color selected?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 06, 2022 Jul 06, 2022

Copy link to clipboard

Copied

@salpilk said: "I want to have black fill text, on a path with no fill/stroke"

 

Just do the following:

Have a path with a visible stroke.

Set your text with the Type on Path tool.

Change the stroke color to [None].

 

From my German inDesign:

TextOnPath-StrokeWeight-0-StrokeColor-None.PNG

 

Also doable with the Effects panel.

Set the opacity of the stroke to 0%. Do not do that with the whole object.

 

TextOnPath-StrokeWeight-4-StrokeColor-Yellow-OpacityOfStroke-0%.PNG

 

 

Regards,
Uwe Laubender
( Adobe Community Professional )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 06, 2022 Jul 06, 2022

Copy link to clipboard

Copied

I tried to recreate your problem using InDesign 16.4 on Big Sur and could not. 

Is this happening in all documents or just one? If it is just one document then try exporting the file as an IDML and then reopen that file in your version of InDesign. This process can clear out some corruption in the file.

If this is a problem that you are having in all documents then you might want to try trashing your InDesign preferences. This will reset the program to its defaults and hopefully fix the problem.

To do so:

For Macintosh Users: The User Library folder in which InDesign’s preferences are stored is hidden by default on most Macintoshes. To access it make sure that InDesign is closed and click on the desktop to launch a Finder Window (Command-N). With this window in column view follow the path User>Home folder (it’s the folder with an icon that looks like a house—it may have the user’s name rather than “Home”) and click on the Home folder. With the Option Key pressed choose Library from the Finder Go Menu. “Library” will now appear within the Home folder. Within the Library folder find the folder called Preferences and within it find the folder called “Adobe InDesign” and the file called “com.adobe.InDesign.plist” and delete both that folder and that file. When InDesign is next launched it will create new preference files and the program will be restored to its defaults.

For Windows Users: You can try the quick way of resetting on a PC which is to hold down Ctrl + Alt + Shift when launching InDesign and respond affirmatively when asked if you want to reset. There have been some recent reports that the window asking if you want to reset is not popping up but that the prefs are being reset anyway. If this works great but if it doesn’t you may have to manually delete them.
To do so: On Windows 7 and above the preference files are hidden. To find them go to the Control Panel and open Folder Options and then click the View tab. Then select “Show hidden files and folders” or “Show hidden files, folders or drive options” in Advanced Settings. Then delete (or rename) the folder at the end of this path: C:\Users\<USER>\AppData\Roaming\Adobe\InDesign\<Version #>\<Language>. Make sure that InDesign is closed when you do this. When you relaunch the program it will create new preference files and the program will be at its default settings.

The advantage of manually deleting preference files is that after you’ve reset up the program (make sure that no document window is open) to your liking, you can create copies of your personalized “mint” preference files (make sure that you quit the program before copying them—that finalizes your customization) and use them in the future to replace any corrupt versions you may need to delete.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 06, 2022 Jul 06, 2022

Copy link to clipboard

Copied

Another option is to set the stroke weight to 0.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 11, 2022 Jul 11, 2022

Copy link to clipboard

Copied

Hi @salpilk & @aniri5j9ox8tw2ln,

 

We would like to follow up on your issue. Are you able to resolve the issue by following our expert's advice? Please feel free to update the discussion if you need further assistance from us.

 

We would be happy to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jul 12, 2022 Jul 12, 2022

Copy link to clipboard

Copied

Ich habe mit dem Problem des Threaderstellers nichts zu tun. Ich hatte ihm ja doch einen Tipp gegeben...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 12, 2022 Jul 12, 2022

Copy link to clipboard

Copied

LATEST

Sure. Thank you for the help. Appreciate your presence in our InDesign community.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines