• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
8

Thai vowel and tone marks not showing correctly in InDesign

Community Beginner ,
Oct 10, 2023 Oct 10, 2023

Copy link to clipboard

Copied

Can someone please help me to figure out which setting I need to set for Thai vowel and tone mark settings to display properly in InDesign? I'm using Noto Sans Thai font (although I've replicated the problem in Cordia UPC). I did some digging that said that changing the Advanced Type Default Composer Preference to Adobe World-Ready Paragraph Composer would fix the issue, but it's not working for me. I'm on a PC, based in the US. Thank you!

 

Example shown below.

Kimberly30993721sps5_0-1696946362495.png

 

TOPICS
Scripting , Type

Views

691

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 10, 2023 Oct 10, 2023

Copy link to clipboard

Copied

I did some digging that said that changing the Advanced Type Default Composer Preference to Adobe World-Ready Paragraph Composer would fix the issue, but it's not working for me.

 

Well, that should be the fix. Here's an animation of me doing exactly that:

 

THAI1.gif

 

Note that I have the frame selected when I make that change. If I have nothing selected at all, then the World-Ready Composer would be selected for all new text frames, but it won't change any text frames that are already in place.

 

Here's another method of doing the same thing - I've selected text with the Text tool instead of choosing the frame with the black pointer Selection tool, and I'm using the Control-Alt-Shift-J keyboard shortcut for the Justification dialog instead of the little hamburger-icon flyout menu on the Paragraph panel, but that doesn't matter, it all works exactly the same:

 

thai2.gif

 

If you still can't get the WRC to render your Thai text correctly, could you describe the steps you're using to turn it on? It's possible that your installation of InDesign is damaged and needs to be repaired.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 10, 2023 Oct 10, 2023

Copy link to clipboard

Copied

Joel is the man for this, but just thought I'd check to be sure your text is assinged Thai as the language in your paragraph styles...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 10, 2023 Oct 10, 2023

Copy link to clipboard

Copied

You know, Peter, I was just thinking about that. Some fonts simply won't render correctly if they do not have the appropriate language assigned. It's possible to make features like contextual alternates or mark-to-mark positioning dependent on language settings (as is the case with my entire collection of Telugu fonts, and I did see that you've already replied to a thread about Telugu very recently). However, that's not the case for Cordia, the font I used; my text in my GIF animation is actually marked as English. 

 

(No, wait, in my example it's actually marked as Arabic! 🙂 But it works just as well when marked as English, or Thai. Poor form on my part, I know.)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 10, 2023 Oct 10, 2023

Copy link to clipboard

Copied

Well, as I said, you're the expert here. Just didn't want to assume that languasge would not be an issue.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 10, 2023 Oct 10, 2023

Copy link to clipboard

Copied

@Joel Cherney @Peter Spier You both have been so helpful...thank you! I tried Joel's original suggestions of selecting the text box or the text itself and updating the preference and that didn't work; however, modifying the Paragraph Styles/Advanced Character Formats/Language to Thai does work! 🙂 Unfortunately, it was a bit of a fluke for me to realize that this was an issue. I'm also working with Simplified Chinese, Traditional Chinese, Korean, and Japanese...do any of those have similar language requirements and I just am not realizing it because I don't speak/read the languages?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 10, 2023 Oct 10, 2023

Copy link to clipboard

Copied

If you're new to this kind of work, I would strongly suggest that you have a post-DTP in-language review stage, performed by the original translators, if possible. I have been doing this kind of work for twenty years, and I typically insist on this myself. If you don't read the language, it's possible to set it up incorrectly in a wide variety of ways. The ways it can go wrong are so varied that I despair of summarizing them for you. 

 

There is another composer that is hidden from you, called the J Composer, which you'd need to typeset the Japanese correctly. It's visible only when you have an install of InDesign set up to reveal all of the hidden CJK formatting tools (or if you write Javascript to access tools not visible in the GUI). InDesign's other composers will happily break lines in the wrong place in Japanese. It's easier to spot bad line breaks in Chinese and Korean without being able to read very much of those languages, but it's almost impossible to do so in Japanese. 

 

Here's a Medium post from Ken Lunde that shows you how to modify your installation of InDesign to make it possible to do CJK typesetting without a folder full of Javascript. 

 

If you look at that material (e.g. the wide variety of typesetting tools that have no English translation of their names!), you will realize that it's not really possible to just sit down and format all of these languages well. Japanese typesetting, in particular, is very different from setting type in any European language. Each writing system has its own rules and conventions, and if you don't know any of them and assume that typesetting is independent of language, you're guaranteed to make major mistakes.

 

That being said, if you know that your previous versions of these documents were correct, it's easier to know that your work won't make them illegible. Just as an isolated example, if you are placing Korean text in an English-language install of InDesign, it will often fail to wrap lines at spaces. It'll treat Korean like Chinese, and just wrap text in the middle of a word. That's not permissible in Korean (while it is, more or less, in Chinese). You will want to turn on hidden characters (Type -> Show Hidden Characters) to ensure that each line of Korean really does end in a space or a return. 

 

Sorry to be the bearer of bad news! 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 10, 2023 Oct 10, 2023

Copy link to clipboard

Copied

And now that I've actually drank this cup of coffee sitting my desk, I think I see what I failed to read in your post. You changed the Composer in the Preferences, correct? In Edit -> Preferences -> Advanced Type? That will only affect new text frames drawn in new documents. To affect text that is already on the page, it's possible to use either of the methods I demonstrated, but if you are using Paragraph Styles, it'd be better to make that change there:

 

thaipara.gif

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 10, 2023 Oct 10, 2023

Copy link to clipboard

Copied

@Joel Cherney To answer your question, I was modifying an existing document (not creating new) and was using Edit/Preferences/Advanced Type. I tried modifying the language under Edit/Preferences/Dictionary, but that didn't make the change...only changing the language in the Paragraph Styles worked (the Paragraph Styles must be overwriting the document preferences). Your latest video was helpful for me to see that there are 2 ways to modify the Paragraph Style for it to work (Advanced Character Formats/Language or Justification/Composer). Thank you again! 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 18, 2023 Oct 18, 2023

Copy link to clipboard

Copied

@Joel Cherney @Peter Spier How would you handle this problem in a multi-language, multi-font document given that the only thing that worked was changing the Language setting and there will be multiple?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 18, 2023 Oct 18, 2023

Copy link to clipboard

Copied

I'll continue to defer to Joel, but in my opinion ALL text needs to have the correct language assigned. Language is a character-level attribute, so you can create character styles for every language you need. One way to apply them would be to use a GREP style to apply the propewr character style to specific unicode ranges for each language, and I'll let Joel explain how to do that since he probably has done it and knows the ranges for your languages. GREP styles will slow down the program a bit, but they can be applied in addition to other methods of applying a character style so would not interfere with also making things bold or italic, for example.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Oct 18, 2023 Oct 18, 2023

Copy link to clipboard

Copied

LATEST

So Peter's right here; the correct workflow is to make sure that all of your text is marked with the correct language. (I was being sloppy, in the example GIF I made.) And in many cases, I would do exactly what he described - I'd make GREP Styles to dynamically apply language settings to various writing systems based on their Unicode values. We can't do that here, though, because Traditional Chinese, Simplified Chinese, and Japanese all share characters with the same codepoints, yet must be typeset in different fonts. 

 

So I'm not sure what your workflow looks like, but it sounds to me like you're going to need to make additional paragraph and/or character styles, one for each language. So if I had header styles named something unimaginitive like H1, H2, H3 etc., then I might make five or six other paragraph styles H1 Traditional Chinese, H1 Simplified Chinese, H1 Japanese, etc. When you make a new paragraph style there's a dropdown to let your new style be "Based On" another style, so that each child style would just be the parent H1 style + the language-specific font. 

 

New styles done in this way might be what you need, but honestly I can't guess. Marking your text as Japanese language won't apply the J Composer, which is necessary for correct Japanese layout, like I said in my post on the 10th. If you're modifying existing translated InDesign files, then hopefully it's already turned on in the Paragraph Styles, and you won't have to think about it. 

 

 

 

 

 

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines