• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit Search
0

The "ghost text": text deleted from a docx file reappears in the InDesign-imported text

Community Beginner ,
Jul 24, 2021 Jul 24, 2021

Copy link to clipboard

Copied

I sent the pdf files of InDesign-formatted text to the editor. He was surprised by finding in the layout the huge blocks of texts he had previously deleted from the source docx files. When I checked the source, the "ghost text" wasn't there. It was undetectable with the search tools. However when I pasted the file in InDesign, the "ghost text" popped up again. I tried to copy-paste the text in a new docx file, and the result was the same. The only way to get rid of the "ghost text" was to paste the text only, yet then I lost the footnotes.

Apparently the "ghost text" reappearance makes the editor's work going to pot as we can not be sure how deeply it impacts the edited text. I've never encountered such a problem. Please, help.

TOPICS
Import and export

Views

144

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 24, 2021 Jul 24, 2021

Copy link to clipboard

Copied

I bet track changes was enabled in Word and and the changs had not yet been accepted before the file was placed.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 24, 2021 Jul 24, 2021

Copy link to clipboard

Copied

Thank you, Peter. I'm sure you are right. The question is — how should I import the clean, ghost-free text? The file I received looks unsuspicious, yet it's full of surprises.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 24, 2021 Jul 24, 2021

Copy link to clipboard

Copied

Open the Word file and check for revisions.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 24, 2021 Jul 24, 2021

Copy link to clipboard

Copied

Thanks, Bob. The Word file I received from the editor looks perfectly clean. No revisions, no comments, nothing.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 24, 2021 Jul 24, 2021

Copy link to clipboard

Copied

Try a file>save as and save it to a new name. Place that.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 24, 2021 Jul 24, 2021

Copy link to clipboard

Copied

Ok, I found that conversion to rtf solves the problem while keeping footnotes intact. Yet it is a one-time solution and does not eliminate the problem itself.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 24, 2021 Jul 24, 2021

Copy link to clipboard

Copied

I would try opeing the Word file and going to Track Changes > Accept all changes, then do a Save AS and see waht happens. That's a pretty typicalrequirement with Word files.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 24, 2021 Jul 24, 2021

Copy link to clipboard

Copied

Thanks, Peter. Just tried, didn't work. No problem with that while saving as .rtf works as I've written above.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 24, 2021 Jul 24, 2021

Copy link to clipboard

Copied

When you imported, was Track Changes checked on the Word Import options?

As for saving as another file format, the best way I've done it is to save as an old .doc format instead of .docx.

Word's internal XML structure is kinda weird. I've had situations where even old deleted images (in the Word file) will show up when imported into inDesign.

 

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 24, 2021 Jul 24, 2021

Copy link to clipboard

Copied

Thanks, roaringmousegraphics. In fact, what I'm receiving from the editor are .doc, not .docx files. But placing .doc files into InDesign layout brings another problem: the reddish-spotted squares on the place of some (not all) footnotes. Saving and importing as .docx solves this problem, so I didn't even want to mention it in this thread. As I've written above, saving as .rtf helps.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 24, 2021 Jul 24, 2021

Copy link to clipboard

Copied

I mean, saving as .rtf helps to get rid of ghost text.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 25, 2021 Jul 25, 2021

Copy link to clipboard

Copied

DOC is a very outdated format. Why in the world would you not want to mention this?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 25, 2021 Jul 25, 2021

Copy link to clipboard

Copied

BobLevine, it had never been a problem for me. For some reason, this particular editor didn't manage to update his system. Fine. I receive .doc, convert them to .docx, everything works, nobody tries to reeducate anybody. But then this "ghost text" problem emerged.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 25, 2021 Jul 25, 2021

Copy link to clipboard

Copied

LATEST

Well, yes, it is.. (I'm usually an .rtf guy, actually) but when I've had issues with an XML-based file, and all I'm doing is importing text, It has saved me, so I mentioned it as another alterantive.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines