• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Tracking & Kerning issues while writing URDU Language in InDesign latest version 19.4

Community Beginner ,
Jun 18, 2024 Jun 18, 2024

Copy link to clipboard

Copied

In Adobe inDesign 2024 with North American English and یدعم العربیہ setting the moment i start writing any text in URDU Language that wrote in 18.5 or earlier versions all tracking and kerning get lost in InDesin 19 versions opf 2024.

 

<Title renamed by moderator>

TOPICS
Bug , Type

Views

260

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Jul 10, 2024 Jul 10, 2024

GOOD NEWS....
After reading your detailed and impressive reply I started experimenting with different settings and Then Voila... I finalled discovered the solution. Sharing the screenshot ...
This new setting is available in 19 only. Not there in 18.5.
Where is the new setting? 
Edit.... Preferences... Advanced Type... Just below Default Composer is the new setting...

Votes

Translate

Translate
Adobe Employee ,
Jun 20, 2024 Jun 20, 2024

Copy link to clipboard

Copied

Hi @Bradley336922151vnj,

We are sorry to hear you're experiencing issues with InDesign 19.4. Would you mind sharing a screen recording of the issue for better understanding? Please share the details of your operating system. 

 

Does that happen with all files or with a specific file? Is it only happening with old files or with new files created in the 19.4 version as well?

 

We will be happy to assist you further.

 

Thanks,

Harshika

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 06, 2024 Jul 06, 2024

Copy link to clipboard

Copied

Issue still not resolved in 19.4.
All the subscription money is going down the drain for me. What's the use when nobody listens in Adobe for RTL language issues. Indesign treatment of RTL in version 19 is compelling me to try  Quark as they have also started RTL.
But still I prefer INDESIGN. Sharing a screen shot. The moment I start working in version 19 all Tracking get lost... I have drawn a blue circle where you can see the impact. Educate me if I am doing something wrong. It nver happened in earlier veriosns.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 08, 2024 Jul 08, 2024

Copy link to clipboard

Copied

Any hope of getting it resolved.. ??? 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 08, 2024 Jul 08, 2024

Copy link to clipboard

Copied

Well, Harshika asked you to provide some details (screen recording, whether or not it happens on all of your files or just one, details of your OS). If you provide responses to questions like that, it will be easier to figure out what might be going wrong, and therefore it'd be easier to help you resolve your issue.

 

I work with Urdu fairly regularly, but one thing I've never done is start an Urdu file in one verison and then open it up in a subsequent version. When the developers work on InDesign, they sometimes make changes to the text rendering engine. So if you make an Urdu file in version 18, then open it up in version 19, then your text is still being rendered according to the rules in version 18, until you make a change to the text. At that point, the whole thing re-renders according to the rules in version 19. That sounds exactly like what you're experiencing, right?

 

So, there are some things to try:

 

1) Do you still have version 18.5 installed? You could start the old version, open up your old .indd file saved from 18.5, then export IDML, and try to open that IDML in version 19. 

 

2) You could try to recompose the whole document.  This will probably just induce the spacing error in every story in the document, but it's worth taking a look. Once you have your document open in verison 19, you can use the key combination Control + Alt + / (assuming you're using Windows; on a Mac it's Command + Option + slash). 

 

3) You can experiment with the Justification dialog (Windows shortcut is Control + Alt + Shift + J) to see if the settings you have there are behaving differently in the v19 text rendering engine.

 

3b) I can see you have Kerning set to Metrics; you can try selecting some problematic text and setting that to None. It's possible that the metrics in the font that you're using are being handled differently in v19, and this is one way to check. 

 

4) You can post your v18.5 file here and ask us to download it and see if we can recreate your issue on our own desktops; that might lead to a solution for you, or to a bunch of people ready to file a bug report.

 

That's what I have on the top of my head. I have had my own frustrations in the last few years with the rate at which the InDesign developers fix showstopper bugs in complex script and right-to-left layout tools, but your claim that "nobody listens in Adobe for RTL language issues" just isn't true. They've fixed... half the bug reports I've made regarding layout issues in RTL languages? Not bad, I guess. But in order to get things fixed, when there are bugs, you'd need to be very rigorous in your bug report, and just saying "it doesn't work" won't work. So, if you can, please provide some more details, and also if possible provide a packaged sample file here, so we can try to recreate your issue.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 10, 2024 Jul 10, 2024

Copy link to clipboard

Copied

Thank you for the reply. I will follow your reply and will get back to you.
But in all previous versions such scenario never came in front and only in cversion 19 I have exerienced what I wrote.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 10, 2024 Jul 10, 2024

Copy link to clipboard

Copied

Please allow me to say "I am Sorry" for my statement  "nobody listens in Adobe for RTL language issues". They do. You did it. I appreciate it.
I will share 18.5 files with you.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 10, 2024 Jul 10, 2024

Copy link to clipboard

Copied

GOOD NEWS....
After reading your detailed and impressive reply I started experimenting with different settings and Then Voila... I finalled discovered the solution. Sharing the screenshot ...
This new setting is available in 19 only. Not there in 18.5.
Where is the new setting? 
Edit.... Preferences... Advanced Type... Just below Default Composer is the new setting...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 10, 2024 Jul 10, 2024

Copy link to clipboard

Copied

LATEST

I bet that "Legacy Text Shaping" means "This checkbox turns harfbuzz off".  This is the open source text shaping engine recently implemented in InDesign, which is kind of the default character shaping engine these days.  

 

Isn't Jameel Noori Nastaleeq a fairly old font? Do you know how old the version you're using is? I found this post to the harfbuzz github, about changes to the font that were "recent" back in 2015. If your personal copy of the font is older than that, that might be part of the issue that is forcing you to use the old character shaping engine. (Which should continue working just fine for you for years, I'd imagine.) But I also learned that the harfbuzz maintainers also maintain Noto Nastaliq (!!!) so if I go and ask them "why doesn't Jameel Noori Nastaleeq work with harfbuzz in InDesign" I'm likely to get a very detailled answer! So I'm going to go ask them what's going on, here.

 

Lastly, I'm glad that you found a resolution, and also that you feel like somebody at Adobe is listening. I'm not "at Adobe" though, I'm just an InDesign user who has been posting on the Adobe Forums... for the last twenty years, or more. If you wouldn't mind clicking that "Correct Answer" button on my initial post, I'd appreciate it. And no apologies are necessary whatsoever, I'm glad that my questions spurred you to solve this issue, and that future people who search these forums find your correct answer, which I've also marked as Correct. 

 

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines