trying to place Excel spreadsheet as inline graphic

Participant ,
Aug 10, 2022 Aug 10, 2022

Copy link to clipboard

Copied

I created a document in Indesign and placed (Ctrl + D) Excel spreadsheets in the text inline. Now I have the document open and am trying to use the same steps I used before to place some more Excel spreadsheets and Indesign is placing them in a separate box and not inline with my text like before. I am following the same steps. Using the Type Tool, I place my cursor where I want the spreadsheet to be. Type Ctrl +D. The Place dialog box opens. I select my file and Show Import Options. The Excel Import Options dialog box opens. I put in my cells and make sure it says Formatted Table then click OK. Instead of the spreadsheet pasting into my text, it is in a separate box from the text. Previously, I got a warning message about it taking longer to import a formatted table but I'm not getting that anymore. 

 

I went back and tried to place some previous spreadsheets and now they don't work either. Did I change a setting accidentally? Help! I need to get these spreadsheets in this document ASAP and I can't figure out why it's not working the way it was! 

 

Thanks!!

TOPICS
Import and export

Views

97

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Aug 11, 2022 Aug 11, 2022

csheets@ecisolutions.com said:

"I am simply placing my Type Tool cursor in my text window."

 

"Then typing Ctrl + D to place. After that I select the spreadsheet, set the Excel settings and then instead of pasting into the document or asking me if I want formatted or unformatted, it attaches the text to my cursor and when I click the page it pastes the spreadsheet in it's own separate box."

 

That's definitely not the way it should work with placing Excel files by default.

Ok. I think, I found a

...

Likes

Translate

Translate
Community Expert ,
Aug 10, 2022 Aug 10, 2022

Copy link to clipboard

Copied

Are you placing as an inline graphic or as a table?

Have you restarted InDesign?

Have you rebuilt your InDesign prefs?

Have you restarted your computer?

 

David Creamer: Community Expert, Adobe Certified Instructor, and Adobe Certified Expert (since 1995)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Aug 10, 2022 Aug 10, 2022

Copy link to clipboard

Copied

I restarted my computer. I restarted Indesign. It's still not working. I did not knowingly change any settings or preferences. 

I am simply placing my Type Tool cursor in my text window. Selecting the style I want it to be. Then typing Ctrl + D to place. After that I select the spreadsheet, set the Excel settings and then instead of pasting into the document or asking me if I want formatted or unformatted, it attaches the text to my cursor and when I click the page it pastes the spreadsheet in it's own separate box. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Aug 10, 2022 Aug 10, 2022

Copy link to clipboard

Copied

If your Excel doc is placed as table - then put cursor in any cell, Ctrl+Alt+A - on PC - your whole table should be selected, then hit Ctrl+X (cut) - goto the place you want to place it and Ctrl+V. 

---
Can automate anything - as long as it doesn't require A.I. 😉 and even then 3rd helping hand can be created 😉

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 10, 2022 Aug 10, 2022

Copy link to clipboard

Copied

This is how it should work if I understanding your workflow correctly:

2022-08-10_13-08-05.gif

 

David Creamer: Community Expert, Adobe Certified Instructor, and Adobe Certified Expert (since 1995)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Aug 10, 2022 Aug 10, 2022

Copy link to clipboard

Copied

yes, exactly but instead it's attaching to the cursor and I have to click to put it in. But then it's in a separate window. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 10, 2022 Aug 10, 2022

Copy link to clipboard

Copied

I don't think you said you rebuilt your preferences. 

  1. Quit InDesign.
  2. Start InDesign the way you normally would.
  3. Immediately hold down the Cntl-Alt-Shift keys.
  4. You should get a dialog box asking if your want to "Delete InDesign Preferences file?".
  5. Click Yes.

Test it again.

 

David Creamer: Community Expert, Adobe Certified Instructor, and Adobe Certified Expert (since 1995)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Aug 10, 2022 Aug 10, 2022

Copy link to clipboard

Copied

I deleted the Preferences file but it is still doing the same thing. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 11, 2022 Aug 11, 2022

Copy link to clipboard

Copied

LATEST

csheets@ecisolutions.com said:

"I am simply placing my Type Tool cursor in my text window."

 

"Then typing Ctrl + D to place. After that I select the spreadsheet, set the Excel settings and then instead of pasting into the document or asking me if I want formatted or unformatted, it attaches the text to my cursor and when I click the page it pastes the spreadsheet in it's own separate box."

 

That's definitely not the way it should work with placing Excel files by default.

Ok. I think, I found a way, that the Excel file will be placed to the cursor and not to the active text insertion point.

I unchecked the option to replace the contents. Make sure that the option is checked to replace selected contents when you select the Excel file.

 

From my German InDesign 2022 on Windows 10:

 

PlaceExcelFile-Options.PNG

 

Regards,
Uwe Laubender
( Adobe Community Professional )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines