Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Using Arabic version of Indesign

New Here ,
May 02, 2018 May 02, 2018

Copy link to clipboard

Copied

I am trying to compose a book which includes both Arabic and English. I have downloaded the Middle Eastern Indesign version based on these instructions:

Screen Shot 2018-05-02 at 9.03.36 PM.png

But I am still not getting these options:

Screen Shot 2018-05-02 at 9.03.58 PM.png

I'm having a very hard time typing in Arabic without these options.. any help as to how I can get these to show up would be greatly appreciated. I got these screenshots directly from the Adobe website, so I assume they are all up to date..

Thanks

Views

706

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , May 03, 2018 May 03, 2018
When you have an existing CC applications installed, then you switch to a different language, its normal to see "Install" button beside all applications in the Adobe Desktop… don't panic this is a feature What is basically happening, is that what ever Adobe applications you've installed earlier doesn't support Arabic. When you switch the language, it is allowing you now to install yet another copy with Arabic support. Having said that, you cannot have two copies of InDesign of the same version, ...

Likes

Translate

Translate
Adobe Employee ,
May 02, 2018 May 02, 2018

Copy link to clipboard

Copied

Hi,

Please check if the below steps help:

1. With current language settings, uninstall InDesign

2. Change to the previous language setting you had (English maybe?) and uninstall InDesign

3. Clean both cache and preferences for InDesign. See: Troubleshooting 101: Replace, or "trash" your InDesign preferences [Locked]

4. Now change language to " " and reinstall InDesign

-Aman

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 02, 2018 May 02, 2018

Copy link to clipboard

Copied

Hi,

Thanks for your prompt reply.

I uninstalled my current Arabic version, but when I change the preferences language back to what I had before (English North America), it is showing all of my apps as though I never installed them.. even though I have Illustrator, Photoshop, Indesign, Dreamweaver, Acrobat, and Bridge installed.

Screen Shot 2018-05-02 at 10.29.22 PM.png

I did the cache reset as well, but still face the same issue. I tried uninstalling it from the uninstall option in finder, but it is not doing anything when I click it. I tried uninstalling other adobe apps through this method, and those actually do uninstall. For some reason it's just the indesign one thats giving me issues.Screen Shot 2018-05-02 at 10.35.06 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 03, 2018 May 03, 2018

Copy link to clipboard

Copied

When you have an existing CC applications installed, then you switch to a different language, its normal to see "Install" button beside all applications in the Adobe Desktop… don't panic this is a feature

What is basically happening, is that what ever Adobe applications you've installed earlier doesn't support Arabic. When you switch the language, it is allowing you now to install yet another copy with Arabic support. Having said that, you cannot have two copies of InDesign of the same version, so you'd better choose an older version like CC2017 for Arabic.

Check this topic if you're an Arabic reader.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 03, 2018 May 03, 2018

Copy link to clipboard

Copied

Thanks a lot! That solved the issue of the preferences showing up.

Unfortunately I'm facing another issue now.. The majority of the Arabic I am using is inline with English text. However Arabic text only shows up connected in the correct manner when it is on its own (on a separate line or table cell) with its own paragraph style in Arabic. If I use an English paragraph style, and set the Arabic words in an Arabic character style, the Arabic letters show up the the reverse and are not connected. (see column 3 in attached image). Please let me know how I can fix this.

If I do the opposite (Arabic paragraph style, and English character style) that works. But this will much harder to work with as the majority of my text is in English.. just some words in between are in Arabic.

Thanks

Screen Shot 2018-05-03 at 11.48.09 AM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 03, 2018 May 03, 2018

Copy link to clipboard

Copied

I suspect that you're using "Adobe Paragraph Composer" in the Paragraph Style.

Edit your Paragraph Style, choose "Justification" from left pane, and make sure to have "Adobe World-Ready Paragraph Composer" instead.

Worldready.jpg

Make sure to check your document thoroughly after above change as this change will affect text in other pages, tables, and paragraphs where ever you applied the style.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 04, 2021 Jul 04, 2021

Copy link to clipboard

Copied

HI

How to solve same issue for Isolated version , its not online 

 

Regards 

ALI 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

LATEST

Ali, Adobe FRL license allow you to download a Middle Eastern version. Just choose the Language option (United Arab Emirates), then uncheck "Use OS Locale".

Here is the guide for creating an FRL package… https://helpx.adobe.com/enterprise/using/frl-offline-deployment-guide.html

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines