Weird ligature issues

Community Beginner ,
Feb 15, 2011 Feb 15, 2011

Copy link to clipboard

Copied

I work at a printing company and we do prepress on InDesign CS5 print jobs. We have ran into a type problem that we would like to know if others have had and if there is a preventative solution for. We've had two InDesign CS5 jobs develop this strange problem in the past month.

If automatic ligatures are turned on (and they are invariably), certain letter pairs will swap out with single glyphs as if they are ligatures despite the fact that they should not be ligatures. Once you turn automatic ligatures off, the pairs go back to the way they are supposed to be (but, all your good ligatures go away as well).

Here is an example:

In the document I have currently, the pairs ek and eh convert to the ligature glyph fi and the > symbol. Thus, if I type "seek behind", you would get "sefi b>ind". Turn off the automatic ligatures, and the problem goes away.

This problem is particularly insidious in that there is no warning for it. You load up the fonts, you open the InDesign file, and the pairs have changed themselves since the last time it was opened. If you aren't looking for it, you will not notice that it has changed.

Has anyone seen this problem or know what causes it? What preventative measures can be done to keep it from occurring other that manually turning off ligatures on all text in all InDesign jobs?

Views

32.6K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 20, 2011 Dec 20, 2011

Copy link to clipboard

Copied

This is a little intresting Knowlege that might help

Failed character pairs are in red and always offset by the same value (ie hk is offset by 3, il is offset by 4, sy is offset by 13)

If the pattern holds true, then all of these letter pairs are suspect for fi and fl, so it may not actually be so random as we suspect that their is a coding issue in the ligature engine in indesign that is getting messed up. when reading a font.

    

                 

fi fl
1adag
2be bh
3cfci
4dgdj
5ehek
6fi fl
7gjgm
8hkhn
9ilio
10jmjp
11knkq
12lolr
13mpms
14nqnt
15orou
16pspv
17qtqw
18rurx
19svsy
20twtz
21uxua
22vyvb
23wzwc
24xaxd
25ybye
26zczf

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 20, 2011 Dec 20, 2011

Copy link to clipboard

Copied

Yup, that doesn't seem at all surprising to me. It could also be an issue with the font, because opentype fonts have fairly complicated ligature rules embedded in them; it's really a programming language, I believe.

So it could well be a complex interaction between InDesign and the font's ligature coding.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 20, 2011 Dec 20, 2011

Copy link to clipboard

Copied

The only monkey wrench is that it has happened to Type 1 Postscript fonts.

So it still leads me to think its in indesigns Ligature coding.

One of the tests i ran the other day we had a opened a plain text file up on another machine typed in some specific word like john and others.

Made sure the text file had ligatures set on. The was the Mac OSX's TextEdit program. We then brought the file to the other computer which we knew had the hn issue in a Indesign file.

We made sure we moved the fonts to the user system folder removing it from the indesign folder.

Indesign file still had problems.

Opening the TexEdit file it showed no problems. Then I copyed and pasted the text from the TexEdit file into indesign and the joÚ  appeared in the new text.

This is why I really believe its Indesign issue since i am not seeing this issue in any other program such as Microsoft word, Quark 7 or TextEdit.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 20, 2011 Dec 20, 2011

Copy link to clipboard

Copied

More intresting testing of the issue.

1.)I loaded the file in question to my desktop.

2.) I placed all the fonts in a folder called Document Fonts in the same folder as the Indesign file.

3.) I open the job up the Ligature issue does not happen.

4.) I then close the file rename the fonts folder to Document Fonts1

5.) I then place these exact same fonts into the Adobe Indesign Cs5 > Fonts folder

6.) Open the same indesgn file up and the Ligature issue shows up again.

7.) I leave the fonts in the font folder then close Indesign

8.) I change the name of Document Fonts1 back to Document Fonts open the indesign file up again and the Ligature issue is gone.

IDM file

I did not see anything jumping out at me that is wrong with the file when I cracked it open.

I still think its Indesign Program issue since the file appears to be ok.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 20, 2011 Dec 20, 2011

Copy link to clipboard

Copied

Mattwbrt wrote:

More intresting testing of the issue.

1.)I loaded the file in question to my desktop.

2.) I placed all the fonts in a folder called Document Fonts in the same folder as the Indesign file.

3.) I open the job up the Ligature issue does not happen.

4.) I then close the file rename the fonts folder to Document Fonts1

5.) I then place these exact same fonts into the Adobe Indesign Cs5 > Fonts folder

6.) Open the same indesgn file up and the Ligature issue shows up again.

7.) I leave the fonts in the font folder then close Indesign

8.) I change the name of Document Fonts1 back to Document Fonts open the indesign file up again and the Ligature issue is gone.

If you have a folder in the same directory as the .indd file named Document Fonts ID will use the contents of that folder, if it can, but will not even look at them if you change the name. It looks to me like the issue is with the InDesign fonts folder. Have you tried uninstalling and reinstalling ID after running the clean tool?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 20, 2011 Dec 20, 2011

Copy link to clipboard

Copied

Intresting what I did instead of reinstalling the Indesign i renamed the Indesign Font folder and then made a new folder calling it the same name in the indesign folder.

placed the fonts in that folder and the ligature issue has yet to reappear in the file on that machine so far.

Not sure if that is anything of news since i can rename the job font folder place that in the bad folder and it worked as well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 21, 2011 Dec 21, 2011

Copy link to clipboard

Copied

Having done some more research into this issue.

Their is something wrong in the Indesign Ligature protical.

I have an indesign file that is set up with the previous list of Ligatures based off the fi and fl.

I load various different fonts to the Adobe fonts folder even after having made a new one to make sure its clean.

When the "hn" messes up so does the "hk"

I tested this on the Job I had that the "SY" was messing up and the "SV" messed up and it only messed up in keying the SY and SV and upper case.

I tested another job where the "il" was causing issues in small caps and I loaded the fonts before applying the small caps to the ligature list and the "il" "io" was messing up.

Once i applied the small caps to the font in Indesign the entire font messed up. I was getting Cc Bb for and other characters for the different pairs.

I have been able to replicate these issue pretty quickly now.

Seems removing and placing the fonts in and out of the Adobe Indesgin font folder is how you get the file to break.

I have been running tests with keeping the fonts with the indesign files named Document Fonts for some reason it will not always see my postscript fonts in that situation.

So these tests I can not verify that the solution to the problem is Document Fonts.

I have placed another bug request in to adobe to look into this.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 21, 2011 Dec 21, 2011

Copy link to clipboard

Copied

Matt:

I have placed another bug request in to adobe to look into this.

Just for clarity, the way to get Adobe to respond is to open a Support Case, at http://adobe.com/go/supportportal.

If you just drop a note in the wishform (http://adobe.com/go/wish), you will get no tracking, no followup, and given the realistic timeframes of software development, I would guess your bug is very unlikely to be fixed for CS6, which informed guesstimators expect to ship in April/May 2012, about a year after CS5.5 shipped.

So, again, if you want your bug fixed, please open a support case with Adobe, and ensure that they give you a Bug # after they confirm your bug. They may try to charge you $40 for the privilege, if you don't have a support contract. They'll credit that back to you that if they can confirm your bug, which it sounds like they should be able to do.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 19, 2016 Mar 19, 2016

Copy link to clipboard

Copied

I am now also experiencing this issue. The most common one for me is the "hn"-to-"Ÿ" substitution, but others do occur, as well.

It was never a problem in CS4, 5, or 6, but now that I've upgraded to CC2015, I see it in a number of files with several fonts. I have validated the fonts with Font Book, and they all check out just fine. This issue only occurs in InDesign -- no other application, Adobe or non-Adobe.

For me, quitting and re-starting ID doesn't help. However, I can cure the problem temporarily (for a day or two or three) by deleting the ID Caches located in ~/[my folder]/Library/Caches/Adobe InDesign/Version 11.0. But the problem always re-occurs in seemingly random files -- files created in CC2015, or converted from previous ID versions -- it doesn't matter.


It looks as if the issue is in the ID Caches files. Somehow, they must be repeatedly getting corrupted.

I only have one third-party plug-in. I have tried deleting that plug-in, but the problem still persists -- with or without it -- so that doesn't seem to be the problem.

Since this problem has shown itself through many versions of ID, and many OS versions, it clearly must be an InDesign issue. The question is: why?, and why for only some of us?

While it seems like a relatively minor problem, I see it as a potential business-killer. Already, one client has expressed great concern about needing to re-proof everything, and if we go to press with this problem undiscovered in a file, I might have to pay for entire books being pulped and re-printed.

I see that entries on the Adobe Forum stopped in December 2011. Was a solution found? I really need help with this, if you can offer any suggestions.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 19, 2016 Mar 19, 2016

Copy link to clipboard

Copied

Try creating a new user in System Preferences > Users & Groups. There could either be corruption or third party software conflict in your current user area causing the problem. In the new user, launch InDesign before anything else and see if the problem re-occurs.

It's the fact that it can be temporarily changed by deleting the cache files, but the problem reoccuring that makes me think this is possiblity/likelihood.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 29, 2016 Mar 29, 2016

Copy link to clipboard

Copied

It appears that most (if not all) of the anomalies and erratic behavior that I have been seeing was caused by the presence of two Symbol fonts installed. The Mac OS installs its version of Symbol, and it turns out that MathType also installs its version of Symbol, this time in the ~/Library/Fonts folder. The presence of these two versions of Symbol was definitely causing a lot of erratic behavior (including the constant corruption of the cache files) in ID only. (All my other apps seemed to have no problems, but then again, ID has a very robust and complicated type engine compared to other apps.)

I still don't know if it also was the cause of the weird ligatures. That was occasional enough that that problem might still be hanging around. I'll keep working in ID for another month and check back in to report if the presence of two Symbol fonts was causing that problem, as well!

To be continued . . .

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 24, 2016 Apr 24, 2016

Copy link to clipboard

Copied

No such luck. ID behaved itself for nearly a month, but just yesterday I opened a file and there, again, was the "hn" to "Ÿ" ligature all through the book.

If this had been sent to press, it could have easily cost me $30,000 or more to have the book pulped and reprinted! This problem could easily kill my business!

Adobe: you need to really spend some time and effort to fix this!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jun 22, 2016 Jun 22, 2016

Copy link to clipboard

Copied

Okay, while not the most elegant, we have found a workaround that works:

We tested our solution on a live case and it worked consistently, and was reproducible. We may not have effected a cure for cancer, but we have a cure now for bad ligatures!

We found, like others did, that the bad letter pairs were consistent within a font. The bad letter pairs for us were “eh” and “ek” and so far as we have been able to determine, only occur in Myriad Pro Regular and Myriad Pro Light Italic. The same words set in Myriad Pro Regular worked just fine.

So, your GREP code in your Paragraph Style will be: e(h|k)

Apply Character Style: NO Ligatures (style is set to conditions to turn off ligatures, without effecting any other characteristics of the font).

An easy way to find what bad letter pairs are occurring in your font is to go to Preferences > Composition, and select Substituted Glyphs, and click OK. This will highlight all places that ligatures are being used both correctly, and incorrectly (it also highlights other things, such as ALL CAPs applied to lowercase letters, but that doesn't concern us right now). A quick look over these yellow highlights will show you bad pairs, and then you would write your code similarly.

For those not terribly familiar with GREP code, this e(h|k) simply tells it to look for patterns where a lowercase e is followed by either a lowercase h or a lowercase k. If you only had one bad letter pair, say "ag" for instance, you could write your code as simply: ag


So, while this doesn't solve the reason why the corrupt ligatures are occurring, it does keep them from effecting the work, without having to turn off ligatures where they do belong.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 22, 2016 Jun 22, 2016

Copy link to clipboard

Copied

I think the GREP would be better written as e[hk] which uses the two-character class [hk] rather than the "or" statement.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jun 22, 2016 Jun 22, 2016

Copy link to clipboard

Copied

Thanks. I'm by no means a GREP master, so for my own edification, can you explain how that is better — just because it is less characters, or gets read in faster, or is less prone to errors, or ??

I'm in the middle of writing this into all of our templates that are effected by this, so I want to make sure: 1. that I am writing the best code, and 2. understanding why it is better, so that I can effectively apply it to other code I'm writing.

P.S. when it comes to GREP, you, Jong, and Blatner are my heroes, so I respect your assessments.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 22, 2016 Jun 22, 2016

Copy link to clipboard

Copied

I'm not in the same league with the other guys, so I can't explain what's happening in the execution, but a class is always going to execute faster and cleaner than an or statement.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jun 22, 2016 Jun 22, 2016

Copy link to clipboard

Copied

Okay, cool. Class, it is then. Fortunately, I hadn't gotten very far into the templates, so it was easy to go back and change the ones that were already done.

P.S. Sitting under David Blatner's teaching was one of the best experiences in my career. I was an Apostle of Quark until then, using InDesign begrudgingly. He showed me the light. I now build GREP into almost every template I create, and it's taken jobs that would have take hours down to a matter of minutes. They are easier for the typesetters to use, and more foolproof. And I keep detailed notes on what works and what doesn't, what things are worth the time, and which ones unnecessarily slow the program down, without delivering sufficient benefit. While you may not consider yourself on the same level, I've followed your posts and appreciated your input over the years. You are a true benefit to the InDesign community.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 22, 2016 Jun 22, 2016

Copy link to clipboard

Copied

Thanks for your kind words.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 17, 2017 Jan 17, 2017

Copy link to clipboard

Copied

Remove Ligatures from Entire Text Box

You need to do this with no document open to make this a default setting for any new documents you create.

If your document is open:

  1. Select the text box that contains ligatures. You can also complete the following steps prior to creating a text box.
  2. Click on the "Window" / "Type & Tables" / "Character" to open your Character pallet. (Type pallet)
  3. Click on the character panel flyout menu at the top right of the character pallet.
  4. Deselect "Ligatures."

With no document open:

  1. Open indesign.
  2. (Before opening any document Click on the "Window" / "Type & Tables" / "Character" to open your Character pallet. (Type pallet)
  3. Click on the character panel flyout menu at the top right of the character pallet.
  4. Deselect "Ligatures."

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 31, 2017 Jan 31, 2017

Copy link to clipboard

Copied

I ran into this issue mid December 2016. I found that after copying and pasting type, any occurrence of "technology" came out as "tecÜology". This happened in three separate docs in cc2017. Font was Avenir LT STD. I always run the current cc build.

During the same week, I was working in cc2015 (for a separate client) and had the work "technology" come out as "tecĂology".

I found in both of the first case that if I typed into the document the letters "hn" they would instantly append into Ü in the cc2015 version.

The problem did not persist after the end of December.

I am trying to figure out a way to recreate the issue so I can properly trouble shoot the issue. Anyone find a way to make this error consistently happen yet? Does anyone know of a way to tell certain ligatures to automatically append (as in the way it happens using a Japanese language set)?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 31, 2017 Jan 31, 2017

Copy link to clipboard

Copied

Remove Ligatures from Entire Text Box

You need to do this with no document open to make this a default setting for any new documents you create.

If your document is open:

  1. Select the text box that contains ligatures. You can also complete the following steps prior to creating a text box.
  2. Click on the "Window" / "Type & Tables" / "Character" to open your Character pallet. (Type pallet)
  3. Click on the character panel flyout menu at the top right of the character pallet.
  4. Deselect "Ligatures."

With no document open:

  1. Open indesign.
  2. (Before opening any document Click on the "Window" / "Type & Tables" / "Character" to open your Character pallet. (Type pallet)
  3. Click on the character panel flyout menu at the top right of the character pallet.
  4. Deselect "Ligatures."

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 31, 2017 Jan 31, 2017

Copy link to clipboard

Copied

Ligatures needed to be present on one of the jobs. On the 2nd, once I noticed the issue I just turned them off. The job that needed the ligatures on was 88 pages. It can't be an all or nothing solution.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 31, 2017 Jan 31, 2017

Copy link to clipboard

Copied

Also, I am actually looking for repeatable errors. I can not offer my client a solid solution without being able to test said solutions.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 12, 2019 Apr 12, 2019

Copy link to clipboard

Copied

Hi,

I am working on reproducing this issue. However i am unable to do so. I would like to know, some commonalities amongst the configurations in which the issue is faced.

For example:

  • Does the issue occur when MathType is used?
  • Does the issue occur when Symbols fonts are used?
  • Does the issue occur only when fonts are placed in InDesign fonts folder?
  • Does the issue occur after using InDesign for a considerable amount of time?
  • Does the issue occur when exporting InDesign document to PDF or in other formats too?
  • Some concrete steps to reproduce the issue?
  • Any other common aspects or additional information?

I would appreciate if you can share the sample files with which the issue is seen

Also, do vote for this issue here: InDesign False Ligatures Bug – Adobe InDesign Feedback

I did note that there is a pattern- whenever fi is changed-so is fl, whenever hk is changed so is hn, whenever io is changed so it in. Thanks for pointing this pattern of these false ligature

-Aman

amaarora@adobe.com

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 12, 2019 Apr 12, 2019

Copy link to clipboard

Copied

LATEST

The pattern you noticed is in the glyph ids --InDesign applies OpenType functions (defined by glyph ids) to the wrong font.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines