• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

When importing in Trados, IDML is full of cf tags

New Here ,
Dec 06, 2023 Dec 06, 2023

Copy link to clipboard

Copied

When we are importing the IDML file (exported from InDesign) in Trados for translation, we get to see lot of cf tags all over the file. The translation team is having a hard time, instead of 1 hour task, it is taking them almost 8 to 9 hours to clean the file. 

I have attached the snip of the issue.

Please guide. 

snip1.PNG

 

 

TOPICS
Import and export

Views

164

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 06, 2023 Dec 06, 2023

Copy link to clipboard

Copied

This is not something InDesign users can help you with. You should contact Trados tech support to get help with the issue.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 06, 2023 Dec 06, 2023

Copy link to clipboard

Copied

Why do you have to "clean" those tags? You should ignore them and translate everything between those tags ?

 

▒► ID-Tasker / ID-Tasker Server - work smart not hard ◄▒

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 06, 2023 Dec 06, 2023

Copy link to clipboard

Copied

Usually, after finishing a translation, the translator has to process the whole file and confirm the location of all tags or format painting or whatever. It's an additional step that a) isn't textual in nature, and b) usually has some kind of clunky interface where it takes Way Too Many Clicks to finalize. So translators are often reluctant to perform it, and cleaning it up as a non-translator after the fact can be a hassle. 

 

If you look at the OP's sample, pretty much every sentence is surrounded with "no character style" tags. So in an ordinary situation, the translators would only have to go through the tag cleanup clicks for the Bold-RED style, two cleanup bits in the sample presented. Instead, it looks like every single sentence is surrounded with useless tags, radically increasing the post-TRX cleanup work. 

 

Which reminds me!  There's a tool for this problem. @Saraswati33985476h28w  you should go to the Trados app store and download "Cleanup Tasks". It has a tool for removing tags, and I think you could just remove all instances of the cf tag with maybe three clicks. 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 06, 2023 Dec 06, 2023

Copy link to clipboard

Copied

But removal of those tags - will remove applied formatting - and returned file will be "useless"? 

 

▒► ID-Tasker / ID-Tasker Server - work smart not hard ◄▒

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 06, 2023 Dec 06, 2023

Copy link to clipboard

Copied

It appears that you're seeing the result of manual formatting (local overrides) being used in the INDD layout file, rather than Paragraph and Character styles.

 

Whoever (or whatever automated technology) created the INDD layout file needs some training in how to format and lay out the document using only Paragraph and Character styles.

 

Manual formatting gets embedded into the text content stream inside the file, which is what is shown in your screen capture. Causes severe problems for all technologies and prevents them from easily, quickly, and accurately processing the text content.

 

To view where in the INDD layout that manual formatting/override has been used, turn on the Style Highlighter button in the upper right of the Paragraph Styles panel. It will show all overrides in blue-green, and once identified, the InDesigner can then deal with them appropriately (such as replace the overrides with styles). Switch the highlighter button on/off to view the overrides:

 

Text as it appears in InDesign and in print.Text as it appears in InDesign and in print.

 

With the Style Highlighter turned on, manually formatted sections are highlighted in "swimming pool" green.With the Style Highlighter turned on, manually formatted sections are highlighted in "swimming pool" green.

 

I've attached a sample INDD and IMDL file for you to test with your publishing system.

 

I don't know how your system works with files, but you might still see indicators of where styles were used. However, they will be consistent throughout the document and should be very easily searched/replaced/deleted if you don't need them at all, or mapped to your system's utility to format the text.

 

Let us know if this identifies the problem you're having.

 

|    Bevi Chagnon   |  Designer & Technologist for Accessible Documents
|    Classes & Books for Accessible InDesign, PDFs & MS Office |

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 06, 2023 Dec 06, 2023

Copy link to clipboard

Copied

LATEST

Thanks Bevi for the details. I am afraid I can't download the attached files. Can you please share them again.

Thanks again!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 06, 2023 Dec 06, 2023

Copy link to clipboard

Copied

Back when I worked with Trados, this was unfortunately pretty typical. You can reduce the tag cleanup a fair bit by starting with an InDesign file that's actually been prepped for translation with styles carefully applied thoughout. You can see from the tag contents that it's all locally applied formatting instead of proper paragraph and character styles. 

 

So, proper preparation before processing in Trados is part of the issue, here. But also there's a setting in Studio that I can't remember the exact name of, it's something like "Show formatting but hide recognized tags" that will make it make a bit more sense to your translators & minimize post-Trados tag cleanup. Maybe View -> Options -> Toggle something? 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines