• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
3

Windows Explorer shows generic icon for INDD files

Explorer ,
Feb 01, 2024 Feb 01, 2024

Copy link to clipboard

Copied

Am using InDesign 2024 version 19.1X64 on a computer running Windows 11 Enterprise version 22H2.

All of a sudden, Windows Explorer stopped showing an InDesign application icon for files made and saved with InDesign 2024. Shows a generic icon instead. Curiously, InDesign Markup Language files show the correct program icon.   Note: redacted the file names in the screenshot because the docs are still in draft status.
indesign icon missing.png

I right-clicked the file icon and chose properties, and INDD files are assigned to InDesign 2024.
INDD poperties.png

And I have used Windows 11's Default Programs control panel to map all INDD files to InDesign 2024.
But the  icons for INDD files still show up generic.
Do I need to uninstall and reinstall InDesign to get the correct icon to appear?

TOPICS
How to , Performance

Views

322

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 01, 2024 Feb 01, 2024

Copy link to clipboard

Copied

Did you uninstall ID 2023 after installing 2024? 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 01, 2024 Feb 01, 2024

Copy link to clipboard

Copied

After making sure InDesign 2024 worked (not the newest computer), I removed previous versions, yes.
I did not delete the preferences for previous versions (there were issues getting INDD 2024 to port them over to the new version) -- until I read your post this morning. Did so, and rebooted the computer. That did not solve it. Am on production deadlines, so it will be a couple of days before I can try removing INDD 2024, rebooting, and reinstalling it. That will be my next move.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 01, 2024 Feb 01, 2024

Copy link to clipboard

Copied

Removing 2023 AFTER installing 2024 is probably the cause. If so, I would think doing an uninstall/reinstall of 2024 should fix it.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 06, 2024 Feb 06, 2024

Copy link to clipboard

Copied

Uninstalling InDesign 2024 and all of my settings  for it (and 2023) did not help. File icons for .INDD still showing generic. It did create quite a scary situation: When I started INDD up after doing the uninstall, deleting preferences, and rebooting, it was stuck showing "touch " with some kind of animation, and the InDesign window ran off the screen! Tried clicking my mouse to change that, but nothing happened! Then I remembered: My laptop is docked to fullsize displays and I normally run with the lid down. My laptop is "convertible," (screen can be used as a touchscreen). And had the same issue when I first moved to Creative Cloud.  InDesign was set, by default, to run on touch screeen if it can't find a keyboard. After a lot of screen size adjustment, finally was able to click in its menu and convince InDesign NOT to run in "touch" mode ! Yessir, youbetcha I went into INDD's Settings and cleared the checkbox: "Switch to Touch Workspace when the Keyboard is detached."
Clear the checkboxClear the checkbox
Next I had to restore all of the deleted custom settings that I use with InDesign. Fortunately, had kept a copy of them in the Cloud on OneDrive, and was able to recover them using Microsoft's instructions. InDesign is working just fine now. The icons are still generic. Methinks that's a Windows problem, not an Adobe problem.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 09, 2024 Feb 09, 2024

Copy link to clipboard

Copied

Checked with our work's PC Help Desk, after uninstalling and reinstalling did not solve the problem, and it appears to be an issue with Windows 11, not InDesign.  Yesterday, the computer also deleted My customized InDesignpreferences for Workspace, Keyboard Shortcut, and user dictionary, and I had to once again restore them from a backup I keep on the Cloud -- just in case of things like this.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 05, 2024 Jul 05, 2024

Copy link to clipboard

Copied

LATEST

And did You find any solution?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines