Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Working in RGB in InDesign

New Here ,
Aug 23, 2016 Aug 23, 2016

Copy link to clipboard

Copied

Good evening,

I am trying to put together a web - RGB - version of an Annual Report I've just wrapped up. The report was created in CMYK and now, when I bring in Illustrator files with updated color profiles (switched from CMYK to RGB), the swatches and display colors are converted to CMYK regardless. I'm having trouble figuring out how to keep them in RGB.

As in, if in the Illustrator doc the colors are set up as RGB spot color swatch with an RGB overall document profile. When I place it into inDesign, it converts the doc and imported swatch to CMYK. If I create a new swatch via InDesign, it shows up in RGB no problem. Ugg... I don't often fell like a dumb-dumb in InDesign, but this is very frustrating. Any help would be appreciated.

Thank you!

KR.

Views

21.6K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Aug 24, 2016 Aug 24, 2016
Unlike Illustrator, InDesign allows you to have a mix of different color modes on a page—RGB, Lab, CMYK, or placed grayscale. A document has two profiles assigned—an RGB profile to handle the preview of RGB colors, swatches, and placed RGB objects with no profile, and a CMYK profile to handle the preview of CMYK colors, swatches, placed CMYK with no profile, and grayscale objects.
if in the Illustrator doc the colors are set up as RGB spot color swatch with an RGB overall document profile. When I
...

Likes

Translate

Translate
Enthusiast ,
Aug 23, 2016 Aug 23, 2016

Copy link to clipboard

Copied

Press Alt+E+B and choose Document RGB. Hope this is the option you are looking for...

Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 11, 2021 Aug 11, 2021

Copy link to clipboard

Copied

This shortcut didn't work for me. Can you explain how I can get there from the menu? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 11, 2021 Aug 11, 2021

Copy link to clipboard

Copied

Do you mean this?

Edit > Transparency Blend Space > Document RGB

Edit > Transparency Blend Space > Document CMYK

 

Regards,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 11, 2021 Aug 11, 2021

Copy link to clipboard

Copied

LATEST

Thanks! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 24, 2016 Aug 24, 2016

Copy link to clipboard

Copied

Unlike Illustrator, InDesign allows you to have a mix of different color modes on a page—RGB, Lab, CMYK, or placed grayscale. A document has two profiles assigned—an RGB profile to handle the preview of RGB colors, swatches, and placed RGB objects with no profile, and a CMYK profile to handle the preview of CMYK colors, swatches, placed CMYK with no profile, and grayscale objects.

if in the Illustrator doc the colors are set up as RGB spot color swatch with an RGB overall document profile. When I place it into inDesign, it converts the doc and imported swatch to CMYK.

Is there a reason for defining a spot color? Does the annual report print with extra spot plates? Try setting the AI RGB color to process not spot, and if there is transparency on the ID page set your Transparency Blend Space to RGB. Also turn off Overprint Preview, which forces the preview of all color into your document's CMYK profile.

When you export the report to PDF you can convert all color into a single RGB space, so you can have a mix of color spaces and export to a uniform color space. Something like this which would convert everything into sRGB:

Screen Shot 2016-08-24 at 9.30.43 AM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines