Highlighted

All my Creative Cloud .ai graphics loading with white background

Community Beginner ,
Jan 08, 2019

Copy link to clipboard

Copied

For no reason that I can comprehend all new vector graphics I pull from my creative cloud library that were created and saved with Illustrator are now importing to Indesign with white backgrounds. It is the same result if I choose to do so via the place command. Previously existing graphics that are linked to a creative cloud library display as intended. I've checked and it is EVERY vector graphic, though none of the files have white backgrounds in them.

Community Beginner
Correct answer by MDKTM | Community Beginner

So I'd say that's a missing feature. I was able to resolve the issue by first placing an object outside of my libraries and checking transparent background. After doing that all items from my library imported properly. It would be more intuitive to have a global option that applies to libraries instead of a gimmick outside of them.

Views

287

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

All my Creative Cloud .ai graphics loading with white background

Community Beginner ,
Jan 08, 2019

Copy link to clipboard

Copied

For no reason that I can comprehend all new vector graphics I pull from my creative cloud library that were created and saved with Illustrator are now importing to Indesign with white backgrounds. It is the same result if I choose to do so via the place command. Previously existing graphics that are linked to a creative cloud library display as intended. I've checked and it is EVERY vector graphic, though none of the files have white backgrounds in them.

Community Beginner
Correct answer by MDKTM | Community Beginner

So I'd say that's a missing feature. I was able to resolve the issue by first placing an object outside of my libraries and checking transparent background. After doing that all items from my library imported properly. It would be more intuitive to have a global option that applies to libraries instead of a gimmick outside of them.

Views

288

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 08, 2019 0
Adobe Community Professional ,
Jan 08, 2019

Copy link to clipboard

Copied

When you place the graphic, turn on "Show Import Options". In the Import Options dialog box, make sure that the "Transparent Background" checkbox is enabled.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 08, 2019 1
Community Beginner ,
Jan 08, 2019

Copy link to clipboard

Copied

I'm not seeing import options when placing directly from libraries.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 08, 2019 0
Adobe Community Professional ,
Jan 09, 2019

Copy link to clipboard

Copied

MDKFWTA  wrote

I'm not seeing import options when placing directly from libraries.

True. But unfortuanely the import options of CC Lbrary assets are the ones you were using the last time when placing an AI graphic file with InDesign's Place command.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 09, 2019 1
Most Valuable Participant ,
Jan 09, 2019

Copy link to clipboard

Copied

And the transparent background is a sticky setting.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 09, 2019 1
Community Beginner ,
Jan 08, 2019

Copy link to clipboard

Copied

So I'd say that's a missing feature. I was able to resolve the issue by first placing an object outside of my libraries and checking transparent background. After doing that all items from my library imported properly. It would be more intuitive to have a global option that applies to libraries instead of a gimmick outside of them.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 08, 2019 0
New Here ,
Jul 14, 2020

Copy link to clipboard

Copied

I've seen this solution on multiple forums, but it has not made a difference for me. I'm also not able to uncheck "white BG" from the place options panel, which isn't a problem with normal placing. Screen Recording  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 14, 2020 0
Adobe Community Professional ,
Jul 15, 2020

Copy link to clipboard

Copied

Hi Tomtomfest,

the resolution of your video is a bit low, but as far as I can see you are placing a png graphic for changing the background to transparency. PNG files have different import options. You need the import options of an Adobe Illustrator ai file.

 

Thanks,
Uwe Laubender

( ACP )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 15, 2020 0