Highlighted

Alternate glyphs not working

Community Beginner ,
Dec 07, 2017

Copy link to clipboard

Copied

Hi guys,

at work, we use a CC for Teams subscription. I have a bug that none of the others have and has remained throughout the installation of a newer version of InDesign and trashing the prefs.

If I type a new text I cannot select alternate glyphs; there is no on-context menu and if I manually select another version of the glyph it will just show the standard. If I use a file with text made by a colleague it works normally. We use macOS Sierra 10.12.6 with the latest version of InDesign.

Anyone know what's happening? I haven't been able to find it on this forum, nor by googling it. I'm hoping it's a simple setting I'm overlooking

Thanks!

Schermafbeelding 2017-12-07 om 14.25.37.png

Correct answer by Tiekerz | Community Beginner

Thanks everyone for your help. It isn't on World ready, and it's turned on in advanced, but your suggestions made me think and the solution was too easy

I checked language settings and discovered my standard language switched to Malayalam (granted, that is weird). I reset it and everything works fine.

Schermafbeelding 2017-12-08 om 09.18.17.png

I'll post how to change it in case someone else stumbles upon this thread with the same problem: open InDesign (but not a document) and go to your language settings (command T), set it to your preferred language (dutch in my case) and you're done.

Cheers!

Views

5.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Alternate glyphs not working

Community Beginner ,
Dec 07, 2017

Copy link to clipboard

Copied

Hi guys,

at work, we use a CC for Teams subscription. I have a bug that none of the others have and has remained throughout the installation of a newer version of InDesign and trashing the prefs.

If I type a new text I cannot select alternate glyphs; there is no on-context menu and if I manually select another version of the glyph it will just show the standard. If I use a file with text made by a colleague it works normally. We use macOS Sierra 10.12.6 with the latest version of InDesign.

Anyone know what's happening? I haven't been able to find it on this forum, nor by googling it. I'm hoping it's a simple setting I'm overlooking

Thanks!

Schermafbeelding 2017-12-07 om 14.25.37.png

Correct answer by Tiekerz | Community Beginner

Thanks everyone for your help. It isn't on World ready, and it's turned on in advanced, but your suggestions made me think and the solution was too easy

I checked language settings and discovered my standard language switched to Malayalam (granted, that is weird). I reset it and everything works fine.

Schermafbeelding 2017-12-08 om 09.18.17.png

I'll post how to change it in case someone else stumbles upon this thread with the same problem: open InDesign (but not a document) and go to your language settings (command T), set it to your preferred language (dutch in my case) and you're done.

Cheers!

Views

5.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 07, 2017 0
Adobe Employee ,
Dec 07, 2017

Copy link to clipboard

Copied

Hi,

Can you check the paragraph panel menu and let us know the composer? If it is Adobe world ready, then you wont see the blue underline below the glyph that on hover shows the alternative glyphs...

-Aman

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 07, 2017 0
Community Beginner ,
Dec 07, 2017

Copy link to clipboard

Copied

Th ecomposer is on Adobe world ready, but it used to work fine untill the CC 2018 update last month.

it always was on Adobe world ready

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 07, 2017 0
Adobe Employee ,
Dec 07, 2017

Copy link to clipboard

Copied

Hi,

It should not have worked after CC 2017.0 release of InDesign.

Can you please check that again?

You can still apply the alternative via character panel or the glyph panel.

-Aman

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 07, 2017 0
Community Beginner ,
Dec 07, 2017

Copy link to clipboard

Copied

Hi

It worked on CC 2017 without a doubt

i work with Hebrew all the time and World ready paragraph composer and used to work always worki with alternative glyphs in hebrew

this bug started ever since last update for CC 2018

Aviv

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 07, 2017 0
Adobe Community Professional ,
Dec 07, 2017

Copy link to clipboard

Copied

I remember that exclusion when it came out. If it showed up in CC 2017, it wasn't supposed to. See the documentation circled below:

ContextualMenu.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 07, 2017 0
Community Beginner ,
Dec 07, 2017

Copy link to clipboard

Copied

ok.

Parhaps it was Middle Eastern composer?

Did that change to the World ready?

I rememeber i used to switch glyphs in Hebrew

will it be fixed in the future?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 07, 2017 0
Adobe Employee ,
Dec 07, 2017

Copy link to clipboard

Copied

Hi,

Thanks Steve for citing the InDesign documentation. This was supposed to have been blocked since CC 2017 release(both the OpenType adornment and the blue underline which is seen on selecting a single character).

This was done purposefully due to some limitations.

If you feel this should come back then do add it here:Adobe InDesign Feedback

-Aman

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 07, 2017 0
Community Beginner ,
Dec 08, 2017

Copy link to clipboard

Copied

Thanks everyone for your help. It isn't on World ready, and it's turned on in advanced, but your suggestions made me think and the solution was too easy

I checked language settings and discovered my standard language switched to Malayalam (granted, that is weird). I reset it and everything works fine.

Schermafbeelding 2017-12-08 om 09.18.17.png

I'll post how to change it in case someone else stumbles upon this thread with the same problem: open InDesign (but not a document) and go to your language settings (command T), set it to your preferred language (dutch in my case) and you're done.

Cheers!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 08, 2017 2
Most Valuable Participant ,
Dec 08, 2017

Copy link to clipboard

Copied

No idea how ID ever managed to change your default settings on its own (did you recently upgrade from CC2017 to 2018?), but here is the underlying reason:

OpenType features are grouped primarily per script (different writing systems: Latin, Greek, Hebrew, Arabic, and so on). Only within each group of 'alphabets', features for separate languages may be defined.

What happens with this font is that it contains features for "Latin" only. Malayalam does not use the "Latin" writing system, and so InDesign tries to find features that apply to either "all" (properly called "DFLT") or this particular script. Which are not there, so you don't get any.

It happens to work again with your Dutch default because this does have the features defined in the "Latin" group, and the same is true, presumably, for all other European languages that use this particular alphabet.

A solution from the font creator's side would be to add all of the special features to all of the possible scripts/languages (or possibly to "DFLT" only), but ... there is no reason to! The font does not contain any special features for Malayalam, so as it is, the font "works as intended" – provided you indeed set the language correct!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 08, 2017 1
Community Beginner ,
Dec 08, 2017

Copy link to clipboard

Copied

Oh that's interesting, thanks for clarifying.

To answer your question, it's been a while since I upgraded but the problem has been around a while, maybe since then I don't know. That may sound ignorant (and it probably is ) but since I work for a newspaper I often work in predefined documents and the setting is correct, and for making ads most times I set my own breaks instead of letting InDesign do it (which is how I could've noticed sooner). Mind you I did switch back to dutch a few times the past weeks, but since it happened so irregularly it took a while for the penny to drop.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 08, 2017 0
Adobe Community Professional ,
Dec 07, 2017

Copy link to clipboard

Copied

It also needs to be turned on in Advanced Type Preferences:

InDesign CC080.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 07, 2017 0
New Here ,
Jun 24, 2020

Copy link to clipboard

Copied

Not sure if anyone is still having problems with this issue, but here is a possible solution. I am using CC 2020 and it would not let me use certain glyphs in photoshop. I removed the OTF font file type and installed the TTF of the font I want. I restarted photoshop and it works now. Before some of the glyphs did not work, now all of them work. Not sure what the difference is between the fonts but it worked. Hope it helps! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 24, 2020 0