Highlighted

Arabic character period in the wrong spot?

Community Beginner ,
Oct 28, 2014

Copy link to clipboard

Copied

Well this is an annoying problem.  I'm working with a bunch of Arabic text copied from a Word doc and pasted into InDesign CC.  And while the text is flowing in the right direction, the periods insist on winding up on the right margin at the end of the text instead of after the last character in the sentence, at the end of the line to the left.

I've set the character to Adobe Arabic Regular, the text to right justify, the Language under Character to Arabic, and the Paragraphs to Adobe World-Ready Paragraph Composer.

In Googling for solutions, I see instructions to Select the paragraph direction from the Paragraph panel (not an option in my Paragraph panel), choose Character Direction from the Character panel (also not an option), From the Story panel (Window > Type & Tables > Story), click a story direction (not available).  I've also tried adding spacing and hard returns before and after the period character, changing that character to another font and re-placing it, switching to single line vs. paragraph world-ready... nothing is working.

What am I doing wrong/how do I get the periods once and for all in the right spot?

Here's is a trick mentioned by another contributor a few days ago. Create a text frame and then Ctrl +Type/Fill with Placeholder Text. This will let you choose what to fill with. Choose Arabic. Create a new paragraph style and use it where needed.

Views

17.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Arabic character period in the wrong spot?

Community Beginner ,
Oct 28, 2014

Copy link to clipboard

Copied

Well this is an annoying problem.  I'm working with a bunch of Arabic text copied from a Word doc and pasted into InDesign CC.  And while the text is flowing in the right direction, the periods insist on winding up on the right margin at the end of the text instead of after the last character in the sentence, at the end of the line to the left.

I've set the character to Adobe Arabic Regular, the text to right justify, the Language under Character to Arabic, and the Paragraphs to Adobe World-Ready Paragraph Composer.

In Googling for solutions, I see instructions to Select the paragraph direction from the Paragraph panel (not an option in my Paragraph panel), choose Character Direction from the Character panel (also not an option), From the Story panel (Window > Type & Tables > Story), click a story direction (not available).  I've also tried adding spacing and hard returns before and after the period character, changing that character to another font and re-placing it, switching to single line vs. paragraph world-ready... nothing is working.

What am I doing wrong/how do I get the periods once and for all in the right spot?

Here's is a trick mentioned by another contributor a few days ago. Create a text frame and then Ctrl +Type/Fill with Placeholder Text. This will let you choose what to fill with. Choose Arabic. Create a new paragraph style and use it where needed.

Views

17.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Guru ,
Oct 28, 2014

Copy link to clipboard

Copied

Here's is a trick mentioned by another contributor a few days ago. Create a text frame and then Ctrl +Type/Fill with Placeholder Text. This will let you choose what to fill with. Choose Arabic. Create a new paragraph style and use it where needed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Oct 28, 2014

Copy link to clipboard

Copied

Thanks Ellis!  I don't know why that worked, but it did -- of course it means re-setting all of the boxes and fonts in my (originally English) document but at this point I'll take that over fighting with the existing boxes for the rest of the day.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Guru ,
Oct 28, 2014

Copy link to clipboard

Copied

If you use Arabic in a regular basis you'll be better off installing the English-Arabic version from your Creative Cloud desktop application.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Oct 28, 2014

Copy link to clipboard

Copied

You were most likely pasting from a Word document with right-to-left character flow into an InDesign document with paragraph with left-to-right paragraph direction. You mentioned setting your paragraphs to right justify, but RTL paragraph behavior and right-aligned text are two different things. Turning on the WRC and setting language to Arabic will get you most, not all, of the settings you need for correct display. That's why the Middle East edition (the English-Arabic version that Ellis mentions) exists - all of those settings that you see in the Help pages are in that version only.

(In fact, somewhere on that page, it says that the page only applies to ME versions of the software. I can't recall where it is, but it's conspicuously not in large print at the top of the page.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Oct 28, 2014

Copy link to clipboard

Copied

Thanks Joel -- if we end up doing any more of these I'll download the ME edition.  In the meantime, hopefully the intel posted in reply to my confusion can help other searchers -- y'all are the best!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
May 24, 2017

Copy link to clipboard

Copied

I now this is an old post but hoping for some help.

Am on mac CC2017 and tried this in Indesign by holding down Command and type >> file with placeholder text. I also tried with holding down CTRL and type >> file with placeholder text. Pasting still puts the period in the wrong position.

Our IT dept is having trouble installing in the arabic version even though we set the cloud prefs to English Arabic. Going to ask them to uninstall CC2017 and then install as there is a good cache that can get the Arabic Illustrator on my computer. Most of my work is in English so going to ask them to keep CC2015 and flip that setting that Adobe likes to move around and hide for keeping previous apps on computer.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
May 24, 2017

Copy link to clipboard

Copied

If the document you're working with was created in a Middle Eastern version of InDesign, then you better have a Middle Eastern version on your machine too so you can continue to work on this document without facing these weird typographical behaviour.

Your IT personnel can install another (older or newer) InDesign or another Illustrator copy on the same machine without the need to uninstall current copy, just let them follow below steps…

  • From the Adobe CC desktop menu, scroll up/down to find the section "FIND ADDITIONAL APPS", click on the "Previous Versions" drop menu and choose "VIEW PREVIOUS VERSIONS".

previous1.jpg

  • From the same Adobe CC desktop menu, click on InDesign "Install" button to access previous versions, this way you may download InDesign CC (2014) or CC (2017) but before you download, switch your Language to "English يدعم العربية" from the Preferences.

previous2.jpg

  • You may proceed to download InDesign CC (2015) with Arabic / Persian / Urdu capabilities now and have both InDesign versions on the same machine. This way you may run both InDesign versions at the same time if needed hence keeping your English version. But don't forget to switch Creative Cloud language in the Preferences menu back to English.

previous3.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
May 25, 2017

Copy link to clipboard

Copied

Thankyou Zaid. شكرا.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
May 26, 2017

Copy link to clipboard

Copied

You're welcome mike. عفواً

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Nov 24, 2017

Copy link to clipboard

Copied

Hi Zaid,

In Arabic, why the dot at the end of paragraph always moved to the right. See the last word of MikeGondek above. The word

سكرا

The dot is on the right, not in on the left side. Do you know how to fix it? Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Nov 26, 2017

Copy link to clipboard

Copied

ahmatm52743247  wrote

In Arabic, why the dot at the end of paragraph always moved to the right. See the last word of MikeGondek above. The word

سكرا

Do you mean here on the forum, or in InDesign?

Although we cannot do much for the forum behavior and where full stop shows on the wrong end of line, we can however control it in InDesign.

If you have InDesign يدعم العربية , then choose Paragraph Direction as shown below…

RTL.jpg

LTR.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Nov 26, 2017

Copy link to clipboard

Copied

Yes thats great answer. It resolves my problem.

However, another problem emerge. I cannot open .EPS file format with AI ME 2018. When I install AI ME 2018, I removed the old version (English 2017). Can I install the 2018 English edition together with ME edition?

Currently I reinstall 2017 English and it works well. But I want to use the latest version.


Thanks for the answer.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 28, 2018

Copy link to clipboard

Copied

Thanks alottttttttttttt Zaid, now I am working with two versions of illustrator, one for arabic one for english, seemed too much at first but it really answered my problem and smoothened my workflow. bless you for sharing.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 28, 2018

Copy link to clipboard

Copied

شكرااااااااااا

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 21, 2018

Copy link to clipboard

Copied

Thanks so much, it worked with me

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 28, 2019

Copy link to clipboard

Copied

InDesign Me change full stops to percent sign in Arabic fonts!

help!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 28, 2019

Copy link to clipboard

Copied

which font are you using?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 28, 2019

Copy link to clipboard

Copied

Adobe Arabic..but it happens to all Arabic fonts..

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 29, 2019

Copy link to clipboard

Copied

Is this happening every where even in Microsoft applications? Update your Operating System perhaps it will fix the issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Nov 08, 2016

Copy link to clipboard

Copied

Hi guys, I'm trying this as well but I can't edit my text afterwards. Is there a solution for this? It's pasted like an image. I want to give it some colour but I can't like this.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Nov 15, 2016

Copy link to clipboard

Copied

Hello!

I'm doing exactly the same but with the placeholder text I get now Lorem Ipsum...

If I have a sentence with English text it messes up my layout as you can see below.

Is there no way that it can work properly? No plug-in? I'm getting quite stressed of this problem at moment.

Schermafbeelding 2016-11-15 om 17.41.41.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Most Valuable Participant ,
Nov 15, 2016

Copy link to clipboard

Copied

There are lots of ways to make it work! If you have a subscription to Creative Cloud, you can install the Middle East/North Africa version of InDesign (Arabic/Hebrew toolset with English interface) and then you can get character-level control of direction, insert RTL or LTR parentheses, and so on.

If you're still using Creative Suite (or if you are using CC and want to work in CJK as well as RTL languages), then you can buy a plugin from in-tools.com that will let you set character-level direction. If you are still using Creative Suite and can't pay anything, there are some free scripts that will let you affect character direction.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 27, 2020

Copy link to clipboard

Copied

This worked for me, but I had to Ctrl + Command and then Fill with place holder for it to work. This is on a Mac platform.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
May 10, 2020

Copy link to clipboard

Copied

This solution is for html.  What you have to do is just add attribute dir='rtl' in the body or you can add where the issue is. It will change complete layout and all the issues will be fixed by just putting this. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...