Highlighted

Auto-activate adobe fonts does not work in Indesign

Participant ,
Oct 23, 2020

Copy link to clipboard

Copied

Every time I open a document that uses Adobe fonts, Indesign tells me I have missing fonts and makes me manually load them.  Why, when I have the fonts loaded in CC and set to auto-activate in Indesign, do I have to waste time doing this over and over? 

 

I am running Indesign 16 64bit on Windows 10 (updated to latest IND two days ago).  I have uninstalled the fonts and re-installed them, and I have exited CC and re-logged on.  Those actions had zero effect.

I haven't seen this exact question here, but I see many, many people describing problems with Adobe fonts, and the upshot is that they are dangerously unreliable.  I'm working on a yearly report right now that is the reason my department exists. Should I find some different fonts to use?

Adobe Community Professional
Correct answer by Bill Silbert | Adobe Community Professional

If the keyboard shortcut isn't working for you then try deleting preferences manually,

To do so:

For Macintosh Users: The User Library folder in which InDesign’s preferences are stored is hidden by default on most Macintoshes. To access it make sure that InDesign is closed and click on the desktop to launch a Finder Window (Command-N). With this window in column view follow the path User>Home folder (it’s the folder with an icon that looks like a house—it may have the user’s name rather than “Home”) and click on the Home folder. With the Option Key pressed choose Library from the Finder Go Menu. “Library” will now appear within the Home folder. Within the Library folder find the folder called Preferences and within it find the folder called “Adobe InDesign” and the file called “com.adobe.InDesign.plist” and delete both that folder and that file. When InDesign is next launched it will create new preference files and the program will be restored to its defaults.

For Windows Users: On Windows 7 and above the preference files are hidden. To find them go to the Control Panel and open Folder Options and then click the View tab. Then select “Show hidden files and folders” or “Show hidden files, folders or drive options” in Advanced Settings. Then delete (or rename) the folder at the end of this path: C:\Users\<USER>\AppData\Roaming\Adobe\InDesign\<Version #>\<Language>. Make sure that InDesign is closed when you do this. When you relaunch the program it will create new preference files and the program will be at its default settings.

The advantage of manually deleting preference files is that after you’ve reset up the program (make sure that no document window is open) to your liking, you can create copies of your personalized “mint” preference files (make sure that you quit the program before copying them—that finalizes your customization) and use them in the future to replace any corrupt versions you may need to delete.

TOPICS
Bug, Type

Views

94

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Auto-activate adobe fonts does not work in Indesign

Participant ,
Oct 23, 2020

Copy link to clipboard

Copied

Every time I open a document that uses Adobe fonts, Indesign tells me I have missing fonts and makes me manually load them.  Why, when I have the fonts loaded in CC and set to auto-activate in Indesign, do I have to waste time doing this over and over? 

 

I am running Indesign 16 64bit on Windows 10 (updated to latest IND two days ago).  I have uninstalled the fonts and re-installed them, and I have exited CC and re-logged on.  Those actions had zero effect.

I haven't seen this exact question here, but I see many, many people describing problems with Adobe fonts, and the upshot is that they are dangerously unreliable.  I'm working on a yearly report right now that is the reason my department exists. Should I find some different fonts to use?

Adobe Community Professional
Correct answer by Bill Silbert | Adobe Community Professional

If the keyboard shortcut isn't working for you then try deleting preferences manually,

To do so:

For Macintosh Users: The User Library folder in which InDesign’s preferences are stored is hidden by default on most Macintoshes. To access it make sure that InDesign is closed and click on the desktop to launch a Finder Window (Command-N). With this window in column view follow the path User>Home folder (it’s the folder with an icon that looks like a house—it may have the user’s name rather than “Home”) and click on the Home folder. With the Option Key pressed choose Library from the Finder Go Menu. “Library” will now appear within the Home folder. Within the Library folder find the folder called Preferences and within it find the folder called “Adobe InDesign” and the file called “com.adobe.InDesign.plist” and delete both that folder and that file. When InDesign is next launched it will create new preference files and the program will be restored to its defaults.

For Windows Users: On Windows 7 and above the preference files are hidden. To find them go to the Control Panel and open Folder Options and then click the View tab. Then select “Show hidden files and folders” or “Show hidden files, folders or drive options” in Advanced Settings. Then delete (or rename) the folder at the end of this path: C:\Users\<USER>\AppData\Roaming\Adobe\InDesign\<Version #>\<Language>. Make sure that InDesign is closed when you do this. When you relaunch the program it will create new preference files and the program will be at its default settings.

The advantage of manually deleting preference files is that after you’ve reset up the program (make sure that no document window is open) to your liking, you can create copies of your personalized “mint” preference files (make sure that you quit the program before copying them—that finalizes your customization) and use them in the future to replace any corrupt versions you may need to delete.

TOPICS
Bug, Type

Views

95

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 23, 2020 0
Adobe Community Professional ,
Oct 23, 2020

Copy link to clipboard

Copied

Try resetting your preferences.

 

Restore all preferences and default settings
  1. (Windows) Start InDesign, and then press Shift+Ctrl+Alt. Click Yes when asked if you want to delete preference files.
  2. (Mac OS) While pressing Shift+Option+Command+Control, start InDesign. Click Yes when asked if you want to delete preference files.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2020 1
Participant ,
Oct 26, 2020

Copy link to clipboard

Copied

That doesn't work.  I hit Shift+Ctrl+Alt after starting, held it during starting, and held it before starting, and I didn't get asked any questions about preferences or anything else.

 

Any other suggestions?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 26, 2020 0
Participant ,
Oct 26, 2020

Copy link to clipboard

Copied

By the way, I see the User Guide describing the same process for deleting preferences.  It still doesn't work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 26, 2020 0
Adobe Community Professional ,
Oct 27, 2020

Copy link to clipboard

Copied

I can only tell you you are doing it incorrectly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 27, 2020 0
Adobe Community Professional ,
Oct 27, 2020

Copy link to clipboard

Copied

If the keyboard shortcut isn't working for you then try deleting preferences manually,

To do so:

For Macintosh Users: The User Library folder in which InDesign’s preferences are stored is hidden by default on most Macintoshes. To access it make sure that InDesign is closed and click on the desktop to launch a Finder Window (Command-N). With this window in column view follow the path User>Home folder (it’s the folder with an icon that looks like a house—it may have the user’s name rather than “Home”) and click on the Home folder. With the Option Key pressed choose Library from the Finder Go Menu. “Library” will now appear within the Home folder. Within the Library folder find the folder called Preferences and within it find the folder called “Adobe InDesign” and the file called “com.adobe.InDesign.plist” and delete both that folder and that file. When InDesign is next launched it will create new preference files and the program will be restored to its defaults.

For Windows Users: On Windows 7 and above the preference files are hidden. To find them go to the Control Panel and open Folder Options and then click the View tab. Then select “Show hidden files and folders” or “Show hidden files, folders or drive options” in Advanced Settings. Then delete (or rename) the folder at the end of this path: C:\Users\<USER>\AppData\Roaming\Adobe\InDesign\<Version #>\<Language>. Make sure that InDesign is closed when you do this. When you relaunch the program it will create new preference files and the program will be at its default settings.

The advantage of manually deleting preference files is that after you’ve reset up the program (make sure that no document window is open) to your liking, you can create copies of your personalized “mint” preference files (make sure that you quit the program before copying them—that finalizes your customization) and use them in the future to replace any corrupt versions you may need to delete.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 27, 2020 2
Participant ,
Oct 28, 2020

Copy link to clipboard

Copied

No, you can only tell me that it works for you there.  I have done EXACTLY what you suggest and what the Adobe user guide specifies, and I have tried multiple variations on those instructions.  It * does * not * work here on this copy of indesign on this machine.

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 28, 2020 0
Participant ,
Oct 28, 2020

Copy link to clipboard

Copied

I knew about this and was going to try it this morning.  Thanks for not assuming I'm incompetent.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 28, 2020 0
tomhock LATEST
Participant ,
Oct 28, 2020

Copy link to clipboard

Copied

Thank you Bill Silbert.  As Eugene Tyson suggested, deleting the preferences appears to have worked.  When I opened my document, the fonts loaded automatically without forcing me to take some action.  Hopefully, this aspect of the program will continue to operate correctly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 28, 2020 0