Auto-zoom in InDesign 2017: intentional?

Community Beginner ,
Nov 17, 2016 Nov 17, 2016

Copy link to clipboard

Copied

Take a look at the video below. It shows me typing along in a zoomed window, when all of a sudden, InDesign yanks the zoom back to "Fit Spread in Window" for no apparent reason. The cursor is still on the same line as before. The trigger seems to have been that a paragraph was pushed off the bottom of that page, changing the location of the page break. The view does not update immediately after that event, but it does at the first pause.

I don't remember previous versions of ID doing this. Is it intentional, and is it possible to turn this off?

I also wonder if it might be a bug. When I choose the View -> Fit Spread in Window menu item, I notice that the menu item remains checked, even if I subsequently zoom in with the track pad. That's the situation that seems to give rise to this behavior. If I pick the Zoom Out menu item and then Zoom In, the check disappears from beside Fit Spread in Window and then the behavior shown below does not occur. I would expect the check to be cleared by any type of view change that modifies the zoom setting (but not by, e.g. panning).

Views

357

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 17, 2016 Nov 17, 2016

Copy link to clipboard

Copied

That behavior is not happening to me on my Mac (Mac OS X 10.2.1) and InDesign CC 2017.

Try restoring your InDesign preferences:

Trash, Replace, Reset, or Restore the application Preferences

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 14, 2021 Jan 14, 2021

Copy link to clipboard

Copied

LATEST

This has started happening to me in InDesign 16.0.1 x64 Windows. Every time I hit the spacebar, it zooms out to full page-spread view. I wondered, is this just a bug or is it some kind of feature gone wrong that can be fixed by changing a menu option, or do I need to take a machete and chop off by preferences at the root?

 

Well, I trashed the preferences (after backing up) and it's still occuring. I looked through the preferences menu to see if there was some option I could turn off, but no.

 

I did some playing around, and saw some keystrokes without the Alt key depressed interpreted as if they were typed while having the Alt key depresseed. I suspect that this is just a symptom of the "InDesign sticky Alt-key problem." That is, you use Alt+scroll wheel to zoom in, and start typing. But because InDesign still thinks you have the Alt key pressed down, it interprets your keystrokes – in my case, Alt+<spacebar> as "zoom out to full-spread view."

 

There are references to this related to a Wacom driver for Apple computers, but I have a PC and no Wacom driver, so it's not related to that.

 

On Reddit I found a suggestion as follows:

Download and install AutoHotkey: http://www.autohotkey.com/

Create a new Text Document and enter the text:

~LAlt Up:: return

Save the document as "name".ahk (you may need to turn on view file extensions)

Finally right click the file and click Run Script (you will need to do this every time you start your computer)

 

I have an autohotkey script that loads and runs every time I reboot (love authohotkey), and I tried adding this to my keystrokes specifically for InDesign with the following:

#IfWinActive ahk_class indesign

;fix problem with sticky Alt key in InDesign
~LAlt Up:: return

 

As far as I can tell, this fixed the problem. Your mileage may vary.

Update:

Well, it didn't fix the problem, and since it's an intermittent problem, I couldn't tell.

I discovered this, though, as I was investigating the problem. When, in InDesign, you press and release the Alt key without doing anything else, there is an underline under the "F" in theleftmost menu item, File. And, the word File is slightly highlighted. Experimenting some more, an easy way to turn this off is to hit the Escape key. So, in AutoHotKey, I changed the above line to:

~LAlt Up:: send {Esc}

I tested it and it prevents the highlighting of "File" and the underlining of "F" so I think this really fixes the problem. If/when I find the terrible side effects this causes, I will post here. 

 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines