Autocorrect in InDesign still doesn't work despite numerous suggestions

Explorer ,
Nov 30, 2020 Nov 30, 2020

Copy link to clipboard

Copied

Hi All

 

This is truly a frustrating issue that doesn't seem to go away.

 

I publish a 600 page book every 2 years and attempt to use shortcuts by adding "rr" into the autocorrect function to auto write "rural and remote"

I have many of these shortcuts.

In Word (ewwww) it just works. In InDesign I need a PhD and a good internet connection to research what to do. I change all the settings to Hunspell, enable dynamic spelling, pressing "W" to escape preview mode, update to v16.0, wear a tiara, put the fan on high etc.

 

What is going on? Why is this a consistently an awkward function for InDesign? 

 

I understand ill get all the usual responses to troubleshoot - ive done these

 

Ive attached the file for reference. In anticipation, if it works on your PC (not mac), then why? What is it about my settings that isn't enabling autocorrect?

 

Thank you

sean

 

 

 

Views

98

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Nov 30, 2020 Nov 30, 2020
Hi @Sean novice:   I got it working. I think there is corruption in the paragraph styles. Take a look at the style definition of just one style—check out the random borders and shading values on lines 3-5, which are not actually in use and I can't just turn off. These are in your [Basic Paragraph] style, along with others. When I see them in the style definition, I can't use auto-correct.     If I click on Reset to Base (which clears out everything, unfortunately):   Then the auto-correct work...

Likes

translate

Translate

Translate
Explorer ,
Nov 30, 2020 Nov 30, 2020

Copy link to clipboard

Copied

ADDIT

 

It works in the general text ...

BUT NOT IN THE TABLES?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 30, 2020 Nov 30, 2020

Copy link to clipboard

Copied

Moved from Using The Community forum.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 30, 2020 Nov 30, 2020

Copy link to clipboard

Copied

Hi @Sean novice :

 

It is working both in and out of tables for me in a new document. (Mac 11.0.1, InDesign 16.0.) But it is not working for me in your file. Does in work in a new file?

 

~Barb 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 30, 2020 Nov 30, 2020

Copy link to clipboard

Copied

Hi @Sean novice:

 

I got it working. I think there is corruption in the paragraph styles. Take a look at the style definition of just one style—check out the random borders and shading values on lines 3-5, which are not actually in use and I can't just turn off. These are in your [Basic Paragraph] style, along with others. When I see them in the style definition, I can't use auto-correct.

 

style1.png

 

If I click on Reset to Base (which clears out everything, unfortunately):

style2.png

 

Then the auto-correct works as expected. 

 

style3.png

 

This is an answer to the question, but not great news. I don't see any easy way to clear all the junk out quickly, other than to reset to base, and then rebuild these paragraph styles. FWIW, I have see these same extraneous values in other people's documents, but they seemed to be ignored. But then again, they probably weren't using auto-correct.

 

On the bright side, you really don't have that many styles, and you are correctly using Based On (for the lists, anyway) so maybe it won't take that long to rebuild them. Once you do, you can set the fan to a temperature keeps you comfortable, and only wear that tiara when you actually want to.

 

~Barb 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Nov 30, 2020 Nov 30, 2020

Copy link to clipboard

Copied

It works for me here, but I noticed you have different dictionaries applied to different parts of your copy (English USA and Englis UK). Autocorrect entries you add manually are dictionary-specific so you would need to add it to every dictionary you are using, or fix your styles (paragraph and character) to use the dictionary you want.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 01, 2020 Dec 01, 2020

Copy link to clipboard

Copied

@roaringmousegraphics: Nice work!

 

When I simply change the dictionary back to English USA for a paragraph, it works in that paragraph. (Reset to base as per my long answer above did the same thing, but was going to create a lot more work for you.)

 

Give this a try, and let us know. Then you or I can mark @roaringmousegraphics's answer as correct.

 

~Barb 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines