Highlighted

Automatic hyphenation won't work

New Here ,
Sep 01, 2018

Copy link to clipboard

Copied

I have a document right now that is acting like I have turned off the hyphenation, but I didn't. It doesn't seem to matter what I do with tracking, justification settings, hyphenation settings, etc., the only hyphens in the document are the discretionary hyphens I put in. And it won't hyphenate even with discretionary hyphens if it is the second or third to last word in a paragraph, even though I unchecked last word setting in the paragraph style hyphenation. I am using styles. I also double checked, and the language is listed as English. I can create new documents from scratch and they respond to my hyphenation changes with automatic hyphenation, just not this one. Any ideas?

That's good to know that a new Basic paragraph bit of text will hyphenate. I  assume you created that in the same document as the non-hyphenating text? 

You know I would still export to IDML and open it/save as new name, just in case. It won't harm  anything if you do that in the same version.

If the problem still persists,  I would try copying a non-hyphenating  paragraph out of one  of your frames, creating a new frame  on the pasteboard, and pasting it in. Does it hyphenate?

If it does, it could possibly be that there's something glitchy with the original text frames. (I've seen this with converted Quark docs before ... rarely, but I've seen it.) Try copying all the text out of a story, deleting the frame, dragging out a new text frame, and pasting it in. If it hyphenates, there you go. You need to redo the frames in the doc.

If copying/pasting to a new text frame doesn't make it hyphenated, then I'd select the entire paragraph and make sure the Character Style was None. Still not hyphenating?  Select [Basic Paragraph]. Now it should hyphenate.

When you are able to eliminate corruption of document and corruption of text frame as a cause, then remove all local formatting (in case a jokester applied No Break to every long word) and apply a bad boy paragraph style. Keep applying styles one by one till you see hyphenation gets disabled. Then look at the style definition for:

-  No Language (I know  you said  they're  set to US English but want to be thorough ;-))

-  No Break

-  Hyphenation on/off AND limits  (maybe it says words have to be 30 characters long before they hyphenate)

-  GREP styles and Nested styles  that are  applying a Character style that uses No Break or No Language

AM

Views

2.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Automatic hyphenation won't work

New Here ,
Sep 01, 2018

Copy link to clipboard

Copied

I have a document right now that is acting like I have turned off the hyphenation, but I didn't. It doesn't seem to matter what I do with tracking, justification settings, hyphenation settings, etc., the only hyphens in the document are the discretionary hyphens I put in. And it won't hyphenate even with discretionary hyphens if it is the second or third to last word in a paragraph, even though I unchecked last word setting in the paragraph style hyphenation. I am using styles. I also double checked, and the language is listed as English. I can create new documents from scratch and they respond to my hyphenation changes with automatic hyphenation, just not this one. Any ideas?

That's good to know that a new Basic paragraph bit of text will hyphenate. I  assume you created that in the same document as the non-hyphenating text? 

You know I would still export to IDML and open it/save as new name, just in case. It won't harm  anything if you do that in the same version.

If the problem still persists,  I would try copying a non-hyphenating  paragraph out of one  of your frames, creating a new frame  on the pasteboard, and pasting it in. Does it hyphenate?

If it does, it could possibly be that there's something glitchy with the original text frames. (I've seen this with converted Quark docs before ... rarely, but I've seen it.) Try copying all the text out of a story, deleting the frame, dragging out a new text frame, and pasting it in. If it hyphenates, there you go. You need to redo the frames in the doc.

If copying/pasting to a new text frame doesn't make it hyphenated, then I'd select the entire paragraph and make sure the Character Style was None. Still not hyphenating?  Select [Basic Paragraph]. Now it should hyphenate.

When you are able to eliminate corruption of document and corruption of text frame as a cause, then remove all local formatting (in case a jokester applied No Break to every long word) and apply a bad boy paragraph style. Keep applying styles one by one till you see hyphenation gets disabled. Then look at the style definition for:

-  No Language (I know  you said  they're  set to US English but want to be thorough ;-))

-  No Break

-  Hyphenation on/off AND limits  (maybe it says words have to be 30 characters long before they hyphenate)

-  GREP styles and Nested styles  that are  applying a Character style that uses No Break or No Language

AM

Views

2.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 01, 2018 0
New Here ,
Sep 01, 2018

Copy link to clipboard

Copied

Does your style have no break turned on by any chance?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 01, 2018 0
New Here ,
Sep 01, 2018

Copy link to clipboard

Copied

In character styles? As far as I can tell, no break is off, or is there another way to tell besides going into my character style?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 01, 2018 0
New Here ,
Sep 01, 2018

Copy link to clipboard

Copied

It is off in my paraphraph styles

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 01, 2018 0
Explorer ,
Sep 01, 2018

Copy link to clipboard

Copied

Check that the language in the style matches the language of the text.

*Erica Dyson אריקה דייסון *

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 01, 2018 0
Adobe Community Professional ,
Sep 02, 2018

Copy link to clipboard

Copied

Hi faralee274:

Can you share a page of the file on dropbox and post a link here (public) or message me (private)? You've already examined the common culprits, so this would be the quickest way to get to a solution.

~Barb

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 02, 2018 2
New Here ,
Sep 04, 2018

Copy link to clipboard

Copied

I am not able to share the document because of the terms of my contract with the client. That was a very generous offer from BarbBinder though! I appreciate all the time everyone is investing here to help me, and I'm sorry you really are flying blind.

Thank-you AnneMarie, that did the trick. I went through and changed things in the style one by one until I found the offending setting. Apparently, the language had to be set to English Canadian or English UK. I should have tried that right away, but I'm still not entirely sure why that happened. Now that I look, the [Basic Paragraph] is also set to English UK, and if I change it to English USA, it suddenly can't hyphenate either. I thought for a second that this might be a problem with my copy of InDesign, somehow, but I just opened a few other documents and they are all hyphenating fine in USA. In this document, even if I place in an some entirely new words from another document, they have to be changed to UK or Canadian in order to hyphenate. Nuts.

Thank-you all so much!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 04, 2018 0
New Here ,
Jun 25, 2020

Copy link to clipboard

Copied

Hello all,

I had this same mystery and changed my Paragraph Styles to be English: Canadian.

I'm grateful for the fix but I'm curious what is the underlying problem here.

Going to IDML and reopening did not clear the issue.

Last time I had Adobe tech support take over my computer to "help", they trashed my preferences without asking and I had to rebuild all my shortcuts and workspaces. Do you all think that's what will be necessary to get rid of this gremlin?

 

Carol

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 25, 2020 0
Advisor ,
Sep 02, 2018

Copy link to clipboard

Copied

If you create a new text frame styled with [Basic Paragraph]  (making sure there is no + symbol following the name) and for Character Style,  [None], does it hyphenate? It should, by default.

If it does hyphenate, then there's an underlying style/formatting issue affecting the other text. I would check for nested styles or a default character style that applies No Language. 

If it doesn't hyphenate, the document could  be corrupted. Export  to IDML and open that file in the same version of ID, but save with a new name.

AM

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 02, 2018 1
New Here ,
Sep 03, 2018

Copy link to clipboard

Copied

OK, so with the basic style and no character style applied, it does hyphenate. That's good to know. Which you said means it isn't corrupted, so I'm glad about that. The paragraph style itself has no nested styles, and the English language is applied. I'm stumped. But there must be setting somewhere that I don't know about, right? Could it be a function of the font? Or would that only affect it if it couldn't recognize the language, which isn't the case here?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 03, 2018 0
Mentor ,
Sep 03, 2018

Copy link to clipboard

Copied

Nope, forget the fonts.

Double check hyphenation settings of your mysterious para style. The values here: are they reasonable?

Be aware para style language settings can be easily (and inadvertently) overriden by a character style or manually. Just to be sure, select problem text (in a text mode), and see what Control or Character panels says about language. Is it the same English?

That really matters, since Spell Checker and Hyphenation completely depend on it. Nothing else, though.

Best of all, follow a generous proposal of BarbBinder and bother to share a page. Now we all just hunting in the dark.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 03, 2018 1
Adobe Community Professional ,
Sep 04, 2018

Copy link to clipboard

Copied

>> Could it be a function of the font?

As example -

2018-09-04_10-45-37.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 04, 2018 0
Mentor ,
Sep 04, 2018

Copy link to clipboard

Copied

Ah, George, that's a style setting, not a font. If you switch to completely different Font Family / Font Style in the same window, No Break setting will remain untouched. It's not tied up with specific font.

However, that's a good point to re-check for any possible No Break. I would check for grep styles, and then - any possible 'wild' nobreaks, using Find Format function in Find/Change dialog.

And then - post a link to a sample file here.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 04, 2018 0
Adobe Community Professional ,
Sep 04, 2018

Copy link to clipboard

Copied

>> that's a good point to re-check for any possible No Break

I mean it this Why not?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 04, 2018 0
Advisor ,
Sep 04, 2018

Copy link to clipboard

Copied

That's good to know that a new Basic paragraph bit of text will hyphenate. I  assume you created that in the same document as the non-hyphenating text? 

You know I would still export to IDML and open it/save as new name, just in case. It won't harm  anything if you do that in the same version.

If the problem still persists,  I would try copying a non-hyphenating  paragraph out of one  of your frames, creating a new frame  on the pasteboard, and pasting it in. Does it hyphenate?

If it does, it could possibly be that there's something glitchy with the original text frames. (I've seen this with converted Quark docs before ... rarely, but I've seen it.) Try copying all the text out of a story, deleting the frame, dragging out a new text frame, and pasting it in. If it hyphenates, there you go. You need to redo the frames in the doc.

If copying/pasting to a new text frame doesn't make it hyphenated, then I'd select the entire paragraph and make sure the Character Style was None. Still not hyphenating?  Select [Basic Paragraph]. Now it should hyphenate.

When you are able to eliminate corruption of document and corruption of text frame as a cause, then remove all local formatting (in case a jokester applied No Break to every long word) and apply a bad boy paragraph style. Keep applying styles one by one till you see hyphenation gets disabled. Then look at the style definition for:

-  No Language (I know  you said  they're  set to US English but want to be thorough ;-))

-  No Break

-  Hyphenation on/off AND limits  (maybe it says words have to be 30 characters long before they hyphenate)

-  GREP styles and Nested styles  that are  applying a Character style that uses No Break or No Language

AM

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 04, 2018 0