Highlighted

Black boxes appear over my text boxes

New Here ,
Sep 12, 2020

Copy link to clipboard

Copied

I have been having a problem lately where these huge black boxes appear over my text boxes. Here are a few screenshots.

trophyhusban_0-1599937500971.pngtrophyhusban_1-1599937534497.png

They appear throughout my document, which is primarily one text box across several pages. If I move the text boxes, the black boxes move too. If I copy the text into a new document, the black boxes appear again. This is happening on two of my files.

Does anyone else have this problem? Does anyone know of any possible solutions?

I can fix it by copying my text into Google Drive and copying it from there back into InDesign. I would rather not do that, because it deletes all my formatting.

Adobe Community Professional
Correct answer by Laubender | Adobe Community Professional

Hi trophyhusban,

yes, this is a known bug in InDesign 15.1.2. with underlines and some Variable Font fonts.

As a workaround you could use a different font.

 

See the following discussions:

 

Unwanted black bars on pages and pdf
mautime, Aug 28, 2020

https://community.adobe.com/t5/indesign/unwanted-black-bars-on-pages-and-pdf/td-p/11394994

 

Indesign_ Hyperlink Issue
kattieb49090295, Sep 09, 2020

https://community.adobe.com/t5/indesign/indesign-hyperlink-issue/td-p/11421834?page=1

 

And a report at InDesign UserVoice:

 

Underline with variable font
When the underline of a variable font is activated, the underline takes the whole height of the page. (Indesign 15.1.2)

François, August 31, 2020

https://indesign.uservoice.com/forums/601180-adobe-indesign-bugs/suggestions/41275063-underline-with...

https://community.adobe.com/t5/indesign/indesign-hyperlink-issue/td-p/11421834?page=1

 

Vote for fixing the issue.

Also do some comments at UserVoice with details about the used fonts and how they are installed.

E.g. through the Document fonts folder or the application's Fonts folder or through the operating system or a font utility software. Or check if the fonts are from the Adobe Fonts service.

 

Thanks,
Uwe Laubender

( ACP )

TOPICS
Bug

Views

307

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Black boxes appear over my text boxes

New Here ,
Sep 12, 2020

Copy link to clipboard

Copied

I have been having a problem lately where these huge black boxes appear over my text boxes. Here are a few screenshots.

trophyhusban_0-1599937500971.pngtrophyhusban_1-1599937534497.png

They appear throughout my document, which is primarily one text box across several pages. If I move the text boxes, the black boxes move too. If I copy the text into a new document, the black boxes appear again. This is happening on two of my files.

Does anyone else have this problem? Does anyone know of any possible solutions?

I can fix it by copying my text into Google Drive and copying it from there back into InDesign. I would rather not do that, because it deletes all my formatting.

Adobe Community Professional
Correct answer by Laubender | Adobe Community Professional

Hi trophyhusban,

yes, this is a known bug in InDesign 15.1.2. with underlines and some Variable Font fonts.

As a workaround you could use a different font.

 

See the following discussions:

 

Unwanted black bars on pages and pdf
mautime, Aug 28, 2020

https://community.adobe.com/t5/indesign/unwanted-black-bars-on-pages-and-pdf/td-p/11394994

 

Indesign_ Hyperlink Issue
kattieb49090295, Sep 09, 2020

https://community.adobe.com/t5/indesign/indesign-hyperlink-issue/td-p/11421834?page=1

 

And a report at InDesign UserVoice:

 

Underline with variable font
When the underline of a variable font is activated, the underline takes the whole height of the page. (Indesign 15.1.2)

François, August 31, 2020

https://indesign.uservoice.com/forums/601180-adobe-indesign-bugs/suggestions/41275063-underline-with...

https://community.adobe.com/t5/indesign/indesign-hyperlink-issue/td-p/11421834?page=1

 

Vote for fixing the issue.

Also do some comments at UserVoice with details about the used fonts and how they are installed.

E.g. through the Document fonts folder or the application's Fonts folder or through the operating system or a font utility software. Or check if the fonts are from the Adobe Fonts service.

 

Thanks,
Uwe Laubender

( ACP )

TOPICS
Bug

Views

308

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 12, 2020 0
Adobe Community Professional ,
Sep 12, 2020

Copy link to clipboard

Copied

Have you made a .idml and open/work from that file?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 12, 2020 0
Adobe Community Professional ,
Sep 12, 2020

Copy link to clipboard

Copied

If this is happening on only two documents then Jonathan's suggestion to export as an IDML and then reopen that with your version of InDesign could work. Exporting as an IDML can remove corruption from a file. If this is happening for more documents even if it's not consistant then resetting your InDesign preferences may work. This will reset the program to its defaults which hopefully will stop this behavior.

To do so:

For Macintosh Users: The User Library folder in which InDesign’s preferences are stored is hidden by default on most Macintoshes. To access it make sure that InDesign is closed and click on the desktop to launch a Finder Window (Command-N). With this window in column view follow the path User>Home folder (it’s the folder with an icon that looks like a house—it may have the user’s name rather than “Home”) and click on the Home folder. With the Option Key pressed choose Library from the Finder Go Menu. “Library” will now appear within the Home folder. Within the Library folder find the folder called Preferences and within it find the folder called “Adobe InDesign” and the file called “com.adobe.InDesign.plist” and delete both that folder and that file. When InDesign is next launched it will create new preference files and the program will be restored to its defaults.

For Windows Users: You can try the quick way of resetting on a PC which is to hold down Ctrl + Alt + Shift when launching InDesign and respond affirmatively when asked if you want to reset. There have been some recent reports that the window asking if you want to reset is not popping up but that the prefs are being reset anyway. If this works great but if it doesn’t you may have to manually delete them.

To do so: On Windows 7 and above the preference files are hidden. To find them go to the Control Panel and open Folder Options and then click the View tab. Then select “Show hidden files and folders” or “Show hidden files, folders or drive options” in Advanced Settings. Then delete (or rename) the folder at the end of this path: C:\Users\<USER>\AppData\Roaming\Adobe\InDesign\<Version #>\<Language>. Make sure that InDesign is closed when you do this. When you relaunch the program it will create new preference files and the program will be at its default settings.

The advantage of manually deleting preference files is that after you’ve reset up the program (make sure that no document window is open) to your liking, you can create copies of your personalized “mint” preference files (make sure that you quit the program before copying them—that finalizes your customization) and use them in the future to replace any corrupt versions you may need to delete.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 12, 2020 1
Adobe Community Professional ,
Sep 12, 2020

Copy link to clipboard

Copied

Hi TrophyHusban:

 

Are you using underlines in the file?

 

~Barb

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 12, 2020 1
New Here ,
Sep 12, 2020

Copy link to clipboard

Copied

Yes, I am using a lot of underlines. Removing all underlines fixed the problem (after I tried saving it as a .idml file and resetting my preferences). Is this the best way to fix the error? Does this mean I can't use underlines in this document?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 12, 2020 0
Adobe Community Professional ,
Sep 12, 2020

Copy link to clipboard

Copied

Crazy! Check your character and paragraph styles that might be affecting the text. Possible culprits include underlines, paragraph rules, and shading.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 12, 2020 1
Adobe Community Professional ,
Sep 12, 2020

Copy link to clipboard

Copied

This is a bug that Adobe is aware of, so for now, no.

Underlines do not typically appear in professionally published documents. If you need a separator, use a paragraph rule above or below. If you want to a emphasize text, consider changing the typeface, size, style or weight.

 

~Barb 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 12, 2020 0