Can't set up hyperlinks

Community Beginner ,
May 01, 2018 May 01, 2018

Copy link to clipboard

Copied

I am using InDesign CC 2018 on a machine running Windows 7. I want to set up a large document (to be turned into a pdf later) that will have multiple hotlinks on each page, to allow users to jump quickly to section contents pages and then to individual pages. I have made multiple attempts to set up a hotlink, being careful every time to follow the instructions in the online help document precisely. I have tried setting up hotlinks with the source on a Master page; I have tried setting up hotlinks with the source on a document page; I have tried setting up hotlinks whose sources are strings of text, and others whose sources are text boxes; I have tried setting up hotlinks with and without destinations; and I have tried saving test documents as InDesign files and as pdf files (with interactive content switched 'on'). Nothing I have done has resulted in a single instance of a working hotlink. Can anyone tell me what on earth is going wrong?

Views

823

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Community Beginner , May 02, 2018 May 02, 2018
Bill, I have discovered the problem. When exporting the pdf, there is a pulldown option at the bottom of the window labelled "Interactive elements". In your screenshot in your first response, it is showing "Do not include", and I don't recall any instruction in the online guides to change that. The only other option offered by the pulldown is "Include appearance", which seems strange to me considering its apparent function, but selecting that option when saving the pdf makes the hotlinks active....

Likes

translate

Translate

Translate
Adobe Community Professional ,
May 01, 2018 May 01, 2018

Copy link to clipboard

Copied

When you export to pdf do you have "Hyperlinks" checked in the General section of the Export Adobe Pdf dialog window? See screen shot:

Screen Shot 2018-05-01 at 4.31.40 PM.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 01, 2018 May 01, 2018

Copy link to clipboard

Copied

One other thing are you exporting as an interactive pdf or as a print pdf? The interactivity in Interactive pdfs are not recognized in many pdf readers so I would recommend exporting to a print pdf as in my first post.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 01, 2018 May 01, 2018

Copy link to clipboard

Copied

In rereading your original post it sounds like you’re expecting the interactivity to work in the InDesign file. It doesn’t work like that. The interactivity is seen in the form that you export to such as a pdf or Publish Online.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 02, 2018 May 02, 2018

Copy link to clipboard

Copied

Bill, thank you for your replies. FYI, I'm in the UK so I am on a different time to you. I posted my original question last night just before closing down. And today I've been sidetracked by having to deal with a faulty heating pump in my home.

Anyway, to answer your points; yes, I did check the hyperlinks box in the Export window; the reader I was using was Adobe Acrobat Professional; and yes, I was hoping to see the link being active in the InDesign file (so I could check that it was functioning correctly) but it wasn't active in the pdf either.

The purpose of my exercise is to create an easily navigable guide to journalistic editing procedures for colleagues in my workplace, which publishes an online magazine. I want to set up masterpages, each with about a dozen hotlinks already established -- so that I don't have to create each one individually on each page of a document that will be well over 100 pages long.

I think this should be easy, so I can't see what it is that I am not doing, or should be doing that I'm not. Any guidance would be helpful.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 02, 2018 May 02, 2018

Copy link to clipboard

Copied

Setting up hyperlinks to navigate from one page to another is a relatively simple procedure. See screen shot:

HYPERLINKS.png

In this example I am using the red square (which is on page three of my document) as the actual link. In actual practice it is better to draw an unstroked and unfilled rectangle to place over the spot where you want the link or you can select text with the text tool and make that the link. In either case you would make the selection and choose "New Hyperlink" in the Hyperlinks Panel pull-down menu (picture on the right). When you do so the New Hyperlinks dialog box will appear (picture left) and in this case I've set it to navigate back to page one when it is ultimately clicked on. Make sure that the actual title of the InDesign file is written in the "Document:" field. Note that when the object became a hyperlink that its selection became a dashed line. If I'd used type it would get an underline under it. Note that when it became a hyperlink it got a listing in the hyperlinks panel. When I tested this in a pdf made in the manner described in my first post, it worked perfectly.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 02, 2018 May 02, 2018

Copy link to clipboard

Copied

Bill, As far as I can see, your procedure is exactly the procedure I followed. The only point of difference is that when I tried using highlighted text to create the link it never acquired an underline. Other attempts using a text box did show a dash outline to the box, but still no active link was made. However, I will try this later in the day when I have time to experiment and will let you know how it goes. Thanks for your input.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 02, 2018 May 02, 2018

Copy link to clipboard

Copied

Hope it works out.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 02, 2018 May 02, 2018

Copy link to clipboard

Copied

One other thought. When you highlighted text did you do it with the text tool or did you select the text frame with an arrow tool? The underline under  hyperlinked text only happens when the text has been selected with the text tool while it is being made into a hyperlink.

If you still can't make it work when you get back to experimenting with this, please post relevant screen shots so that either myself, or whomever sees them first, can provide a clue as to how to help you.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 02, 2018 May 02, 2018

Copy link to clipboard

Copied

Bill, I have discovered the problem. When exporting the pdf, there is a pulldown option at the bottom of the window labelled "Interactive elements". In your screenshot in your first response, it is showing "Do not include", and I don't recall any instruction in the online guides to change that. The only other option offered by the pulldown is "Include appearance", which seems strange to me considering its apparent function, but selecting that option when saving the pdf makes the hotlinks active. (A user such as me would have ticked one of the boxes immediately above, such as "Hyperlinks", so you would assume that you would not need to give the same instruction twice.) I've now tested a pdf made with a text-string as the hyperlink source, and another using a text box as the source, and both worked. So, success at last. I hope this means that the entire document will work as hoped, when I finish creating it.

Many thanks for your patient instruction.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 02, 2018 May 02, 2018

Copy link to clipboard

Copied

I'm glad that it worked but that option should not have made any difference since it does not actually apply to hyperlinks. But if it made the difference for you then great.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 22, 2021 Jan 22, 2021

Copy link to clipboard

Copied

This did not work for me.  I am at my wit's end.

 

Some of my hyperlinks work; others do not.  Most do not.

I can copy and paste them into a browser, so they work...they just don't work as hyper links from the PDF.

 

I've tried the "interactive for PDF" in the upper right hand corner of screen, next to the Adobe Search box.  Nothing.  In the link box on the right hand side of the screen (where layers, strokes, pages, etc. are all listed), the links all have green dots - and I can click on the green dot and go to the websites.  

 

I've tried unselecting the "shared hyperlink destination" in the "edit hyperlinks" drop-down.  Nothing.

 

We've finally just written after every link in the PDF "If the link doesn't work, copy and paste it into your browser - that will work" - but that doesn't look very professional.

 

I've given up.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines