Highlighted

Cannot run InDesign Server in VM

New Here ,
Apr 06, 2020

Copy link to clipboard

Copied

I just started using InDesign Server and stumbled into an issue that's given me headaches for the last few days. This problem happens in an Azure virtual machine running Windows Server 2019 Datacenter. However, when I followed the same steps on my laptop, it all worked fine. Here is the problem:

 

After freshly installing InDesign Server, I started it running this command:

InDesignServer -port 18383

That then starts running and eventually outputs "Servicing SOAP requests on port 18383".

 

However, if I navigate to http://localhost:18383/service?wsdl in my browser, the request times out. 

If I run the following command:

sampleclient -host 18383 script_path

(where script_path is a path to one of the sample scripts in the InDesign Server SDK), I get the following message:

SOAP 1.1 fault: SOAP-ENV:Client [no subcode]
"No such host is known. "
Detail: getaddrinfo failed in tcp_connect()

And, as I previously mentioned, I do not have this issue when running InDesign Server on my laptop. Could anyone help with this?

TOPICS
Activation billing and install, Bug

Views

264

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Cannot run InDesign Server in VM

New Here ,
Apr 06, 2020

Copy link to clipboard

Copied

I just started using InDesign Server and stumbled into an issue that's given me headaches for the last few days. This problem happens in an Azure virtual machine running Windows Server 2019 Datacenter. However, when I followed the same steps on my laptop, it all worked fine. Here is the problem:

 

After freshly installing InDesign Server, I started it running this command:

InDesignServer -port 18383

That then starts running and eventually outputs "Servicing SOAP requests on port 18383".

 

However, if I navigate to http://localhost:18383/service?wsdl in my browser, the request times out. 

If I run the following command:

sampleclient -host 18383 script_path

(where script_path is a path to one of the sample scripts in the InDesign Server SDK), I get the following message:

SOAP 1.1 fault: SOAP-ENV:Client [no subcode]
"No such host is known. "
Detail: getaddrinfo failed in tcp_connect()

And, as I previously mentioned, I do not have this issue when running InDesign Server on my laptop. Could anyone help with this?

TOPICS
Activation billing and install, Bug

Views

265

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 06, 2020 0

Have something to add?

Join the conversation