Case sensitive character styles

Explorer ,
Jan 21, 2021 Jan 21, 2021

Copy link to clipboard

Copied

So I just came across a weird problem in Character Styles.

 

I need to create a semibold italic character style. Simple enough. Problem is, I'm using the font Montserrat, and it's semibold italic is spelled with an uppercase B: SemiBold.

 

That's where the problem comes in. Under "Font Style" In the Character Styles Options dialog window, the only option is Semibold Italic (lowercase b). When I select that and apply the new character style to my text, it doesn't work--up in the font style selection dropdown it's showing [Semibold Italic], as if that style doesn't exist (which it doesn't).

 

In other words, it appears that in the Character Style options, the font styles aren't case sensitive, but for the actual font, it is case sensitive. Unless I'm missing something, that means I effectively can't create a Semibold Italic character style for Montserrat because Semibold Italic doesn't exist for that font--SemiBold Italic does. But SemiBold Italic doesn't exist under Character Styles--Semibold Italic does.

 

Am I missing something or am I really trying to do something that won't work?

TOPICS
Bug, How to, Type

Views

103

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 21, 2021 Jan 21, 2021

Copy link to clipboard

Copied

Hi @Jonlin Creative:

 

It's working fine for me. The brackets around a typeface or style mean that you don't have the font available—so go back and double check that you have downloaded the semibold version.

 

~Barb

 

font.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 21, 2021 Jan 21, 2021

Copy link to clipboard

Copied

Hi @Barb Binder 

 

The problem is actually with SemiBold Italic, not SemiBold. And I do have the font activated. The trouble is that for Montserrat, "Semibold Italic" doesn't exist--"SemiBold Italic" does. But under the character style options, SemiBold Italic doesn't exist--Semibold Italic does. So when the character style calls for "Semibold Italic" in Montserrat, it can't find it--because in that font the B is uppercase.

 

Does that make sense?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 21, 2021 Jan 21, 2021

Copy link to clipboard

Copied

It works perfectly with may version of Montserrat

Capture d’écran 2021-01-21 à 19.00.19.jpgCapture d’écran 2021-01-21 à 19.00.32.jpg

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 21, 2021 Jan 21, 2021

Copy link to clipboard

Copied

Sorry about that!

 

I had the same experience you did—until I realized I did not activate semibold italic. So I did (fonts.adobe.com) and now it's working. 

 

sb1.png

 

 

sb2.png

 

Will you share the same screen shots with us?

 

~Barb 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 21, 2021 Jan 21, 2021

Copy link to clipboard

Copied

Okay, just to assure you I'm not totally crazy, here are some screenshots. 🙂

 

The first one shows what I'm seeing when I try to apply a Semibold Italic character style to Montserrat. As you can see, the character style is applied, and it looks like I don't have the font activated.

 

The second screenshot, however, shows that I do in fact have the font activated since I was able to apply it manually without the character style.

 

All of that said, I did end up finding a solution to the problem. I simply set some text in Montserrat SemiBold Italic, selected it, then created a new character style while I had the text selected. Problem solved. (I don't know why it didn't work when I created the character style manually without the text highlighted.)

 

Graphic1.jpg

 

Graphic2.jpg

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines