Highlighted

change background color in indesign

Enthusiast ,
Oct 31, 2020

Copy link to clipboard

Copied

I followed a tutorial on how to place a background color in an indesign project.

It doesn't work.

Look at the attached photo...

I created a rectangle over the page, and text disappeared but image, object remained visible

I filled rectangle with a color

I sent the the colored rectange to the background. Nothing changed. (In the tutorial, it changed and the text became visible.)

So I opened text frame options and clicked the box that says "ignore text wrap."

The result was very weird. check the photo.

Maybe the project is corrupted. Again?

Does anybody know a method that works?

Using indesign 2021 on a mac running 10.15.7

Here's a beautiful attachment showing all my steps...

Adobe Community Professional
Correct answer by rob day | Adobe Community Professional

It looks like you might have Paragraph Shading turned on for the text. Select the text and from the Paragraph panel’s fly out menu check Paragraph Borders and Shading>Shading. Paragraph Shading can also be included with the text’s applied Paragraph Style:

 

Screen Shot 15.png

TOPICS
How to, Performance

Views

86

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

change background color in indesign

Enthusiast ,
Oct 31, 2020

Copy link to clipboard

Copied

I followed a tutorial on how to place a background color in an indesign project.

It doesn't work.

Look at the attached photo...

I created a rectangle over the page, and text disappeared but image, object remained visible

I filled rectangle with a color

I sent the the colored rectange to the background. Nothing changed. (In the tutorial, it changed and the text became visible.)

So I opened text frame options and clicked the box that says "ignore text wrap."

The result was very weird. check the photo.

Maybe the project is corrupted. Again?

Does anybody know a method that works?

Using indesign 2021 on a mac running 10.15.7

Here's a beautiful attachment showing all my steps...

Adobe Community Professional
Correct answer by rob day | Adobe Community Professional

It looks like you might have Paragraph Shading turned on for the text. Select the text and from the Paragraph panel’s fly out menu check Paragraph Borders and Shading>Shading. Paragraph Shading can also be included with the text’s applied Paragraph Style:

 

Screen Shot 15.png

TOPICS
How to, Performance

Views

87

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 31, 2020 0
Adobe Community Professional ,
Nov 01, 2020

Copy link to clipboard

Copied

It would be better if you share a sample indd file so that someone can look at it and provide some inputs.

-Manan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 01, 2020 0
Enthusiast ,
Nov 01, 2020

Copy link to clipboard

Copied

wow. Didn't know I could do that! wow. I will look it up for next time.... I think some of the people below might have saved me. gotta check out their fixes!

Here's a dropbox link to a bit of the problem. I don't know the correct way to do this...https://www.dropbox.com/s/o5gh7c1xv15jupj/Archive.zip?dl=0 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 01, 2020 0
Adobe Community Professional ,
Nov 01, 2020

Copy link to clipboard

Copied

Looks like the fill of your text frame is set to Paper, try setting it to None.

 

Screen Shot 9.pngScreen Shot 10.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 01, 2020 0
Enthusiast ,
Nov 01, 2020

Copy link to clipboard

Copied

No. Unfortunately, it is set to none.  

set to none.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 01, 2020 0
Adobe Community Professional ,
Nov 01, 2020

Copy link to clipboard

Copied

In the first new screen shot (with the arrow) the text frame isn't selected. Try selecting it and check again.

 

~Barb 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 01, 2020 0
Enthusiast ,
Nov 01, 2020

Copy link to clipboard

Copied

Tried that. Set to none.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 01, 2020 0
Adobe Community Professional ,
Nov 01, 2020

Copy link to clipboard

Copied

Hi @straightlife :

 

  1. I wish everyone would post such a clear pictorial of their workflow! That was awesome!
  2. Is text wrap on for the blue frame? Select the blue frame and disable it with Window > Text Wrap and click the first button on the top row in place of ignore text wrap in Text Frame Options on the text frames.

 

~Barb  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 01, 2020 0
Enthusiast ,
Nov 01, 2020

Copy link to clipboard

Copied

Text wrap turned off....  Screen Shot 2020-11-01 at 1.06.57 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 01, 2020 0
Enthusiast ,
Nov 01, 2020

Copy link to clipboard

Copied

HOWEVER. When I didn't use uploaded text from WORD (it's a long document), Everything worked just as it was supposed too!

Before loading the color I created a text box and typed in it.

Then I placed the photo.

Then I made a rectangle and sent it to the back. That worked.

So....  I can't believe I have to retype all the text directly into Indesign in order to get a colored background....

So, help???????

Is there an alternative way to import text when it won't have a white background?Screen Shot 2020-11-01 at 1.32.38 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 01, 2020 0
Enthusiast ,
Nov 01, 2020

Copy link to clipboard

Copied

Thanks everybody for being so supportive. I believe something went wrong with the text I placed from WORD.  I exported the text in the document as a .txt file.

I imported it, and everything worked quite well. So the problem has been solved.  I wouldn't have perservered if you guys hadn't made your kind suggestions.Screen Shot 2020-11-01 at 1.54.40 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 01, 2020 1
Adobe Community Professional ,
Nov 02, 2020

Copy link to clipboard

Copied

It looks like you might have Paragraph Shading turned on for the text. Select the text and from the Paragraph panel’s fly out menu check Paragraph Borders and Shading>Shading. Paragraph Shading can also be included with the text’s applied Paragraph Style:

 

Screen Shot 15.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 02, 2020 1