Character Styles based on [None] change selection to Minion Pro

Contributor ,
Oct 26, 2020 Oct 26, 2020

Copy link to clipboard

Copied

Dear all,

as soon as I opened a document in InDesign 2021 all my Character Styles which do not have a family font specified and are based on the [None] style automatically change the selection to Minion Pro font family. 

In the 2020 version I used this feature to apply different weights plus other things but now everything gets changed to Minion Pro until I do not specify the font family as well. 

As far as I know leaving the font family blank should be interpreted by InDesign as "do not change the font family", right?

Is there something I am missing? 

Has something changed from v2020?

What should I do to obtain the same results as before?

Thanks

TOPICS
Bug, How to, Type

Views

199

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct Answers

Adobe Community Professional , Oct 26, 2020 Oct 26, 2020
That would be true. InDesign's default font would be Minion Pro. If you had custom paragraph styles, and the styles were in a different font, that could be blown away in the version upgrade. But it's not insurmountable. I dont know what font you use for your default font style, so for illustration purposes, I'm going to use one named Fred. Please note that I don't actually have a Fred font. Shut down out of InDesign Open the InDesign application only. Do not open any documents. Go to the...

Likes

Translate

Translate
Contributor , Oct 26, 2020 Oct 26, 2020
Thanks.I have now modified the [Basic Paragraph] paragraph style in the document I need to have the font I need and everything seems back to normal. Tried opening a new document and it's still on Minion Pro, which is good.I hope that's it.

Likes

Translate

Translate
Adobe Community Professional ,
Oct 26, 2020 Oct 26, 2020

Copy link to clipboard

Copied

That would be true. InDesign's default font would be Minion Pro. If you had custom paragraph styles, and the styles were in a different font, that could be blown away in the version upgrade.

 

But it's not insurmountable. I dont know what font you use for your default font style, so for illustration purposes, I'm going to use one named Fred. Please note that I don't actually have a Fred font.

 

  1. Shut down out of InDesign
  2. Open the InDesign application only. Do not open any documents.
  3. Go to the Window>Styles>Paragraph Styles menu command. This opens the Paragraph Styles panel.
  4. Double-click on the sole, [Basic Paragraph] style to open the Paragraph Style Options dialog box. Select the Basic Character Formats section from the list at the left, and change the Font Family: options box from Minion Pro to Fred. Click the OK button.
  5. If you have a special paragraph style for all your documentation that you don't want to be your default font, just create a new one using the panel's flyaway menu to open the New Paragraph Style... menu command and go through all the options listed to the left of the Paragraph Style Options box to choose the precise settings to create your custom paragraph style. Then click the OK button.
  6. Close InDesign. This should set your custom paragraph settings.

 

Make sure it takes with your Character styles:

 

  1. Open only the InDesign application again.
  2. Go to the Window>Styles>Character Styles menu command. This opens the Character Styles panel.
  3. Double-click on the sole, [None] style to open the Paragraph Style Options dialog box. Select the Basic Character Formats section from the list at the left, and if the Font Family: options box is blank, you can count on it being Fred.
  4. Of course, at any time you can specify what that font should be in the Font Family options box to be sure. Which may be the better option for setting up your character styles in the long run, anyway.

 

Hope this helps,

 

Randy

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Oct 26, 2020 Oct 26, 2020

Copy link to clipboard

Copied

Thanks Randy!

Before I try this I would like to be sure of something: this procedure you describe is going to change the default font for every document created with InDesign, both in the future and old ones that get opened, right? 

Is there a way to make it so that just this documents gets the desired font (which is called Academico, btw)? 

 

Also, why does this reset happens with a version upgrade? I do not recall changing the default font to Academico in InDesign 2020, where this document had been created.

Curiously enough, browsing a bit in the Edit Character Style box of all different styles, changing inheritance to [none], then OK, then repeating and changing it to do not inherit solves this for some of them. Not consistent though. 

As I tend to leave font choice to paragraph styles I would like my character styles only to change attributes of the font and not belong to any font at all. Is this possible? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 26, 2020 Oct 26, 2020

Copy link to clipboard

Copied

What should be happening is this:

When you applied a PARAGRAPH style with, say, Helvetica regular, the apply a CHARACTER style, say, Bold to a word and then later apply the Character style [None] to that word again, it should revert to Helvetica regular again and not Minion... So make sure that paragraph styles are applied and character styles to complete paragraphs as I see some users do sadly enough...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Oct 26, 2020 Oct 26, 2020

Copy link to clipboard

Copied

Thanks.

I have now modified the [Basic Paragraph] paragraph style in the document I need to have the font I need and everything seems back to normal. 

Tried opening a new document and it's still on Minion Pro, which is good.

I hope that's it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 30, 2020 Oct 30, 2020

Copy link to clipboard

Copied

LATEST

Glad you're back in business.

 

Could you do us a favor though? Please mark the answer(s) that got you where you want to be as a Correct Answer. This alerts the moderators to archive this thread so it'll help other users who find themselves in similar situations. That's where, for example, the Related conversations links are generated like you'll see below.

 

And if you have issues in the future with InDesign — or heck, with any Adobe software — feel free to come back here and call for help. There are lots of sharp people around here who can lend a hand.

 

Happy things worked out well for you,

 

Randy

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines