Checkbox tooltip in PDF doesn't match description set in InDesign

Participant ,
Jul 14, 2021 Jul 14, 2021

Copy link to clipboard

Copied

I'm making check boxes for accessible pdf forms in InDesign. I have a problem that occurs in both the 2020 and the 2021 version of the porgram. I include the check box’s Name, Description and Value in ID. The client has very specific requirements where the boxes are mutually excluside (i.e., checking box #2 turns of box #1). They do not want radio buttons because they want users to be able to turn off all the choices, which you can't do once you’ve selected a radio button. I can achieve this by giving all the checkboxes a shared button Name but different button Values. The behaviour works as requied. However, the tooltips don’t match what I've programmed in ID. In the attached files (ID and PDF), the programmed ID Descriptions are box 1, box 2 and box 3 and the Values are one, two and three but the Tooltips are all box2 and the Values are all Box. Does anybody know why this is happening? I don’t want to have to manually change all this in Acrobat if it should work as programmed.

TOPICS
Bug

Views

46

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 15, 2021 Jul 15, 2021

Copy link to clipboard

Copied

I have tested this briefly and am getting similar results - the second box (one on the right) always comes in with the alt text. Let me investigate this more. Even setting specific alt text in the object export options doesn't work with this...

 

I will come back once i have taken this apart a little more

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 15, 2021 Jul 15, 2021

Copy link to clipboard

Copied

Thanks, Ian. I'm glad to hear I’m not the only one and that I am, in fact, programmming the check boxes as I should. I forgot to mention that I am working on a Mac with Big Sur. I’m going to try it out on an old laptop with an older OS. What platform/OS did you try it on?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 15, 2021 Jul 15, 2021

Copy link to clipboard

Copied

Just tried building a brand new file using ID 2020 on High Sierra and it did the same thing.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 16, 2021 Jul 16, 2021

Copy link to clipboard

Copied

yeah - it's doing the same for me now on all machines 2 Macs and 2 PCs. Different versions of Indesign loaded but I noticed all my machines are using the latest version of acrobat...

 

Let me test more - sorry i don't have a quick fix but will see what we can find and help with.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jul 16, 2021 Jul 16, 2021

Copy link to clipboard

Copied

LATEST

Thanks. I really appreciate all thet ime you're taking on this. If I can't find a fix, we may have to hire somebody to make these changes manually since it doesn’t make sense to pay a senior designer to do basic coding. Looking forward to any insights.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines