CS5 Running very sticky

New Here ,
May 03, 2010 May 03, 2010

Copy link to clipboard

Copied

Hello,

I've installed InDesign CS5 and it's running terribly when I have graphics placed, especially at high resolution display.  It's choppy, sticky - to much to even work with.  I've thrown out the SavedData and InDesign Defaults, but it doesn't help.  Has anyone else experienced this problem, or have any ideas what I can do.  CS4 runs fine.

Thanks,

Adam

Views

32.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
replies 205 Replies 205
Participant ,
Oct 15, 2010 Oct 15, 2010

Copy link to clipboard

Copied

I just managed to speed up the InDesign a bit (maybe a bit more than a bit in my case):


In Preferences -> Interface

Set Tool Tips to None

Switch off:

- Show Transformation Values (they are on the top bar anyway no need to show them by transparent window by cursor).-

- Multi-Touch Gestures (unless you really need them).

- Auto-Collapse Icon Panels

- Auto-Show Hidden Panels

Hand tool - set to Better Performance (does not really matter I suppose but...)

Live Screen Drawing - set no never (actually it is hard for me to see the difference between never and delayed)

In View -> Extras

Hide:

- Content Grabber

- Live Corners

In Window

uncheck:

- Application Frame

- Application Bar

If you uncheck control it really speeds up but this is what we do need I suppose.

Further you may consider (if not needed) to uncheck all from Preferences -> Track Changes

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 15, 2010 Oct 15, 2010

Copy link to clipboard

Copied

The differnce between Delayed and Never for Live screen drawing is what happens when you click and wait before dragging. With delayed you'll get a live update, with never you won't.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Oct 15, 2010 Oct 15, 2010

Copy link to clipboard

Copied

Thanks. Now I do copy that.

So this is such a place between two worlds.

You can't use immediate because it slows you down but if you have to, just this time, hold your mouse still for a while then drag.

So... if I set it to "never" my interface would have one dilemma less to consider. I stay by never.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 14, 2011 Mar 14, 2011

Copy link to clipboard

Copied

Phorna, these are exactly the sort of concrete tips I was looking for. Extremely helpful. Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 19, 2010 Oct 19, 2010

Copy link to clipboard

Copied

I've been using 7.0.3 and it seems to have a very positive impact on ID CS5 performance. I can run with a high quality display performance and enable live screen redrawing and things are working quite well.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 11, 2011 May 11, 2011

Copy link to clipboard

Copied

LATEST

My Applescript was running 10x slower on CS5 than on CS3.

I found that turning off Preferences -> File Handling -> Always Save Preview Images with Documents, fixed the script's speed problem.

Also turning the Display Performance to Fast (Optimized) at the beginning of the script and turning it back to Typical when complete helped for scripts that take more than a few seconds to run.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines