Highlighted

Data Merge Shifting Records off the page...?

New Here ,
Aug 15, 2012

Copy link to clipboard

Copied

I am trying to do a data merge to create a member directory, finished size 5.5x8.5

I am doing multiple records (each sized 1.5x.1.5 inches) per document page, and when I  Preview the multiple record layout, it shifts all of the records down about 1 inch, and over to the left about 2. It does not seem to be lining up with anything. My margins for the data merge are set to .3 all around.

I have tried using a data source that is a CSV (comma delinated) and also a Text (tab delinated) file.

I have tried creating a new file and reseting the needed info from scratch, to help ensure there wasn't any possible file corruption.

Here's a picture of what's happening. Can anyone give me a clue why this shift is happening?

I am using CS6, and have never had this happen to me before with any previous work.

BEFORE.pngAFTER.png

Adobe Community Professional
Correct answer by SJRiegel | Adobe Community Professional

It seems to be connected to the preview, so that if it was previewed even once it didn't run correctly. The only way I was able to get correct behavior out of the file was to create a brand new file, copy the text block into it, set up a new data-merge info and run without preview.

Any attempts to create a new file and preview before running resulted in offset records.

Views

20.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Data Merge Shifting Records off the page...?

New Here ,
Aug 15, 2012

Copy link to clipboard

Copied

I am trying to do a data merge to create a member directory, finished size 5.5x8.5

I am doing multiple records (each sized 1.5x.1.5 inches) per document page, and when I  Preview the multiple record layout, it shifts all of the records down about 1 inch, and over to the left about 2. It does not seem to be lining up with anything. My margins for the data merge are set to .3 all around.

I have tried using a data source that is a CSV (comma delinated) and also a Text (tab delinated) file.

I have tried creating a new file and reseting the needed info from scratch, to help ensure there wasn't any possible file corruption.

Here's a picture of what's happening. Can anyone give me a clue why this shift is happening?

I am using CS6, and have never had this happen to me before with any previous work.

BEFORE.pngAFTER.png

Adobe Community Professional
Correct answer by SJRiegel | Adobe Community Professional

It seems to be connected to the preview, so that if it was previewed even once it didn't run correctly. The only way I was able to get correct behavior out of the file was to create a brand new file, copy the text block into it, set up a new data-merge info and run without preview.

Any attempts to create a new file and preview before running resulted in offset records.

Views

20.8K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 15, 2012 0
Adobe Community Professional ,
Aug 15, 2012

Copy link to clipboard

Copied

Can you include a screen shot of the Multiple Record Layout tab, and the Options tab? The key to the problem may be in one of those.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 15, 2012 0
New Here ,
Aug 15, 2012

Copy link to clipboard

Copied

That WOULD make sense.... here we go!

Screen shot 2012-08-15 at 12.35.27 PM.png

Screen shot 2012-08-15 at 12.35.54 PM.png

Screen shot 2012-08-15 at 12.36.00 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 15, 2012 0
Adobe Community Professional ,
Aug 15, 2012

Copy link to clipboard

Copied

Everything looks fine there, so my best guess would be a stray item on the page could be throwing things off. If you could post a link to the InDesign file, I could take a look at it. (I will create a dummy data file to test with)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 15, 2012 0
New Here ,
Aug 15, 2012

Copy link to clipboard

Copied

See, that's what I thought. Which is why I created an entirely new document.

Could it be corruption in the Excell file I created the Data Source from?

Here it is, don't know how much help it will be!

http://dl.dropbox.com/u/5635747/JLOKC12-3-Membership-Revised.indd

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 15, 2012 0
Adobe Community Professional ,
Aug 15, 2012

Copy link to clipboard

Copied

Something went wrong with your dropbox link; it opens as an html page full of code instead of a link to download the file.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 15, 2012 0
Mentor ,
Aug 15, 2012

Copy link to clipboard

Copied

I was able to d/l the ID file, but I am limited to CS5.5

IE9

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 15, 2012 0
New Here ,
Aug 15, 2012

Copy link to clipboard

Copied

Woops, forgot to zip it. Sorry. Thanks for all your help!

http://dl.dropbox.com/u/5635747/JLOKC12-3-Membership-Revised.indd.zip

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 15, 2012 0
New Here ,
Aug 15, 2012

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 15, 2012 0
LEGEND ,
Aug 15, 2012

Copy link to clipboard

Copied

I haven't look at your posted file, but a number of users of CS5 and CS5.5 have reported oddities after running the preview.

What happens if you either take a leap of faith and DON'T run the preview, or Undo after running it so it's as if it never happened, then run the merge?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 15, 2012 0
Mentor ,
Aug 15, 2012

Copy link to clipboard

Copied

After two InDesign lockups, it appears a custom page size has been applied to the live page, although I don't use the feature enough. Using the page tool informs me that the page size is 8.5 x 5.5; identicle to the document setup size...

It being a end product multiple page, I added a second page to the master spread, applied the masters to the live page, where abouts ID informed of the custom page size. I applied the Master Page size, 8.5 x 5.5 to the live page and corrected the offset merge...I think.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 15, 2012 0
Adobe Community Professional ,
Aug 15, 2012

Copy link to clipboard

Copied

It seems to be connected to the preview, so that if it was previewed even once it didn't run correctly. The only way I was able to get correct behavior out of the file was to create a brand new file, copy the text block into it, set up a new data-merge info and run without preview.

Any attempts to create a new file and preview before running resulted in offset records.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 15, 2012 5
New Here ,
Aug 15, 2012

Copy link to clipboard

Copied

Great! Guess InDesign is trying to teach me to not second-guess myself? Tried it as you suggested, SRiegel & Peter Spier, and it worked perfectly. I had seen posts suggesting errors similar to this in CS5, but didn't think the hijink would have transfered to CS6. Should have known better. Having quite a long document to merge (and a somewhat slow computer) made me reluctant to try it without the preview, but looks like it worked out.

Thanks to all of you for all your help and input! Much appreciated!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 15, 2012 0
New Here ,
Aug 24, 2012

Copy link to clipboard

Copied

I am having a similar issue with multiple records on a single page resulting in the entire page ending up offset when merged. Using InDesign 5.5.

I have tried starting over with a new file and skipping the preview step, but this doesn't seem to make a difference. My entire text block (with at the least the merges in the right place in the text) scoots over to the right and down a few inches. Any suggestions? I'm merging with an Excel csv file. Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 24, 2012 0
New Here ,
Sep 01, 2016

Copy link to clipboard

Copied

If you move the data fields from the master and place them into page 1, it solves the issue

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 01, 2016 0
Explorer ,
Nov 17, 2012

Copy link to clipboard

Copied

For what it's worth - here's what I dicovered ... the hard way 😕

I was having the same problem with the previewed and final text frames being off-set. After many hours of searching for answers and testing theories I remembered I started out the document with a landscape format - then changed to portrait. InDesign and/or the data merge utility still thought I was in landscape. I created a new document wich solved the problem!

I'm using CS6 ...

Dave

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 17, 2012 1
New Here ,
Aug 06, 2020

Copy link to clipboard

Copied

I have been struggling with this issue on more than one occasion and this is what worked for me! It was always random (it seemed) and no matter what I did, nothing worked. I am so glad I continued to read this thread! Thanks so much!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 06, 2020 0
New Here ,
May 30, 2013

Copy link to clipboard

Copied

I had a similar issue trying to print on Avery 5160 labels. (3 columns of 10 labels).  I fixed it by creating a new document and in the Page set up window for the new document (before it is opened), I made a custom size 8.5 x 11 instead of choosing it from the list, and I set up the margins and made 3 columns in the same window. Once the document opened, I drew a new text box, opened data source, and place fields in the new text box.  I went to Data merge and under the Multiple Record Layout tab, I put in exactly the same margin and column measurements that I used on the original page set up.  I clicked the preview box and it came up perfect! 

**These were the same measurements I used in the document that didn't work. The only difference was that in the failed attempt, I set up the margins and columns after I opened a standard 8.5 x 11 page.

I am using CS6.

Jenni

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 30, 2013 0
Community Beginner ,
Jun 09, 2014

Copy link to clipboard

Copied

So I noticed that no one put a clear cut answer on here, or I missed it if they did..

So here's my two cents since I had the same issue recently:

When you start a new document Facing Pages will be checked (see below)

Facing Pages1.JPG

Un-check this, set up your document and you should be good to go. Hope this helps someone in the future.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 09, 2014 4
Participant ,
Jul 09, 2014

Copy link to clipboard

Copied

I'm glad I found this thread. I've done multiple records many times. Most of the time it's postcards. But the last time I was pulling my hair out because of the offsetting. I managed to get it close enough to print, but today my new job is 9 postcards per sheet and it was offsetting way up off the page.

I started over with a new document and this time it was offsetting way off the right of the page. It's got to be a bug... it happens in CS5.5 and CS6.

The Facing Pages option didn't make a difference for me, but doing the settings blindly (no preview) did work. I put in guides so I could see that my addresses were in the correct spot and made sure to measure the space needed for rows, columns and margins so I put in the correct information before creating

I don't know what is the circumstance to cause this. Could it be my odd page size? It's 18.25x12.25 inches.

In the past, my post cards have been 4-up but to keep costs down we need to use larger sheets and do them 9-up.

Thanks again!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 09, 2014 0
Explorer ,
Jul 15, 2014

Copy link to clipboard

Copied

I'm having trouble also with multiple record merge on a large document (12 x 18"). I'm going to keep working on it. I've tried new documents, facing pages off,  no master items, no margins. I will report back after more experimentation.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 15, 2014 0
New Here ,
Sep 07, 2014

Copy link to clipboard

Copied

You right, I solved in these simple steps:

1) I copied the elements in the document

2) I created a new document (with "facing pages" checked)

3) Pasted the elements using "Paste in Place" function

It worked for me  🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 07, 2014 0
Explorer ,
Oct 23, 2014

Copy link to clipboard

Copied

It still does not work for me. I'm using CC 2014. It's unbelievable that Adobe can't repair this! Users have been complaining for at least 5 years.

I did a work around by creating a new document, NO preview, and generating layout in smaller pieces on multiple pages, then copying and pasting into another full size  document and popsitioning "by hand".

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2014 1
New Here ,
Jan 18, 2015

Copy link to clipboard

Copied

Lol. I thought I was the only one that still can't figure out how to solve it.

1. This is my setting for the canvas.

20150119-113446.jpg

2. As you can see, there's a margin of 6 mm around.

20150119-114213.jpg

3. After get the data on data merge, I try to generate. Note that I set 6 mm margin & a gap of 5.625 mm in between (will make a perfect 10 pcs on a page) >> then I click OK.

20150119-114240.jpg

4. Note that after generated, all the design had been moved down around 8.797 mm.

20150119-115112.jpg

After all the reading on this thread, after many attempt to fix it. NON I found help. The only closes I could get is it only move down about 2.8 mm only. But still moved. I have about 3000 pcs card need to be generated. That's 600 pcs (front & back)! I can't imagine opening one by one to adjust everything back to it's place.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 18, 2015 0
LEGEND ,
Jan 19, 2015

Copy link to clipboard

Copied

Make a new template the same page size, but NOT FACING PAGES. Copy your field placeholders and paste into the correct positions, then merge WITHOUT pressing the preview button.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 19, 2015 0
Community Beginner ,
Apr 21, 2015

Copy link to clipboard

Copied

I'm having the same issue today, for the first time... also on CC2014... It's hard to believe that this has been an issue for 5+ years and hasn't been fixed... seems like it should be a (relatively) simple one...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 21, 2015 0
New Here ,
Apr 27, 2015

Copy link to clipboard

Copied

Never had this issue till switching to CC2014 two weekends ago.  It seems as pointed out farther back that the facing pages setting messes stuff up.  New document with facing pages off resolved all my issues and I was able to preview successfully as well after doing so.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 27, 2015 0
Community Beginner ,
Apr 28, 2015

Copy link to clipboard

Copied

Thanks Charles... but, neither my "template" document or "merged" document have "facing pages" checked... so, that's not the issue... at least not for me...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 28, 2015 0
Valorous Hero ,
Apr 28, 2015

Copy link to clipboard

Copied

Have you tried making a new template, copying the placeholders to the new one, and without ever pressing the Preview button, merge to a new document?

Mike

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 28, 2015 0
Community Beginner ,
Apr 29, 2015

Copy link to clipboard

Copied

Hi Mike... yes, tried that as well... and it didn't work... for me, at least...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 29, 2015 0
Valorous Hero ,
Apr 29, 2015

Copy link to clipboard

Copied

Bummer. If you would like a second pair of eyes to look at an offending merge document, I would be happy to do so.

You would need to package and or ensure anything necessary for the document is in a ZIP file, uploaded to dropbox.com or the like, then PM me the download link.

Best, Mike

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 29, 2015 1
New Here ,
Jul 23, 2015

Copy link to clipboard

Copied

I figured out something that works for me! If you set the margins back to 0 after you preview then that time and every time after that you won't have the shifting issue anymore! It at least worked for me after trying everything people suggested and nothing working.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 23, 2015 0