Highlighted

Data merge with special characters on Mac

New Here ,
Jun 17, 2020

Copy link to clipboard

Copied

Hello,

 

I want to create business cards using the data merge option in InDesign. I am working on Mac.

 

Indesign wants comma seperated data. I experienced troubles exporting this comma seperated file in Excel or Numbers. They tend to be semicolon seperated only. However, the easiest workaround was using Google Docs which allows the export of such comma seperated file.

 

Then, when importing my data using data merge, any special character gets replaced with wrong characters. Like é or à get replaced with ÅÃ etc.

 

Google told me it is an encoding issue. I downloaded the text editor Sublime which allows encoding in UTF-8, UTF-16, etc. However, any encoding different than UTF-8 results in an error when importing the data.

 

Any advice on this?

Thanks!

stick with what works.

  • save your database *.numbers file
  • menu/file/export-to-csv
  • during the export process … window appears for advanced options … default text-encoding is unicode-utf8 … change to western-macos-roman
  • save as *.csv file

that's all there is to it … you surely don't need "sublime" or whatever it's called.

Topics

How to, Import and export

Views

159

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Data merge with special characters on Mac

New Here ,
Jun 17, 2020

Copy link to clipboard

Copied

Hello,

 

I want to create business cards using the data merge option in InDesign. I am working on Mac.

 

Indesign wants comma seperated data. I experienced troubles exporting this comma seperated file in Excel or Numbers. They tend to be semicolon seperated only. However, the easiest workaround was using Google Docs which allows the export of such comma seperated file.

 

Then, when importing my data using data merge, any special character gets replaced with wrong characters. Like é or à get replaced with ÅÃ etc.

 

Google told me it is an encoding issue. I downloaded the text editor Sublime which allows encoding in UTF-8, UTF-16, etc. However, any encoding different than UTF-8 results in an error when importing the data.

 

Any advice on this?

Thanks!

stick with what works.

  • save your database *.numbers file
  • menu/file/export-to-csv
  • during the export process … window appears for advanced options … default text-encoding is unicode-utf8 … change to western-macos-roman
  • save as *.csv file

that's all there is to it … you surely don't need "sublime" or whatever it's called.

Topics

How to, Import and export

Views

160

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Participant ,
Jun 17, 2020

Copy link to clipboard

Copied

What is the error message reported? Can you break down your data file to 2 lines (title and one data record) and test that. If the error appears too might you share it here? Which version of InDesign are you using? If you are in a hurry you might also try MyDataMerge for mac which adds many features to InDesigns data merge and solves a lot of common issues automatically (we use it regularly) including encoding. They have a free version also.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 18, 2020

Copy link to clipboard

Copied

I am on MacOS Mojave 10.14.6. running InDesign 2020 15.0.3.

 

The content of my txt file looks like this:

 

 

A, B, C, D
1é, 2à, 3è, 4ù

 

 

 

When choosing anything but UTF-8, I get "The data source cannot be opened. Confirm that the file exists nd you have the right to open it, then chose the select data source command again."

 

I would love to get it done without any extra Software. It is a very simple thing I want to do.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Jun 18, 2020

Copy link to clipboard

Copied

Is your file located on a network drive? Try to copy it to the desktop for testing purposes.

This usually occurs either if you don't have reading rights OR the file is opened by another application at the time InDesign tries to access it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 18, 2020

Copy link to clipboard

Copied

Hi and thanks for your message!

No, the file is located on my Desktop. I just tested the entire list of encoding options (UTF-16 LE BE with/out BOM) for some I get the error mentioned above, some others output the error "Impossible to decode certain characters of the content" (rough translation from my French InDesign).

 

I closed Sublime and even deselected the file in Finder just to make sure its not this bad boy that causes havoc.

 

Still, I am unable to merge any data that uses special characters like é, à, è etc.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Jun 18, 2020

Copy link to clipboard

Copied

stick with what works.

  • save your database *.numbers file
  • menu/file/export-to-csv
  • during the export process … window appears for advanced options … default text-encoding is unicode-utf8 … change to western-macos-roman
  • save as *.csv file

that's all there is to it … you surely don't need "sublime" or whatever it's called.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 18, 2020

Copy link to clipboard

Copied

You, @boots_n_patches, are my hero of the day.

 

This is exactly what there is to do: It works!

 

Thanks a million!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Participant ,
Jun 19, 2020

Copy link to clipboard

Copied

happy  to  share  my  knowledge … godspeed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...