Debug InDesign 2020 plug-in with XCode 9.2.0 won't launch InDesign

Explorer ,
Sep 04, 2020 Sep 04, 2020

Copy link to clipboard

Copied

I've been trying to debug a plug-in of mine to find out why it won't load but it won't launch InDesign 2020 when I click the Run button on Xcode. Nothing happens. I have done this with 2019, 2018, 2017, etc and the debugger always launches the app and I'm able to trap/step through things.  I tried the same test with one of the InDesign SDK test projects and get the same results. I've tried the option to select the app during the launch process and it brings up the modal to select the app, but once I do, the same results.

 

I've been scratching my head as to what is different between the other versions and InDesign 2020 or if I'm simply missing some permission issue. But not messages appear and nothing happens. Any ideas to what I'm missing?

 

Thanks for any suggestions I can try.

TOPICS
How to, SDK

Views

102

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Sep 05, 2020 Sep 05, 2020

Copy link to clipboard

Copied

In Xcode you specify InDesign as executable via

menu Product >> Scheme >> Edit Scheme … >> Run >> Info >> Executable

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 08, 2020 Sep 08, 2020

Copy link to clipboard

Copied

Yes, that is what I have done. This has worked in the past when I've worked with project plug-ins for InDesign CC 2019 and older but for some reason with InDesign CC 2020, Xcode is not launching the app when I click Run to debug it. As I mentioned in my initial post I have also tried the option in the Product >> Scheme >> Edit Scheme >> Run >> Info >> Executable to choose the app before running. When doing this and click Run, the modal comes up allowing me to pick the app but it still doesn't launch.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Sep 08, 2020 Sep 08, 2020

Copy link to clipboard

Copied

When you have specified the executable, is that reflected by the scheme dropdown (left from "My Mac) - the icon should become the purple ID square.

When you say "not messages appear" does that include the various logs via console.app?

Also, have a look at your .xcscheme deep within the .xcodeproj/xcuserdata/*.xcuserdata/xcschemes .

There should be an entry "<PathRunnable FilePath= …" pointing to the executable.

Compare that with a working scheme of a different InDesign version.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 29, 2020 Oct 29, 2020

Copy link to clipboard

Copied

LATEST

I got side tracked with some other projects and am now back trying to solve this issue.

 

I checked the console log and it only shows "Message from debugger: unable to attach"

I also checked the xcschemes files and aside from folder name and app name differences the <PathRunnable> information looks the same and correct.

I've tried manually launch the app and attach to the process and I get an error message that it "Could not attch to pid:..."

I'm wondering if there is something different about how the InDesign CC2020 was installed impacting permissions. It was installed through the CreateCloud process. I've tried adding permissions for all list user representation on my machine and give them read/write permission to the app but none of this has made a difference. I'll try re-installing the app and see if anything changes doing that.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines