Highlighted

Drop Cap creates a space

Community Beginner ,
Apr 28, 2020

Copy link to clipboard

Copied

Good day all,  I have a bit of a head scratcher using a drop cap on the 1st character of the 1st paragraph. I set up the paragraph style to use a character style.  Read through a whole bunch of articles of other drop cap issues but none seem to have the problem I do.

 

In indesign cc2020 it looks perfect, once exported the drop cap is there and it spans the corect number of line, the problem I am having is that it for some weird reason creates space between the dropcap of the word and the rest of the word.

 

Here is a picture of what it looks like in InDesign:

Dropcap in indesign.PNG

This is my settings for the character style:

Character Style for Dropcap.PNG

I left size and leading blank as most people say thats what I should do.  But then when I eport to ePub I get this space:

Dropcap with space.PNG

Please I dont know what else to try to make it fit right.  It is probably something simple I am mising but I am very new to Indesign and dont know what setting I am mising.  I also first thought maybe its just the reader I am using to test my exports as the reader also removes Old English but if I send it to my ipad it is back to old english, but it does the same on three different type of ipads.

Just an update, dont know if this is the only way to fix it. I removed the 1st line indent on the paragraph style and that seem to have fixed the problem. So now the drop cap is fixed but the paragraph indentation is now not the same but for the 1st letter of every chapter it might be fine.

Indent removed.PNG

TOPICS
EPUB, How to, Import and export, Publish online, Type

Views

478

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Drop Cap creates a space

Community Beginner ,
Apr 28, 2020

Copy link to clipboard

Copied

Good day all,  I have a bit of a head scratcher using a drop cap on the 1st character of the 1st paragraph. I set up the paragraph style to use a character style.  Read through a whole bunch of articles of other drop cap issues but none seem to have the problem I do.

 

In indesign cc2020 it looks perfect, once exported the drop cap is there and it spans the corect number of line, the problem I am having is that it for some weird reason creates space between the dropcap of the word and the rest of the word.

 

Here is a picture of what it looks like in InDesign:

Dropcap in indesign.PNG

This is my settings for the character style:

Character Style for Dropcap.PNG

I left size and leading blank as most people say thats what I should do.  But then when I eport to ePub I get this space:

Dropcap with space.PNG

Please I dont know what else to try to make it fit right.  It is probably something simple I am mising but I am very new to Indesign and dont know what setting I am mising.  I also first thought maybe its just the reader I am using to test my exports as the reader also removes Old English but if I send it to my ipad it is back to old english, but it does the same on three different type of ipads.

Just an update, dont know if this is the only way to fix it. I removed the 1st line indent on the paragraph style and that seem to have fixed the problem. So now the drop cap is fixed but the paragraph indentation is now not the same but for the 1st letter of every chapter it might be fine.

Indent removed.PNG

TOPICS
EPUB, How to, Import and export, Publish online, Type

Views

479

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 28, 2020 0
Community Beginner ,
Apr 28, 2020

Copy link to clipboard

Copied

Just an update, dont know if this is the only way to fix it. I removed the 1st line indent on the paragraph style and that seem to have fixed the problem. So now the drop cap is fixed but the paragraph indentation is now not the same but for the 1st letter of every chapter it might be fine.

Indent removed.PNG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 28, 2020 0
Most Valuable Participant ,
Apr 28, 2020

Copy link to clipboard

Copied

I think you are asking too much of InDesign when attempting to use it as an "epub editor". As you already noticed, this appears correctly in InDesign itself. It is the epub viewers' capabilities that lack the same (extensive) functionality that InDesign offers.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 28, 2020 0
Community Beginner ,
Apr 28, 2020

Copy link to clipboard

Copied

Not so, after the change I made it displays 100% correct in iBooks in my mac, the problem is neither with the epub reader or indesign, it was purely settings that I was aplying wrong

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 28, 2020 0