Highlighted

En Dash reverts back to hyphen when exported to PDF

Community Beginner ,
Sep 17, 2020

Copy link to clipboard

Copied

My InDesign (v 15.1.2) document clearly shows thtat I have inserted an en dash (–), but when I convert my document to an intereactive PDF, the en dash reverts back to a hyphen.  I generally create en dashes with the shortcut, but because of the issue I'm having, I also tried creating it via type> insert special character>hyphen and dashes>en dash. Does anyone have any idea why this is happening and how I can maintain the en dash in the PDF? Thanks in advance for any replies/solutions!

Adobe Community Professional
Correct answer by Randy Hagan | Adobe Community Professional

Don't know for sure, but my most common guess is that maybe a font you're using doesn't have one.

 

A good way to test would be to set something with the default Minion Pro font. I know that font has one. Save the test, then export an interactive PDF and see what happens. You may also want to go to the Advanced PDF Export Options and set and in the Fonts section change the Subset fonts when percent of characters used is less than: edit box to 0% and see if that makes a difference

 

Another thing you can try is to open the interactive PDF in Acrobat DC and try to use the Edit PDF tools to change it there and see if you get any different result. If the whole font is embedded, that might work; if it's subsetted, you likely will not.

 

Please let us know what happens and we'll go on from there.

 

Randy

TOPICS
Bug, How to, Import and export, Type

Views

74

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

En Dash reverts back to hyphen when exported to PDF

Community Beginner ,
Sep 17, 2020

Copy link to clipboard

Copied

My InDesign (v 15.1.2) document clearly shows thtat I have inserted an en dash (–), but when I convert my document to an intereactive PDF, the en dash reverts back to a hyphen.  I generally create en dashes with the shortcut, but because of the issue I'm having, I also tried creating it via type> insert special character>hyphen and dashes>en dash. Does anyone have any idea why this is happening and how I can maintain the en dash in the PDF? Thanks in advance for any replies/solutions!

Adobe Community Professional
Correct answer by Randy Hagan | Adobe Community Professional

Don't know for sure, but my most common guess is that maybe a font you're using doesn't have one.

 

A good way to test would be to set something with the default Minion Pro font. I know that font has one. Save the test, then export an interactive PDF and see what happens. You may also want to go to the Advanced PDF Export Options and set and in the Fonts section change the Subset fonts when percent of characters used is less than: edit box to 0% and see if that makes a difference

 

Another thing you can try is to open the interactive PDF in Acrobat DC and try to use the Edit PDF tools to change it there and see if you get any different result. If the whole font is embedded, that might work; if it's subsetted, you likely will not.

 

Please let us know what happens and we'll go on from there.

 

Randy

TOPICS
Bug, How to, Import and export, Type

Views

75

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 17, 2020 0
Adobe Community Professional ,
Sep 17, 2020

Copy link to clipboard

Copied

Don't know for sure, but my most common guess is that maybe a font you're using doesn't have one.

 

A good way to test would be to set something with the default Minion Pro font. I know that font has one. Save the test, then export an interactive PDF and see what happens. You may also want to go to the Advanced PDF Export Options and set and in the Fonts section change the Subset fonts when percent of characters used is less than: edit box to 0% and see if that makes a difference

 

Another thing you can try is to open the interactive PDF in Acrobat DC and try to use the Edit PDF tools to change it there and see if you get any different result. If the whole font is embedded, that might work; if it's subsetted, you likely will not.

 

Please let us know what happens and we'll go on from there.

 

Randy

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 17, 2020 1
Community Beginner ,
Sep 17, 2020

Copy link to clipboard

Copied

Further to my dilemma, the thumbnail in the document files shows an en dash but the moment I open the PDF–no en dash! Due to a deadline, I was forced to be creative. I saved the file under a different name, inserted a text frame for the first word, created a line with the line tool, then inserted another text frame for the second word. Backyard technology at its best!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 17, 2020 0
Adobe Community Professional ,
Sep 18, 2020

Copy link to clipboard

Copied

So, you haven't tried to remedy the original problem? And since you worked around this instance, you don't need any help anymore?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 18, 2020 0
Adobe Community Professional ,
Sep 18, 2020

Copy link to clipboard

Copied

It might be a font issue, not all font glyphs are embeddable in PDFs - it's unusual, I've never seen this before, so can only assume that the en dash is not part of the embeddable font set - so it reverts to the hyphen.

 

You could try changing the en dash font to something like Arial or Myriad Pro or something to see if that fixes it. Then you will know if it's a font or a program error.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 18, 2020 0