Highlighted

Endnotes in PDF exported from InDesign don't link to correct location

New Here ,
Dec 18, 2017

Copy link to clipboard

Copied

I've created a document with 390 endnotes. Within InDesign, linking from the endnote reference to the endnote text works perfectly.

However, when I export a PDF of the document, the linking doesn't work as expected. While both the endnote reference (in text) and endnote itself act as links, I get sent to the wrong spot (off by several pages).

Other links within the document (e.g., ToC, hyperlinks to text anchors, etc.) work as expected within the PDF.

These endnotes were created (mostly) when placing Word content into my InDesign document.

I'm using InDesign CC 13.0 x64 (Windows).

While exporting a PDF using a slightly modified version of the High Quality Print Preset, I have the following options checked:

  • Create Tagged PDF
  • Include Bookmarks
  • Include Hyperlinks

Having endnotes that don't link properly is an issue for me; any ideas? Do I need to somehow 'regenerate' the linking within InDesign?

Thanks,

Matthew

Adobe Community Professional
Correct answer by Laubender | Adobe Community Professional

Hi Matthew,

I can recreate the problem.

Did that with a document with two sections.


Section 1: Pages i to ix

Section 2: Pages 1 to 123

All endnote texts—I did not much—are on page 123.

The link of endnote 1 that is on the 10th page of the document—just the start of the second section—and is named "1" is going to the wrong page, to the page named "114". 9 pages short!

"114" is the 123rd page in the document.

Also a problem: The links in endnote texts!

My first endnote text links to page "i" instead of page "1".

That's definitely a bug!

Regards,
Uwe

Views

1.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Endnotes in PDF exported from InDesign don't link to correct location

New Here ,
Dec 18, 2017

Copy link to clipboard

Copied

I've created a document with 390 endnotes. Within InDesign, linking from the endnote reference to the endnote text works perfectly.

However, when I export a PDF of the document, the linking doesn't work as expected. While both the endnote reference (in text) and endnote itself act as links, I get sent to the wrong spot (off by several pages).

Other links within the document (e.g., ToC, hyperlinks to text anchors, etc.) work as expected within the PDF.

These endnotes were created (mostly) when placing Word content into my InDesign document.

I'm using InDesign CC 13.0 x64 (Windows).

While exporting a PDF using a slightly modified version of the High Quality Print Preset, I have the following options checked:

  • Create Tagged PDF
  • Include Bookmarks
  • Include Hyperlinks

Having endnotes that don't link properly is an issue for me; any ideas? Do I need to somehow 'regenerate' the linking within InDesign?

Thanks,

Matthew

Adobe Community Professional
Correct answer by Laubender | Adobe Community Professional

Hi Matthew,

I can recreate the problem.

Did that with a document with two sections.


Section 1: Pages i to ix

Section 2: Pages 1 to 123

All endnote texts—I did not much—are on page 123.

The link of endnote 1 that is on the 10th page of the document—just the start of the second section—and is named "1" is going to the wrong page, to the page named "114". 9 pages short!

"114" is the 123rd page in the document.

Also a problem: The links in endnote texts!

My first endnote text links to page "i" instead of page "1".

That's definitely a bug!

Regards,
Uwe

Views

1.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Dec 18, 2017

Copy link to clipboard

Copied

Hi Matthew,

hm… Do you see any pattern of the offset of pages you are sent to?

E.g. Is the offset of pages always the same?

Or does it work with the first endnote and after some other endnotes you suddenly see an offset?

Are there tables in your document?

Are there endnotes in tables in your document?
Can you see a difference in offset with endnotes before and after a table?

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Dec 18, 2017

Copy link to clipboard

Copied

Hi there,

Given your question, I mapped out a subset of links:

Endnote 1 - expected to link to page 112, got 103 (-9 pages)

Endnote 50 - expected to link to page 114, got 105 (-9)

Endnote 100 - expected to link to page 116, got 107 (-9)

Endnote 150 - expected to link to page 117, got 108 (-9)

Endnote 200 - expected to link to page 119, got 110 (-9)

Endnote 250 - expected to link to page 121, got 112 (-9)

Endnote 300 - expected to link to page 123, got 114 (-9)

Endnote 350 - expected to link to page 124, got 115 (-9)

Endnote 390 - expected to link to page 126, got 117 (-9)

Although this is just a sample, it shows a pretty consistent nine (9) page offset. That nine page offset is the same offset prior to starting Arabic page numbering (I have title page, tables of contents/figures/etc., part title page, etc.). This seems like an odd coincidence.

Yes, I use tables in the document but they don't happen to contain endnotes. There doesn't appear to be a change in (nine page) offset before or after tables are used.

Given that nine page offset, is there something I'm doing wrong with respect to setting up the section numbering? Given it works properly within InDesign, I thought I was all set.

Thanks,

Matthew

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Dec 18, 2017

Copy link to clipboard

Copied

In the interest of being thorough, I just updated to 13.0.1 and the problem persists.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Dec 18, 2017

Copy link to clipboard

Copied

No coinincidence, I think. And no, you did nothing wrong. At least all linking is working in the document.  Maybe a bug?


What is the format of numbering in the first 9 pages of your document?

Is it the same like the one you do after starting the second section with Arabic page numbering?

Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Dec 18, 2017

Copy link to clipboard

Copied

I'm using three different master spreads to support no page numbering, Roman numbering (i, ii, iii, etc.), and Arabic numbering (1, 2, 3, etc.).

The first nine pages are a mix of no page numbering (e.g., title page, part title page; using B-Master) and Roman numbering (e.g., tables, acknowledgements, etc.; using C-Master).

Thanks,

Matthew

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Dec 18, 2017

Copy link to clipboard

Copied

Hi Matthew,

I can recreate the problem.

Did that with a document with two sections.


Section 1: Pages i to ix

Section 2: Pages 1 to 123

All endnote texts—I did not much—are on page 123.

The link of endnote 1 that is on the 10th page of the document—just the start of the second section—and is named "1" is going to the wrong page, to the page named "114". 9 pages short!

"114" is the 123rd page in the document.

Also a problem: The links in endnote texts!

My first endnote text links to page "i" instead of page "1".

That's definitely a bug!

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Dec 18, 2017

Copy link to clipboard

Copied

Thanks for reproducing it Uwe! I'll log a bug.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Dec 18, 2017

Copy link to clipboard

Copied

Hi Matthew,

what you could do to workaround the problem:

Do two documents:
Doc A with named pages "i" to "ix".

Doc B with named pages "1" to "126" (I assume your last page in the document is named "126")

Export one PDF from each document.

Open the PDF from doc B with pages named "1" to "126" in Acrobat Pro (DC).

Insert the PDF from doc A with pages named "i" to "ix" with Acrobat's Organize Pages functionality.

That will keep the links intact.

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Dec 18, 2017

Copy link to clipboard

Copied

Laubender  wrote

… That will keep the links intact.

At least the endnote links. Did not test with TOC or other links that go to pages.

Indeed a linked TOC could be a problem… ( Sigh. )

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Dec 18, 2017

Copy link to clipboard

Copied

Thanks for the suggestion of the workaround – the TOC seems to work, but I need to test more to build my confidence that everything is as expected.

I'd guess the linking is done via unique tag within the document DOM and this is why it works when they're combined post-export.

Thanks again,

Matthew

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Dec 18, 2017

Copy link to clipboard

Copied

Do you have a link to the bug report so I can vote for fixing it?

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Dec 18, 2017

Copy link to clipboard

Copied

Found the link and voted:

endnote – Adobe InDesign Feedback

Thank you for reporting.

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Feb 19, 2018

Copy link to clipboard

Copied

This does not work for me. My TOC is created using Layout > Table of Contents with styles. Thoughts?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Dec 18, 2017

Copy link to clipboard

Copied

Hi,

Yes we are able to reproduce the issue. Thanks for reporting it.

@Uwe: Thanks for narrow downing it and finding the root cause,

-Aman

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 31, 2018

Copy link to clipboard

Copied

I have a solution! The document always has to start on page one (no chapters). Create empty pages if you need, and then delete them in the pdf. All endnotes work for me now after doing that.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Feb 19, 2018

Copy link to clipboard

Copied

Now that the links issue has been resolved, thank you everyone ...

Is it possible to change the behaviour of the link in the endnote reference (in text) to link directly to the endnote itself, instead of the page where it resides. If I'm zoomed in 200% and click on endnote #1 in the text, it links to the Endnote PAGE and zooms out to "fit window". I want it to link directly to the endnote itself at the same viewing percentage. Make sense?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 29, 2019

Copy link to clipboard

Copied

I'm assuming this issue hasn't been resolved. I'm working on a document with endnotes and once exporting to PDF, the links don't work. I'm using InDesign 14.0.2.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 29, 2019

Copy link to clipboard

Copied

Hi Lorraine26 ,

can you tell more about your document?

Are there several sections in the Pages panel with different numbering of the pages?

What exactly goes wrong?

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...