Highlighted

First character of story editor and Notes panel displays incorrectly

Adobe Community Professional ,
Nov 07, 2017

Copy link to clipboard

Copied

In both the Story Editor and the Notes panel, the first character displays incorrectly. It doesn't matter what font I choose. It has been this way for along time, but I don't see this in other people's screenshots of their Story Editor panels. Any ideas?

Screen Shot 2017-11-07 at 1.06.56 PM.png

Most Valuable Participant
Correct answer by Jongware | Most Valuable Participant

Yeah that screams "bug! bug!" There are no characters that move along with a resizing text window.

Updated to 2018 recently?

Views

1.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

First character of story editor and Notes panel displays incorrectly

Adobe Community Professional ,
Nov 07, 2017

Copy link to clipboard

Copied

In both the Story Editor and the Notes panel, the first character displays incorrectly. It doesn't matter what font I choose. It has been this way for along time, but I don't see this in other people's screenshots of their Story Editor panels. Any ideas?

Screen Shot 2017-11-07 at 1.06.56 PM.png

Most Valuable Participant
Correct answer by Jongware | Most Valuable Participant

Yeah that screams "bug! bug!" There are no characters that move along with a resizing text window.

Updated to 2018 recently?

Views

1.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 07, 2017 0
Most Valuable Participant ,
Nov 07, 2017

Copy link to clipboard

Copied

It's overlaid with the Not In This Font! character. I see several other occurrences as well, not just at the start of each line. Could there be an invisible character in front in your regular text? You might see the text cursor stutter if you move over it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
Adobe Community Professional ,
Nov 07, 2017

Copy link to clipboard

Copied

Nope, there are no invisible characters. What's so weird is that it is dependent upon the width of the story editor window, not where the text sits in the text frame.

Screen Shot 2017-11-07 at 1.19.19 PM.pngScreen Shot 2017-11-07 at 1.18.44 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
Most Valuable Participant ,
Nov 07, 2017

Copy link to clipboard

Copied

Yeah that screams "bug! bug!" There are no characters that move along with a resizing text window.

Updated to 2018 recently?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
Adobe Community Professional ,
Nov 07, 2017

Copy link to clipboard

Copied

Not yet. I need to. But my operating system is apparently too old, so I need to update that as well. But not in the middle of a bunch of big projects... Perhaps updating to 2018 will fix it...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
Adobe Employee ,
Nov 07, 2017

Copy link to clipboard

Copied

Hi,

No such bug is fixed with CC2018.

Please report it here Adobe InDesign Feedback so that it can be prioritized correctly for fixing it in coming releases

Yes this character which looks like a missing glyph sumbol comes in both story editor and notes panel. I have seen it mostly in InCopy though. Within InDesign it occurs often when working with story editor for tables...

-Aman

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
Adobe Community Professional ,
Nov 07, 2017

Copy link to clipboard

Copied

Oh, apparently I already did: story editor – Adobe InDesign Feedback

Will you vote for this?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
Adobe Community Professional ,
Nov 07, 2017

Copy link to clipboard

Copied

Very strange. I look at the Story Editor pretty frequently in CC 2017 and CC 2018 and I don't think I've ever seen that missing glyph symbol. It may be hard to pin down.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
Adobe Community Professional ,
Nov 07, 2017

Copy link to clipboard

Copied

The strange this is that it also happens on the other computer in my office... My assistant's computer.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
Most Valuable Participant ,
Nov 07, 2017

Copy link to clipboard

Copied

Kelly, is it related to the Story Editor font? Or do you see it with all fonts?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
Adobe Community Professional ,
Nov 07, 2017

Copy link to clipboard

Copied

Font choice doesn't matter. This is Proximo Nova.

Screen Shot 2017-11-07 at 1.46.45 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
Adobe Employee ,
Nov 07, 2017

Copy link to clipboard

Copied

Hi,

It is not a missing glyph(not sure though) symbol. It just looks like one. Since this symbol which looks like a missing glyph symbol does not change with font it is hard to categorize it as a notedef glyph(Havent explored changing the story editor font though)

Shows up frequently when opening story editor to work on a table cell

-Aman

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
Adobe Community Professional ,
Nov 07, 2017

Copy link to clipboard

Copied

Hi Aman,

I had this symbol showing up in several versions of InDesign.
I thought this was fixed with CC 2017.1.

See here:

Re: Strange icons appear in file - how to get rid of them?

Hm. Just tested a Note object and a table with the latest CC 2018 version and indeed there is an issue.

I can see it in the Notes Panel:

SpecialCharacterInNotesPanel.png

I can see it extensively in the Story Editor Window:

SpecialCharacterInStoryEditor.png

So the bug is back…

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2017 0
Contributor ,
Apr 11, 2018

Copy link to clipboard

Copied

This has been driving me nuts for a week. Windows is fine, it only appears on a Mac. I'm running InDesign 13.1 on OS 10.13.4.

As far as I can tell, freshly-created documents are OK; the weird grey symbols only appear when I insert a table, and immediately appear when I do. The following screenshots are taken from from new document created just after trashing preferences:

Screen Shot 2018-04-11 at 14.38.54.png

I insert a table and Bingo! — there they are again:

Screen Shot 2018-04-11 at 14.39.14.png

After resizing the Story Editor window, the symbols stay on the left:

Screen Shot 2018-04-11 at 14.42.17.png

Jeremy

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 11, 2018 1
Adobe Community Professional ,
Apr 11, 2018

Copy link to clipboard

Copied

So glad to find out what triggers it! I have wondering for years. Apparently Adobe says they've fixed it> See the discussion here: story editor – Adobe InDesign Feedback

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 11, 2018 0
Adobe Community Professional ,
Apr 11, 2018

Copy link to clipboard

Copied

Hi Jeremy,
just to be clear on this: In the moment you are adding a table that strange character is back?
Or was this table pasted from a legacy version document opened with CC 2018.1 ?

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 11, 2018 0
Contributor ,
Apr 11, 2018

Copy link to clipboard

Copied

Everything brand new, nothing pasted in. Just "Insert Table" with the Story

Editor open (& invisibles turned on, of course).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 11, 2018 0
Adobe Employee ,
Apr 11, 2018

Copy link to clipboard

Copied

Hi,

Yes we have fixed this issue.

Maybe the bug is still reproducible under certain scenarios.

To help us narrow down, please try out the following...

1. Clean both InDesign cache and preference filesTroubleshooting 101: Replace, or "trash" your InDesign preferences

2. Work on a new document

3. Recheck that the version of InDesign is 13.1

If you still face the issue please let us know...

-Aman

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 11, 2018 0
Contributor ,
Apr 11, 2018

Copy link to clipboard

Copied

I get the bug immediately after trashing preference files and creating a new document. But I don't know how to clear the InDesign cache.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 11, 2018 0
Adobe Community Professional ,
Apr 11, 2018

Copy link to clipboard

Copied

Hi Jeremy,

I recently trashed preferences and cache of InDesign CC 2018.1 13.1.0.76.

And I can see the issue as you described it here!

Maybe I should reinstall InDesign without migrating preferences from previous versions of InDesign?

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 11, 2018 0
Adobe Community Professional ,
Apr 11, 2018

Copy link to clipboard

Copied

Laubender  wrote

… Maybe I should reinstall InDesign without migrating preferences from previous versions of InDesign?

Just did this. But something's went wrong. InDesign migrated old preferences from version CC 2017.1 and I did not tell it to do that.

And of course I still can see the issue Jeremy is seeing…

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 11, 2018 0
Contributor ,
Apr 11, 2018

Copy link to clipboard

Copied

That seems to have worked, thanks very much! Before now, I was deleting preference files only, but this time I deleted the entire contents of the folder "InDesign 13.0" in "Caches".

I'm a little surprised that that folder is not called "InDesign 13.1", as I am definitely running 13.1:

Screen Shot 2018-04-11 at 16.30.00.png

But in any case it seems to be working well now. Thanks again — Jeremy

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 11, 2018 0
Contributor ,
Apr 11, 2018

Copy link to clipboard

Copied

Actually, wait. No. They're back!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 11, 2018 0
Adobe Employee ,
Apr 11, 2018

Copy link to clipboard

Copied

Hi Uwe,

Yes we are aware of a scenrio wherein InDesign migrates preferences on upgrade even when asked to not do so... when updating via Creative Cloud application.

@Jeremy:Please help us reproduce this issue with some concrete steps/videos.

-Aman

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 11, 2018 0
Contributor ,
Apr 11, 2018

Copy link to clipboard

Copied

Hi Aman,

Here's what I just did:

I cleared the cache, trashed preferences, and then uninstalled InDesign.

Then I deleted any files I could find whose filename mentioned "InDesign" in my Users>myname>Library>Caches folder, in my Users>myname>Library>Preferences folder, and in my Users>myname>Library>Preferences>Adobe folder.

Then I did a restart of my Mac.

Then I re-installed InDesign. Then opened it for the first time. I chose "Create new...", "Letter" size by default, then in the new document used the text tool to drag a new text frame, and wrote a line of text, followed by a paragraph return.

I opened the Story Editor by pressing cmd+Y, made hidden characters visible with alt+cmd+I, and all seemed well up to that point.

Then from the menu at the top I chose Table>Insert Table..., accepted defaults, and: there are those weird symbols again!

If I get time tomorrow, I'll try this after a clean install of Mac High Sierra (I do this quite often, so it's no big deal to me).

Best wishes — Jeremy

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 11, 2018 0
Adobe Employee ,
Apr 11, 2018

Copy link to clipboard

Copied

Hi,

Thanks for the information! 

We will try at our end and then update the thread with our findings...

I dont think doing a restore of OS would help solve the problem for you, and you might as well not do it.  Clearing cache and preferences and doing a fresh install of InDesign simulates the same environment.

-Aman

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 11, 2018 0
Explorer ,
Aug 21, 2018

Copy link to clipboard

Copied

The problem went away for a while (my post below) but it's back. I can post a note only via the method I mentioned of loading the clipboard and pasting into a new note the instant after it popped up.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 21, 2018 0
Adobe Community Professional ,
Aug 21, 2018

Copy link to clipboard

Copied

Feel free to use my ExtendScript ( JavaScript ) in reply 27.

You are welcome.

Best,
Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 21, 2018 0
Explorer ,
Aug 21, 2018

Copy link to clipboard

Copied

It works, thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 21, 2018 0
Explorer ,
Jun 06, 2018

Copy link to clipboard

Copied

Using InDesign 13.1, macOS 10.13.4. My files began life as new documents in 13.1, but I had been using InDesign for some years.

When I tried to make a new note, the little Notes dialog came up for a split second with a missing-glyph X as the first character, then the typing area turned white and I could not type into it at all. I could create a new note only by loading the clipboard and pasting into a new note the instant after it popped up.

The trashing of prefs and caches -- whether when starting InDesign or manually in Finder -- partly did the trick for new files, but the missing glyph problem remained in old. But I found I could start a new document, then copy the entire old content and paste in the new, and for now *part* of the problem is fixed: While the missing glyph is visibly there, at least now the Notes dialog is stable and I can type in it.

And something that didn't work was saving as an IDML and opening that.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 06, 2018 0
Adobe Community Professional ,
Jun 07, 2018

Copy link to clipboard

Copied

Hi,

just tested this with my Windows version of CC 2018.1 13.1.0.76: Found no problems doing a new note.

And also the special character is not showing up. The problem with the special character must be a Mac OS X problem.

Will test later with my Mac OS X version of inDesign CC 2018.1 on OS X 10.11.6.

In the meanwhile you could do a new note with the script below. It's written in ExtendScript ( JavaScript ).

Simply select an insertion point and run the script:

( function()

{

    // Do nothing, if:

    if( app.documents.length == 0 ){ return };

    if( app.selection.length != 1 ){ return };

    if( app.selection[0].constructor.name != "InsertionPoint" ){ return };

  

    var text = prompt( "Add text of your Note here:" , "Text for note.",  "Type or paste text for your Note here:" );

    if( text == null ){ return };

  

    var note = app.selection[0].notes.add();

    note.texts[0].contents = text;

}() )

Regards,
Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 07, 2018 1
Explorer ,
Oct 27, 2018

Copy link to clipboard

Copied

Still a bug in 2019 InDesign. Sheesh.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 27, 2018 0
New Here ,
Sep 16, 2020

Copy link to clipboard

Copied

This bug is still present in InDesign 2020. As soon as i insert a new table, the icons appear in story view. 

InDesign-2020-Story-View.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 16, 2020 0