Fix TOC Text Frame Style: align chapter level with text frame border

Community Beginner ,
Nov 06, 2020 Nov 06, 2020

Copy link to clipboard

Copied

Using the TOC creation window to make my TOC, there is a problem with vertical alignment of some of the text:

 

the first level (chapter level) text is always partially above the text frame, whereas the second level text is within the top text frame border (see image below).  I have reviewed Style Options > Text Frame General Options > Inset Spacing = 0.0in for all sides. And neither Gutter nor Vertical Justification fixes it. No other text frames in any of my docs have this issue. It only affects Level 1 text, and repeats throughout the TOC. Adjustments to the Inset Spacing affects all other text proportionally as well (thus, not solving the issue).

 

Does anyone else have this problem? Any idea why this happens and (more importantly) how to fix?

 

ID TOC Text Frame Screenshot.jpg

TOPICS
Bug, How to

Views

73

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Community Beginner , Nov 06, 2020 Nov 06, 2020
Solved my own question--thanks, Me! Here is a similar post that got me going in the right direction:https://community.adobe.com/t5/indesign/spacing-at-top-of-text-box/td-p/9177570?page=1 My own observations and fix:When I originally created the TOC using the TOC creation tool/window, without my knowledge, the Level 1 Text set Baseline Shift = 7pt. Now, I set all TOC levels = 0pt. Then, I went through and adjusted line widths using the Paragraph Styles instead to my liking. I also made sure that,...

Likes

translate

Translate

Translate
Community Beginner ,
Nov 06, 2020 Nov 06, 2020

Copy link to clipboard

Copied

Solved my own question--thanks, Me!

 

Here is a similar post that got me going in the right direction:

https://community.adobe.com/t5/indesign/spacing-at-top-of-text-box/td-p/9177570?page=1

 

My own observations and fix:

When I originally created the TOC using the TOC creation tool/window, without my knowledge, the Level 1 Text set Baseline Shift = 7pt. Now, I set all TOC levels = 0pt. Then, I went through and adjusted line widths using the Paragraph Styles instead to my liking.

 

I also made sure that, for all TOC frames, in Object Style > Style Options > Text Frame Baseline Options > Offset = Ascent; 0in.

 

All looks good now!

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines