Highlighted

Font and File issues

New Here ,
Apr 10, 2020

Copy link to clipboard

Copied

Each year when I update indesign to the newest version I am faced wit issues with my previously saved files. We are saving a weekly document, each week we package the final so all the font and links are in one nice neat folder. After running the update, any file I created in a previous version is "converted" and needs to be resaved (should I want to) this isn't my main problem today, just thought I'd put it out there and see if anyone had a quick fix. The real problem is fonts. After upgrading to CS 2020 I started having intermittent issues with "missing fonts" - sometimes I'd open a file and they would be there, sometimes not. I chatted with support and they had me, trash preferences, trash cache, delete all fonts that had any conflict (in Fontbook) and so forth. So now here's what happens.

If I open a file that has been created in anything earlier than 2020 then there are fonts missing, if I take any text block that shows a missing font (highlighted in pink) and bring it into a current CS2020 document, when I paste it the font is now found, no issue. I need help to figure out why the fints are "missing" in one document but not another. Again, all the files are packaged through ID and have a fonts and links folder. 

Machine specifics:

Mac 10.14.6

All files are saved on an external hard drive (not sure if this makes a difference but t shouldn't).

An additional note on the problem, if I open an older file, that shows missing fonts, and try and use "find font" to swap teh fonts out it will not let me select the same font to replace it. the program allows me to select it but when I click on <replace all> it does nothing.

Thank you for any help.

Topics

Bug, Type

Views

125

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Font and File issues

New Here ,
Apr 10, 2020

Copy link to clipboard

Copied

Each year when I update indesign to the newest version I am faced wit issues with my previously saved files. We are saving a weekly document, each week we package the final so all the font and links are in one nice neat folder. After running the update, any file I created in a previous version is "converted" and needs to be resaved (should I want to) this isn't my main problem today, just thought I'd put it out there and see if anyone had a quick fix. The real problem is fonts. After upgrading to CS 2020 I started having intermittent issues with "missing fonts" - sometimes I'd open a file and they would be there, sometimes not. I chatted with support and they had me, trash preferences, trash cache, delete all fonts that had any conflict (in Fontbook) and so forth. So now here's what happens.

If I open a file that has been created in anything earlier than 2020 then there are fonts missing, if I take any text block that shows a missing font (highlighted in pink) and bring it into a current CS2020 document, when I paste it the font is now found, no issue. I need help to figure out why the fints are "missing" in one document but not another. Again, all the files are packaged through ID and have a fonts and links folder. 

Machine specifics:

Mac 10.14.6

All files are saved on an external hard drive (not sure if this makes a difference but t shouldn't).

An additional note on the problem, if I open an older file, that shows missing fonts, and try and use "find font" to swap teh fonts out it will not let me select the same font to replace it. the program allows me to select it but when I click on <replace all> it does nothing.

Thank you for any help.

Topics

Bug, Type

Views

126

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Apr 26, 2020

Copy link to clipboard

Copied

When an InDesign document resides in a Package folder with the accompanying Fonts folder, any fonts in there will be automatically (and temporarily) activated when the InDesign file is opened ! You can even see them in the Fonts menu list, separated in a section. A new or old file outside of this Package folder has no access to these fonts, but only the installed or activated Adobe CC fonts. Might that be confusing your analysis ?

 

Schermafbeelding 2020-04-26 om 15.31.03.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 26, 2020

Copy link to clipboard

Copied

I think you misunderstood the problem.  When I open a pacakged file, with the fonts folder present, some fonts still show up as "missing". Yes, I checked to see if the fonts were in the fonts folder, yes they are. Additioanlly if I close that document, then reopen it sometimes the fonts are miraculously found. I can replicate this all day long. I spent two hours with an Adobe specialist on my computer last week and he could not figure it out. He said he was going to escalate the problem (five days ago) and I never heard back.  So when you say, "any fonts in there will be automatically (and temporarily) activated when the InDesign file is opened !" I agree this should happen, but it is not happening. Fresh install, fresh preferences, latest update, multiple different files, etc.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Apr 26, 2020

Copy link to clipboard

Copied

I just have to go from what you're writing here, and verify some options and scenarios.

Here are some other changes to investigate.

Did you try creating a new user account on your Mac (for the sake of testing), bring such a package over to that account and see if the same trouble is occurring ? If yes, then there's some conflict or corrpution in the system, the application or the document. If not, then there's something fishy with the Library of the original user account.

Can you narrow the problem down to a small file, maybe with just one page and perhaps a single text frame and font ?

You can also send a zipped folder via WeTransfer to my email: peter@studea.nl

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...