Highlighted

Fonts missing on a shared document.

New Here ,
Sep 15, 2020

Copy link to clipboard

Copied

Hi all!

I have a recurring error that's been bugging me for a while now.

 

Mac Catalina and cc updated to the latest version.

Sometimes, in a specific file that gets constantly updated, indesign won't see some computer fonts. Just to clarify, they aren't user fonts. Basic stuff like Baskerville, Helvetica Neue, Times.

It happens on every terminal we use (three different macs). Not always, but at some point if I work at it for a few hours it'll pop up.

 

One workaround I had is to disable one of the incriminated fonts from the Computer Fonts, and enable it on the User ones. And viceversa. Indesign will be happy for a while.

Using find fonts/replace all doesn't do a thing. I can see the incriminated fonts in the system fonts from the find fonts window, but nothing happens when I replace them.

I have a few paragraph styles defined, I tried changing their fonts to see what happens, but the issue remains.

 

I'm at a loss.

 

I'm pretty sure the file is the problem, something hasn't been done the proper way, but I don't know wheter there's a routine to try and eradicate the problem once and for all.

 

How do we proceed?

 

Regards,

EL

Most Valuable Participant
Correct answer by BobLevine | Most Valuable Participant

Do you have a document fonts folder in the same folder as the InDesign file? If so, try moving it out.

TOPICS
Bug, Type

Views

46

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Fonts missing on a shared document.

New Here ,
Sep 15, 2020

Copy link to clipboard

Copied

Hi all!

I have a recurring error that's been bugging me for a while now.

 

Mac Catalina and cc updated to the latest version.

Sometimes, in a specific file that gets constantly updated, indesign won't see some computer fonts. Just to clarify, they aren't user fonts. Basic stuff like Baskerville, Helvetica Neue, Times.

It happens on every terminal we use (three different macs). Not always, but at some point if I work at it for a few hours it'll pop up.

 

One workaround I had is to disable one of the incriminated fonts from the Computer Fonts, and enable it on the User ones. And viceversa. Indesign will be happy for a while.

Using find fonts/replace all doesn't do a thing. I can see the incriminated fonts in the system fonts from the find fonts window, but nothing happens when I replace them.

I have a few paragraph styles defined, I tried changing their fonts to see what happens, but the issue remains.

 

I'm at a loss.

 

I'm pretty sure the file is the problem, something hasn't been done the proper way, but I don't know wheter there's a routine to try and eradicate the problem once and for all.

 

How do we proceed?

 

Regards,

EL

Most Valuable Participant
Correct answer by BobLevine | Most Valuable Participant

Do you have a document fonts folder in the same folder as the InDesign file? If so, try moving it out.

TOPICS
Bug, Type

Views

47

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 15, 2020 0
Most Valuable Participant ,
Sep 15, 2020

Copy link to clipboard

Copied

Do you have a document fonts folder in the same folder as the InDesign file? If so, try moving it out.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2020 1
New Here ,
Sep 15, 2020

Copy link to clipboard

Copied

Thanks bob,

it does seem the problem is at bay for now.

Should I not export the used fonts when creating a package then?

 

I will keep you updated if the situation changes.

Thank you again,

EL

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2020 0
Most Valuable Participant ,
Sep 15, 2020

Copy link to clipboard

Copied

There's no reason not to, but there can be conflicts sometimes so this is just a good troubleshooting step.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 15, 2020 1